Pyramid incompatible with M-Audio?


#1

Just hooked up the Pyramid for the first time with an M-Audio Keystation 61 MIDI Keyboard - I have read everything, the manual(s), other posts in this forum… and I think i have a good grasp on the Pyramid MIDI settings.

No matter what I do, I cannot get Pyramid to recognize MIDI IN from the M-Audio keystation (plugged direction into Pyramid’s MIDI In). No blinking MIDI IN arrow… nothing.

There were two posts about keystation+pyramid on this forum, and both are unresolved… one person bought another keyboard which solved the problem (seriously tho) and the other person said the USB power supply was the issue… my Keystation gets power right from the wall though…

Any big brains out there got the answer?


-M-Audio Keystation 61’s MIDI connected directly to Pyramid’s Midi In
-All sending on correct channels - all settings appropriate (and I’ve tried every setting)
–>Pyramid does not recognize any MIDI data whatsoever
-M-Audio keyboard works as it should with all my other gear… Moog, DSI, Roland…
-Pyramid works as it should with all other synths with MIDI In+Out ports.


MIDI In problem with Moog Grandmother
#2

TBH, I’m not sure if the Pyramid supports a directly connected USB keyboard. I use a slightly older Axion 49 and it works fine but both Pyramid and keyboard plug into a powered USB hub.

One way you can determine if the Pyramid is sending or receiving MIDI is by referring to the Pyramid display panel. The panel provides MIDI status In & Out via arrow-shaped icons. There’s four icons each showing MIDI USB In & Out plus DIN A & B Out. So if the keyboard is sending MIDI out to the same MIDI channel on the Pyramid then you would see the “In” arrow flash every time a key is pressed, knob turned, slider moved, etc.

Refer to page 3 on the Quickstart doc: http://squarp.net/06_pic_overview/MANUAL/PYRAMID_SEQUENCER_USER_GUIDE_V2.pdf

-Dean


#3

You basically ignored everything the OP said.

  • They’re using the MIDI in port, not USB
  • They are looking for the blinking MIDI input arrow and it’s not showing

#4

So where’s your contrubution to help the OPs issue, besides pointing out my errors?


#5

My keyboard is also connected to mio10 thru Midi A port and it works fine. Of course it’s not a Keystation controller


#6

I have the same problem with my Moog Grandmother. Pyramid is not accepting the MIDI Data from that device. But Grandmother can communicate with any other usual device without a flaw.
I think there is a bug in the PyraOS 3.1.
Contact Squarp directely and tell them of this specific incompatibility: https://squarp.net/contact
Myabe it helps (I wrote too).

See the thread about the Grandmother MIDI problem:


#7

Thank you for the suggestion - sent them a message. Will report back here if/when I find a solution ~
any other ideas everyone?


#8

I just posted this on a thread about problems with the Grandmother. I dunno if it’s the same problem on the M-Audio keyboard, but it’s worth trying.


I have a solution for you! I had this precise problem with a Waldorf KB37 and then had it again when I got my Grandmother.

The MIDI chip in the Pyramid has some issues with certain other chips and they won’t communicate.

Jean @ Squarp told me:

“Indeed, it’s seems it’s an electric incompatibility between these two devices. It’s the first time I heard of this issue with a Waldorf product.”

As a solution, you can use a MIDI THRU box, for example the MIDI SOLUTION QUADRA THRU.

I’m using the MIDISolutions Merger and it works great with both the KB37 and the Grandmother:
http://midisolutions.com/prodmrg.htm



#9

Right, that more or less confirms my guess in MIDI In problem with Moog Grandmother -thread but by the sound of it, this is a hardware level thing that they wont be able to fix with a firmware update. Thanks for sharing that reply here.

Anybody with a oscilloscope so we could declare the guilty part? :wink:


#10

I have the same trouble using a keystep. It is driving me crazy.
Basically all I have atm is keystep midi out to midi in on the pyramid. Then midi out (port a) from pyramid to midi in on the virus. Again, midi channels are the same on all devices.
How hard should such a simple thing be?
Currently waiting for a reply from Squarp.

Someone mentioned a midi thru box. Could you please explain what I need to do with it.

Cheers


#11

Solved!!!

I connected midi out from keystep to midi in on a midi solutions thru box, then midi thru from thru box to midi in on pyramid. Seems to work completely fine now.


#12

Hi Analog8 and pmatilai et al,
Thanks for helping to suss this out! I do not own a MIDI Thru box… kinda sucks that I have to have another thing, as all I need is the singe MIDI in connection to do what I want to do. All said, the Pyramid is worth it. Loving these polyrhythm capabilities most of all.

Will report back and confirm once I get a hold of a Thru~


#13

So what might the thru box be doing that the keyboard isn’t? Maybe the signal from the keyboard isn’t strong enough for the pyramid, but strong enough for the thru box to amplify it?


#14

Something like that. You’d need an oscilloscope to tell for sure.

Edit: more precisely, either the signal from the incompatible device is too weak or too slow to register as an “on” bit on the Pyramid hardware. Here’s what the MIDI specification states about the signal:

The receiver must require less than 5 mA to turn on. Rise and fall times should be less than 2 microseconds.

A thru-box doesn’t “amplify” the incoming signal in the traditional sense, it merely receives and retransmits the signals it receives. In this case, the particular thru-box just happens to have more tolerant input side than the Pyramid, and an output signal that is within the Pyramid tolerance. Technically it could just as well be the other way around, but this is why the standard exists: with devices that truly are compatible with the MIDI spec, none of this would happen.


#15

No idea why the thru box works.
What may make a difference is if I had a power supply from the keystep instead of USB power.

Annoying as hell but happy to have found a fix.


#16

Ok guys after a bit of thinking and messing about I think I have worked out where the problem really lies.
I was powering the keystep by USB only.
I have disconnected the thru box and reconnected midi out from keystep to midi in again on the pyramid… Same problem as before… But… Wait for it…
Now I disconnected the USB cable from the keystep and instead plugged in a 9v 500mA power supply… And guess what? Everything works fine again.
So it appears the the keystep lacks sufficient power with just USB to transmit midi?


#17

I recall seeing the BS/BSP and other Arturia product support a low power mode while powered via USB. Can’t say for certain if KS use similar logic. It was designed to reduce current drain while powered by an iPad. Some customers shared issues with the way it works, while others noticed degraded operation with the Arp and Sequencer. It wouldn’t surprise me that other capabilities are impacted as well, (such as Midi), but that’s my assumption.


#18

I’m also having this problem with Arturia KeyStep. It does seem to be some sort of electrical incompatibility with USB powered operation. Sometimes the KeyStep will work… a little. But with hung notes, missing notes, or just outright weirdness like pitchbends or modulations that I didn’t trigger, etc.

I am having no trouble when using my Novation 61SL midi out as a controller for the Pyramid.

I’m ordering an external power supply for the KeyStep to see if that helps. And a midi thru box too. :slight_smile:

Thanks for the tips, people.


#19

I’ve been having this same headache for 2 daze now.Then to use an old kenton merger box I had in a drawer for years…dusted it off and viola! You sir saved me $60 fpr a thru box.


#20

Following up on my last post…

I received a new ($20, kinda expensive actually) power supply for my Arturia KeyStep, but it seems to work just as well as the USB power. When using it, I am still seeing odd spurious MIDI messages, bank changes, hung notes, and eventually unresponsiveness (after not too long usually). If it works at all.

HOWEVER, I also did purchase a MIDI Solutions Quadra Thru, and when I put it inline between the KeyStep and the Pyramid, everything seems fine. But this is a kind of expensive solution (over $50) for a $120 keyboard. Especially since the KeyStep works perfectly with everything else I’ve tried. Just incompatible with the Pyramid.

It seems like the MIDI is getting garbled sometimes when received by the Pyramid, almost like there’s a speed/chase issue or something. I’m no MIDI expert though.