Velocity encoder assigned to X axis

Hello fellow pyramidions,

This is my first post as just recently received my pyramid hence it might be a total beginner question.

Basically, I cannot rotate encoder 3 to increase/decrease a note velocity anymore… However the other 4 encoders work as expected (i.e. transpose, length, offset).

This is what happens, in stepmode:

  • If I press the touchpad while “Assign” is lit, it reads “touchpad not assigned”.
  • If I press the touchpad while “Assign is unlit”, the default velocity will change
  • When “Assign” switches from lit to unlit there is a split second where an X appears next to the velocity graph (see picture below)

I have tried to “unassigned” encoder n°3 by holding “Assign” but the display “assign control to…” does not appear. Has anyone encounter the same issue ?

Thanks for reading and long be your jam !


So, I haven’t really used this workflow until recently and ran into the same thing.
I left it on the back burner thinking I was doing something wrong, because a little while later, it would work as we’d expect.

Just now I’ve been messing around with some sequences and decided to try it, and yielded the same unexpected results as you’ve noted. Then I rebooted the Pyramid, and it worked as expected.


Difference is that there was data before the reboot and I didnt’ bother saving it.

You should not have to Assign or Unassign these, I think.
But I can’t dupe it every time, so I have no idea if there’s a setting or flow issue that I’m just not considering.

So: you’re not crazy.
Or, perhaps you’re as crazy as I am, in which case, my condolences. :smile:

Can you create a new Project and does it happen the way you describe above or the way you expect it?

So this is bizarre:

  • Create a New Project
  • Enter Step Mode
  • Adjust Encoder #3 verifying that it changes the Velocity
  • Now in the same Mode or another, [Assign] Encoder #3 to some random MIDI CC
  • Encoder #3 no longer modifies Velocity in Step Mode (sends out Assigned MIDI CC)
  • Attempted to Remove Assignation in Step Mode, but not Assignation showed
  • Went to Live Mode & was able to Remove Assignation as expected
  • Re-entered Step Mode and using Encoder #3 yields “Not Assigned”

If you can dupe this, or if you can document steps to duplicate the unexpected behaviour you’re receiving, please go to and fill out a Bug Report.

Maybe give it a bit in case we’re both doing something wrong and someone bright might chime in with an explanation.


Edit to Add: Note that while the “Not Assigned” thing is happening and I’m in Step Mode, if I press and hold a Pad where a Note Event is happening, I can use Encoder 3 to modify the Velocity - but I cannot use Encoder 3 to modify the Velocity for further Note Events. Same for all salient Encoders, actually.

Unless I’m missing something here; all this is expected behavior. You will never get assigned CCs out of the pyramid unless the assign button is lit up, and you will only get their default values when assign is not lit up.

The X appearing next to encoder 3 is a visual feedback reminding you that velocity is always mapped to the X on the touchpad.

Assigning CCs and removing them works as I expect them to; with a few notes… I think you already know how to assign a thing. To unassign that encoder do the same thing except remove assignment, and then on the following “screen” don’t hit cancel… just exit the assignment pane via another button… I think either assign itself or FX [yes both work, but FX pops you into… FX; assign just exits the assign pane] should work… just don’t tell the pyramid to do anything with the encoder after you have unassigned it.

I have mapped and demapped every encoder on my pyramid as well as encoders (several) on my midi fighter twister, and my midi fighter 3d [buttons and 1 of the 4 tilt CCs. MF 3D button+rotate CCs are too fiddly to assign, but they are generally just too fiddly to work with].

Another note you might want to keep handy is if you use a track for CC LFOs when you mute that track; those LFOs will be disabled. [pyramid track mute; not like muting the audio… but you probably knew I meant that]

Also, mapping external CCs works a treat which is amazing with my twister. Assigned encoders all work on external midi gear whether assign is lit or unlit. Basically my opinion regarding this subject is “Get an external midi controller”. Your pyramids encoders are going to get a lot of action just from their base functions, and with the MF twister you get 4 pages of LED fedback encoder goodness.

Thank you for the replies CreepyPants and Ezmyrelda, feels good to be heard :slightly_smiling_face:

So after reading through your posts I have rebooted, created a new project but I am stucked at square one: encoder #3 does not change velocity of a selected note… As mentionned above, I cannot [Assign] / [Unassign] Encoder #3 to some random MIDI CC because the assignement panel will not pop up on the screen. Whereas the assignement procedure for other encoders works like a charm.

To wrap-up, the encoder is not accessible anymore. I think I’ll just leave it like that, at least the other four are working well.

Did not know about that fighter twister device, looks nice to expand the set up later indeed. For now my hands are tied to the vermona, and that’s a lot of knobs to handle :control_knobs: :control_knobs: :control_knobs:

Okay, when you get to the point that it’s not working as expected, that is, Encoder 3 does not modify the Velocity (if you’re in Step Mode, the right hand column on the screen shows:
Step Mode (Put it in Note or Chord)
The Note or Chord
the Velocity Symbol and a value
…other stuff

If the light on the [Assign] button is OFF, does the value next to that Velocity Symbol (like a little ramp) not vary along with twisting the Encoder?

If not, that may be a hardware problem.

Well, I used my mf twister as an example of expected behavior… people generally buy what they think will be best for their music. If at some point you feel you need up to 256 separate addressable encoders with a 4 part rhythm sequencer… it basically speaks for itself… :slight_smile:

If your encoder 3 doesn’t work it sounds like a hardware thing… which is unfortunate… the company seems to be eager to please so I hope you get it resolved… your touchpad still works though right?

Yep it looks like a hardware problem. I have tried to use the encoder 3 in Effect mode with an Harmonizer and it also does not work…

The touchpad is fine I guess but i have not been digging it all through so far so I cannot really say

I am heading to the shop for an exchange because it is going to be prolematic in the long run :slightly_frowning_face:

yeah, it’s a pretty important encoder just on it’s basic function… hardware was what I figured. Hope your exchange went smoothly.

The store owner is very understanding so he got me a mk1 model while they are investigating the issue.

I actually prefer the design of this version :ok_hand:

5 posts were split to a new topic: Midi fighter w/ pyramid

as this seems like a hardware issue, think we can close it off…

I hope where you bought it from can resolve it for you.
(seems most reasonable course of action, given you have only just bought it)

otherwise, you could reach out to squarp to see if they can help you further.