Hi there,

I have a Hermod that I’m trying to use with a Keith McMillen QuNexus Keyboard. It is set to send MIDI to the active channel and sometimes it works. Other times I have to reboot the case to get it working, other times I can’t get it to send MIDI notes no matter how many times I reboot the case. The keyboard is getting power but the light does not light up on the active channel when I play the keys.

Thank you


Hey Jamie,

Did anyone ever get back to you regarding this issue? I’ve been experiencing a similar issue with a new Hermod and an Akai MPK mini mk2. Keyboard powers up via the USB host port but it is somewhat random if it manages to transmit data to the active track. Similarly sometimes a reboot works to fix the issue sometimes it doesn’t. Did you contact Squarp through their contact us process on the website? Be interested what you heard back.

Best, Connor

No. Haven’t heard a word from anyone. I kind of thought this was the official Squarp support forum. lol. Had another issue recently where I didn’t power the Hermod on for about a month and all of my saved programs are gone. Kinda think this this is useless in terms of being an actual piece of music gear. And their support is non existent from what I can see.

This sounds like a good one to contact Squarp so they can discern what the problem might be.

Thanks! :smile:

Hey there. So sorry you feel your issues have not been addressed directly.
This is a community forum. If you have an issue that needs Squarp attention, please visit and fill out the form there. Thanks!

Ah man that really sucks. I have contacted squarp about my issue but haven’t heard anything back (granted I only got in touch yesterday), hopefully hear something back soon.

@Forms - dhave you upgraded to the latest firmware?

you can see Squarp explicitly listed the Akai MPK mini MK2, so Id assume they believe it is working.

a general point of note here… (not to Forms specifically … )

Im a software developer (not connected with Squarp) and done some USB midi work with micro-controllers…

USB Midi has its ‘vagaries’ , just because one device does not work - does not indicated a ‘general fault’ with usb midi, rather just an incompatibility between devices. (so the QuNexus was having issues, does not really say much (if anything) about an Akai not working ;))

one thing, to always check with USB is power - its probably the most common fault Ive seen.
if a USB controller has the option to use external power (as well as bus power) , if you have issues, try it with external power rather than bus power.

Hi, yes updating to the newest firmware was the first thing I did (seeing as Hermod had specifically listed the Akai MPK as one that they had added support). Completely understand the nature of compatibility not being a one size fits all and part of this being that Squarp have to navigate the multitude of USB midi drivers in use on the market. The bugs/faults I’m experiencing are not rendering my Hermod completely out of action. I can still use it. Simply put the general instability I’ve experienced just makes it a little less enjoyable to use that’s all.

Hi @jhowton, hi @Forms

I’m sorry you’re having issues.

My first advice would be to contact us directly via the contact form indeed:

I can’t speak for the QuNexus, but with regard to the MPK Mini MKII, we have tested it extensively at our workshop, and we had no issues. My first instinct would be to try with a different USB cable, maybe with a ferrite bead on it ?
@thetechnobear has a point also, it might be a power issue. Maybe your Eurorack power supply is undersized, causing a voltage drop that impacts the quality of the connection ?

In any case, it would be greatly appreciated if you could use the contact form, that would help us use our bug-tracking system.


Hi @Thibault_Squarp thanks for getting in touch. I did make contact through the contact us form on your website to raise these issues. But as I said it was fairly recently.

You’re suggestion of power issues has made me wonder however. I’d never considered it to be an issue as I know the PSU’s I’m using (2x Clank modular XPSU’s) are more than enough to power my 6u 104hp case. However… I have just remembered that I have until now still been using the power supply brick from my old case which is 15v 45w output. I’ve changed this out for the one supplied with the case and new XPSU’s which is 15v 60w ( the recommenced power output for these PSU’s).

I have a suspicion that this may be the ultimate culprit here. And if so is a very silly mistake on my part. I will continue using this newer power brick and keep note on whether I notice the stability improve.

Let me know if you think this could be to blame, you likely have more of an understanding of how inappropriate power supplies could affect Hermod stability. I have no idea why I didn’t change power supplies straight away.

Thanks for all the help.

I will make sure to direct any further communications through the contact us form you have online.


1 Like

Also remember: always try out different usb cables. Some hardware can be very picky about usb cables.

1 Like

Sorry to bump an old thread, but I’m having a very similar problem. I used to plug in my KM K-Board to the Hermod via the USB Host, and never had any problems. I havne’t used it this way in a year or two, but I recently moved all my eurorack around and want to do this again. The Hermod no longer seems to recognize any note info from the K-Board despite appear to power it fine. I’m now using an intellijel 104hp case, which I imagine has plenty of power to achieve this, even with it mostly filled up, but it isn’t the same case I used to use. I’ve tried multiple usb cables (including the one I used to use), and no dice. I also tried plugging another midi keyboard in – the old Roland A-300pro, and had the same issue, powered it fine, but no note data comes in (though I have no reason to be confident that keyboard is compatible with a Hermod). I’m running the latest 1.72 firmware.

I reached out to Squarp but have yet to hear back, so I figured it was worth posting here, in case others have overcome this problem. I’m worried the USB Host in my Hermod is just shot altogether. Not sure what else to try – I keep wondering if I’m just forgetting how this functionality is supposed to work and missing a setting somewhere, but I’ve combed the settings and manual, and nothing seems applicable.

Any help or commiseration is appreciated!

Not sure if this will be useful to anyone, but my assumption that the Intellijel 104hp case power wasn’t the problem turned out to be incorrect. Even though there was theoretically plenty of headroom for running Hermod in that case, it looks like that was the issue nonetheless. I pulled out an old case and the Hermod ran perfectly there, without any issues receiving midi data over the USB host input. So for anyone else experiencing this, even if you’re “sure” power isn’t the issue, it may still be.