Sample Transfer

Man, I love this thing but I think I’ve hit a brick wall with my competence level as I’m having a major issue getting my own samples to work once put on the RAMPLE SD card.

I’ve got some 16bit 44100hz Mono wav files that I bounced out of Logic Pro X

I created a new folder on the card called E0 as I wanted all my samples for each song in the same folder group and E wasn’t taken.

They’re named as per the manual i.e 1. YBV Piano Chords.wav

They just won’t play when I reinsert the card in the RAMPLE.

No idea what I’m doing wrong, I’m sure it’s one tiny thing :pensive: any advice would be greatly appreciated!

image

Image for reference

cool, you have one… be great to hear what you think of it :slight_smile:
(after this crazy situation is done, Im planning on ordering one)

I dont have one (as above) , but what I would try is:
a) get rid of the dot after the number … i.e. ‘1 YBV’ not ‘1. YBV’

b) try copying an existing (working) wave into this folder, does it work?, then rename does it work?
basically, try to detemine if its your naming convention, or something about your file format.

c) if existing wavs work, and yours with same name dont … then have a look at the sample file format of an existing file.

if think its probably (a) though.

Thanks for the response, I’ve tried removing the dot after the name on the files (all the ones from the other folders that work have a dot after them though). I’ll have a try at dropping a file I know that works from another folder into the folder I added though.

Not sure what I’m doing wrong otherwise though, the files are definitely mono wav and at the right bitrate etc.

It’s a really nice bit of kit! looks to be quite flexible as well.

1 Like

Tried putting an existing sample from another folder in and that works fine so now at a loss as to what to do :frowning:

@squarpadmin is this something you can advise on?

Hi, thanks for your feedback! It sounds like a bug, can you please send us your .wav file, we will check it?

We never tried the export with Logic, it’s possible that it adds extra info in the .wav file, making it no readable by Rample, but we can improve it :slight_smile:

1 Like

Hi, thanks for getting back to me. What would be the easiest way for you guys for me to send it to you?

First, contact us via https://squarp.net/contact and the support team will help you!

2 Likes

Thanks, I think I’ve managed that, the captcha thing didn’t look like it had worked though so I’ll leave it a day or so and if I’ve not heard anything back I’ll send again.

I’ve the same problem. My wav files are not played my rample despite having the following format:
pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, mono, s16. The preloaded files work well and if I copy those into a new folder, they are recognized. Which software do you use to create the samples?

Are you using Logic as well?

I tried audacity, ffmpeg and avconvert… their wav output doesn’t work wit Rample

Hey, one thing to try, if the bit depth, sample rate and number of channels are correct is stripping metadata chunks.

People who are happy with ffmpeg can try something like this in the dir of wavs:

for i in .wav; do ffmpeg -i “$i” -map_metadata -1 -codec copy "stripped/${i%.}.wav"; done

(note that this is for bash shells, so linux/macos/etc., won’t work in the windows command prompt, but you could do something similar)

That’s well beyond the limits of where I care about metadata, but thanks for the option.

I’m a musician first and foremost so I just want to be able to get stuff on as simply as possible.

Squarp got back to my email and suggested using Media Human and that works.

It adds an extra step and requires an additional bit of software that I’m trusting won’t nail my computer though.

I’d much rather be able to use files exported straight out of Logic as that suits me personally (and I’m sure anyone else would be the same with their respective DAW).

It’s a really nice module and works really well in operation but this would be my one small gripe with it. maybe it’s something they can fix with a future update?

2 Likes

That’s good news @ladywantsaudio
( that you have a process that works)

Did you send @squarpadmin a wav file that did not work?

In software dev the first step is being able to isolate the issue - so knowing that media human works for you means that they can look at the difference between what it create and logic - and so track down the issue.

As @kattefjaes says , it’s likely logic is putting a whole load of unnecessary meta data at the beginning of the wav file … knowing this, it would then be probably something @squarpadmin can ignore in a future firmware update.

( there was a similar situation with importing midi in early firmware versions)

It might be useful, for others to post here with what daws and tools are working at the moment, and which have issues.

Having the exact same issue… tried exporting from RX7 as well as Myriad. Will try this Media Human and see how that works. Seems like a bug that can hopefully be remedied.

If you send us an email via https://squarp.net/contact with a link to your audio files, that would certainly help us fixing this.

1 Like

I’ll send some of mine through.

Cheers

my rample is here :partying_face:

so I did a few tests… (which I will of course, be passing to Squarp :slight_smile: )

  1. Logic Pro X does not work (as others found)
    however, If I strip the additional metadata tags from the file using ffmpeg , then it does work.
    so perhaps its the meta data? see tech details below.
    (of course could be its using RF64 as cubase does by default)

what you can do to get around this is, set logic pro to use Audacity.
then export from there

  1. Ableton works fine

  2. Cubase works fine
    when you export you must tick
    ‘don’t use RF64 compliant file format’

  3. Audacity works fine
    remember to set the ‘project’ SR to 4410

others
Bitwig (3.0) and Reason (10), I could not find a way to get them to export mono wav files

overall, appears to work with most daws (that support mono export!) … LPX is the exception.
but there are DAWs that don’t do mono export.

generally, Id recommend using Audacity, its the #1 free audio editor, and is well respected.
its a little quirky, but after you use it a couple of times its pretty reasonable, and has a ton of useful features for prepping samples - many daws allow you to specify an external editor, that means the workflow is not too bad.

id really love it to be able to play stereo files (even if in mono),
but thats something I’ll submit via contact form :slight_smile:


tech notes:

note: ignore file size etc, I selected different regions of audio to export
working example (ableton)

Input #0, wav, from './T1/1.Ableton.wav':
  Duration: 00:00:24.00, bitrate: 705 kb/s
    Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, 1 channels, s16, 705 kb/s
File 'a.txt' already exists. Overwrite ? [y/N] y
Output #0, ffmetadata, to 'a.txt':
  Metadata:
    encoder         : Lavf57.41.100
Stream mapping:
Press [q] to stop, [?] for help
size=       0kB time=-577014:32:22.77 bitrate=N/A speed=N/A    
video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
;FFMETADATA1
encoder=Lavf57.41.100

non-working Logic pro X

Input #0, wav, from './T0/1.lpx.wav':
  Metadata:
    encoded_by      : Logic Pro X
    date            : 2020-05-06
    creation_time   : 19:43:13
    time_reference  : 158760000
    umid            : 0x0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000003600D25F
    coding_history  : 
  Duration: 00:01:35.46, bitrate: 708 kb/s
    Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, 1 channels, s16, 705 kb/s
File 'a.txt' already exists. Overwrite ? [y/N] y
Output #0, ffmetadata, to 'a.txt':
  Metadata:
    encoded_by      : Logic Pro X
    date            : 2020-05-06
    coding_history  : 
    time_reference  : 158760000
    umid            : 0x0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000003600D25F
    encoder         : Lavf57.41.100
Stream mapping:
Press [q] to stop, [?] for help
size=       0kB time=-577014:32:22.77 bitrate=N/A speed=N/A    
video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown

;FFMETADATA1
encoded_by=Logic Pro X
date=2020-05-06
coding_history=
time_reference=158760000
umid=0x0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000003600D25F
encoder=Lavf57.41.100
2 Likes

Yep, there we go, metadata strikes again. Often the culprit with small embedded sample players.

Luckily it’s a super-easy interim fix before the manufacturer catches up (and they normally do)- a mac user with ffmpeg installed can literally fix a whole folder in seconds with a one-liner.

Incidentally, New Sonic Arts Vice also makes samples that the Rample can understand, just as another data point.