Rample began crashing after week or so of normal use

Has anyone else with a Rample seen glitchy behavior occurring after their first week or so of use?

The issue:
My Rample worked fine for the first few days I had it, no problems whatsoever. After the first couple days, I noticed that it seemed to get very glitchy if I fed it multiple fast gates with longer samples. This week, it occurs almost immediately upon feeding it a gate, even to a single channel, on any bank. The screen goes all red, and the bank select encoder becomes seemingly unresponsive.

I tried to file a bug report via the contact form on the site but I can’t submit (keep getting an internal error message).

I’m happy to help debug, but at this point the module is basically unusable which makes me sad, because I’m really excited about the possibilities with this thing.

1 Like

I’ve encountered the same problem. It’s not even possible to use the encoder to do a reset. Sometimes the all red screen returns to normal, sometimes it needs a reboot. It does seem to be dependent on the number and speed of triggers. I found that with all four channels receiving a lot of triggers the module keeps on triggering after the trigger inputs have stopped, as if they’re queued in a buffer. I’m currently just using it with one or two triggers and it generally seems to keep up.

1 Like

@David1 can you send some details to squarp at http://squarp.net/contact

@micahsaul , perhaps just a glitch with contact form ? Or try on a different browser - it should be working ok.
Sounds like you have a use-case that’s way to reproduce, which is always super helpful when trying to debug issues.

Sorry, we’re having an issue on our server at the moment. it should be fixed in an hour or two. Sorry for the inconvenience.

I’m sorry to hear you’re having trouble with the module. Please try and contact us in a couple hours time, we’ll do our best to help you.

EDIT: server error is fixed. Contact form is working again.

Hi,

The contact form is returning an internal server error at the moment. I’ve made a short video demonstrating the problem that I can send to you. I’m only able to attach a single jpg file. Triggered sounds are being interrupted by bursts of digital noise and the entire display flashes red. Rebooting the module doesn’t make any difference. I’ve tried resetting and that doesn’t help either.


The module is pretty unusable as it stands. Could it be a hardware problem?

Thanks.

Kind regards,
David

Update: I tried removing the micro SD card, replacing it and rebooting. The encoder scrolls between the folders, but pressing the encoder does nothing and no sounds are triggered. The module seems completely screwed. :frowning:

Btw, it wasn’t playing any sounds when I removed the micro SD card. OK, I know I shouldn’t have removed it, but what else to do when nothing makes any difference? :hot_face::unamused:

@micahsaul @David1

The contact form is returning an internal server error at the moment.

The error is fixed. You should be able to contact us now. Sorry for the inconvenience.

@David1 Your SD card might be faulty, or maybe its filesystem got corrupted somehow. Please contact us, with pictures and details, we’ll try our best to help you solve this.

1 Like

The micro SD card seemed fine before. I checked it in my PC: files were accessible and no errors were reported. I’m not sure what other details or pictures you need. Before the module became unresponsive the display was flashing all red when the module was receiving triggers:


After removing and replacing the micro SD card and rebooting, turning the encoder shows the folder names, but pressing the encoder has no effect. Triggers do nothing. As far as I can see, the module is essentially bricked.

Hi @David1,
It’s not a matter of more details or pictures, we just use the contact form as the central point of access for all bug reports and customer service. With forum posts, we can’t use our bug tracking system effectively, nor really contact you privately to discuss shipping for servicing, etc.
Would you be so kind as to use the contact form at squarp.net/contact ? This will greatly speed up the process of solving the issue.

Sincerely

OK, will do.

1 Like

@Thibault_Squarp thanks for the update on the contact form. Doing it now!

I’ve started to experience something similar, after 5 minutes or so of playback the Rample goes silent until I re-power the case (encoder gets stuck on whatever screen I’m on). Mostly when using all four channels. At least mine works again after a restart, but the lockup is pretty consistent. Hope a fix is in the works.

@David1 @micahsaul

I’m so very sorry, but I’m afraid as soon as I said it was fixed, the email server crashed again, and sadly we did not notice until this morning. Now, it should be fixed for good, I made sure of it. But if you used the form, and even if it said it sent the email, we simply did not receive it.
Again, I’m terribly sorry for the inconvenience.

I’m experiencing this exact issue.

Ask Rob Playford to sort it out for you, maybe? :sunglasses:

Hi @goldie,

I would advise you to contact us via the contact form:

Any updates on a firmware coming out? This issue pretty much kills this module for me at the moment.

did you send in a bug report via the contact form?

this is advisable - so that you can provide full details of what you were doing when the Rample locked up… e.g. are using gates, or midi, modulating something?

as you can see from above it only a few people reporting issues - so I’m not sure if there is a general issue (e.g I’ve not seen any lockups on my Rample) - perhaps there some particular aspects are ‘provoking’ a bug e.g. modulation of a particular parameter, or a setting.

my experience is that if you submit a bug report, then sometimes Squarp will reach out to you with a beta version of a firmware, so they can work with you in advance of its release to see if their fix, does indeed address your issue.