Project Load and save issue

Hi whilst playing the hapax at some point the sd card project options, save, save as and load stop working. I cannot click anything. Save still works but doesn’t show me the usual saving menu it freezes then jumps to “song” but it has saved. The original SD card was fat16 so i formatted a new SD card and copied my projects over. but i’ve tried 3 sd cards and had the same issue. has anyone played multiple projects with the hapax i.e. load a then b several times then at some point run into this issue? I have to resstart the unit which of course is not ideal for live. I’m not sure if its a bug (filed one) but I wonder if it’s a corrupt file on the SD or something

hey. i’ve had exactly the same issue, spoke to squarp about it last week.
i found the same thing; my factory SD card had been formatted in FAT16, not FAT32.
you’ve done the first thing right; re-formatting, but i’m afraid (according to squarp) that your project files will have been corrupted by the FAT16 format.
you’ll have to create a new project for each of the ones that were made when the card was FAT16.
i recreated my synth parts, one at a time (because i don’t have many patterns per project).
i took a risk and copied/pasted my drum track, to see if the corruption went that far; but so far i’ve not had any further problems. my hapax was doing the same as yours, it was also crashing completely if i tried to select the automation view, which was happening frequently. that issue also seems to have stopped.
you might be able to copy/paste the instrument tracks or patterns to a new project without causing the same problem, but i can’t guarantee it, as it’s only been 4 or 5 days since i did the same.
hopefully, it won’t require a complete recreation of the entire project to avoid the issue!
sorry i don’t have better news, dude. i realise if you’ve got a number of projects already it’s going to be a pain to create them again… i’m surprised squarp managed to let SD cards be incorrectly formatted like that.
good luck!

1 Like

sorry, i forgot to say i also re-installed the OS/Firmware (1.11)
don’t know if that was necessary, but i did it anyway just in case the card had messed with it…

1 Like

My SD card was FAT 16 also, but FAT 16 vs FAT 32 will NOT corrupt your files. FAT16 supports a maximum volume size of 4 GB, while FAT32 can be used on volumes up to 16 TB. As the cards that ship with the Hapax are only 2GB cards, FAT 16 would be fine. That said, the notes at the very top of the firmware page state:

format your SD card with your computer (“FAT32” with Windows, “MS-DOS FAT” with Mac) before using it with Hapax

As for backup, you can simply copy the HAPAX folder on the SD card to another drive. I tested this and it works fine. I copied the HAPAX folder to a hard drive, formatted the SD card, then copied back the folder. All files are accessible and not corrupted in any way.

Important note - I received my Hapax on Sept. 12, 2022, and noticed it had OS 1.04 installed. I suggest you check and update to 1.11 if needed (1.11 is the current version as of the time of this post). A bug “Project → NEW could cause corrupted projects” was fixed in 1.10.

The firmware version and notes are here:

Thanks so much for the reply! i have a gig next week and prepared all my patterns :melting_face: however you’re right after some digging I though maybe the songs created on the old sd on the old f firmware were corrupt I noticed it’s a
Fe w files have a project size of 10kb and the rest 9kb. I then went and created a new project which is 9kb therefore I think there was some data in the old file format that causes the crash. I’m going to try and re create the old problematic ones first and see how I get in but it es probably safer to do it all new again :tired_face: 2 days worth of work. But glad to know there is a solution.

Thanks also for th reply. As the other guy said my projects have been causing issues and I think it’s because I had created them on the old the firmware.

When I got my squarp last week I recorded my midi files from my mc707 I did not need any other Features so did this before updating. I created a templates project and used this for each new roiwjext and even after the update I still used it I believe that file could have been corrupt.

And as you pointed out there was a bug

you’re welcome :smiley:

So I spent 6 hours recording, naming and creating program changes again to see if it was the old files. But it’s still happening I can load a few projects b2b then at some point it just stops allowing me to load or save projects. Sad! Guess I won’t be using it for the next show as switching projects like is the biggest feature for me. Tried 3 sd cards new firmware etc no luck

hey. i’ve just started having the same problem again (appearing not to save/refusing to load)…
i guess squarp were wrong about this one. i’ll have to consider my position with it too, given that like you i need to be able to load two projects at once.
i’m going to email the support team about it again.

That doesn’t give me confidence although it’s strange because no one else has reported this. I’m going to give it one more try and start completely fresh.

What I did notice and squarp mentioned it’s probably irrelevant is that the project.dat file since the new firmware is 9kb and in my he older files I recorded previously it was 10kb. So perhaps the file itself is causing this.

I’m going to start it all again re-record and set the pc messages but let’s see I have little faith at this point. I think it’s a an issue with the sd card reader internally bugging out.

Jean is the fella I’m speaking to at squarp, sort of brushed it off as they thought you fixed your issue.

Such a shame as it would have been amazing to use it in the next gig!

Btw what is your set up are you sending midi sync/clock to the hapax? Or is it your master?

hey. yeah, i’ve been speaking to Jean too; i emailed him earlier to let him know the issues aren’t fixed. hapax is my only sequencer. i’m using novation drumstation/a-station/peak, waldorf blofeld,
roland sh-01a boutique and eventide’s timefactor delay.
hope you can get sorted out one way or another for the weekend; sounds like you’ve lost time because of these issues!

3 days been transferring my songs over from my cirklon. Can’t believe the intended use I.e 2 projects at once is an issue.

I think maybe I’ve figured it out spent another 3 hours redoing everything. I noticed when I made a totally new sd and completely started each project again the project.dat is 9kb for all projects whereas on the other sd (assume corrupted) it was varying from 10-9 maybe the ones with 10 were an issue due to some data loss. Any I’ll report back tomorrow. I’ve only been using proA to create them this time I think maybe the issue could be when using both a and b b2b

So still no luck seems like it’s done for. It’s only a matter of time till others run into this issue. I get it about 20-30mins no matter what I’m doing at some point project load stops working.

yeah, i’ve always been working for 15 mins or so when things started getting messed up.
like you say; the 2 projects at once feature is one of, if not it’s main selling point. if that’s not going to work you may as well use a different sequencer. i’m already looking at alternatives (Digitakt).
i think for now, i’ll have to stop production until either this issue gets sorted out, or it’s taking too long and i move on from it. disappointing when you’ve waited from march until july to get the thing, never mind the cost…
good luck on the weekend, dude!

Out of curiosity what batch were you? Mine came last week. But I’m hoping it is a firmware issue as I’m happy to wait I have 2 other sequencers. But I totally get your situation. The thing is it’s by far the best feature wise however I’d take performance stability over a large feature set any day. Let’s see what the guys come back with usually they are good with these issues so if it’s critical it might get escalated.

Hey guys,

I’ve not encountered this issue specifically, but I’ve also not been copying over projects from another sequencer, so only written stuff organically. Could you give me a bit more info on reproduction steps and I’ll see if I can get mine to do it, too? I’m from the first first batch.

Also, I worked with Jean loads a few months ago fixing some dinSync and MIDI clock issues, he’s good, he’ll get the bottom of it, it’s just nailing these problems sometimes takes time.

Sorry to clarify by copying I mean maually recording in midi directly to each track/pattern. I’ll explain below let me know if you need more context.

Set up. Erm clock to hapax sending midi clock only. Midi out A on hapax to my access virus.

Load project A start playing then load project B load up and start transition etc etc. I do this for 15-30 mins then at some point when I go to load a new project it doesn’t allow me to click into any of the options (save, save as,new, load). Everything still works I can play back etc but cannot load a new project and have to reset. What I would add is when I click save it doesn’t show me the save loading bar but it does save the status of the project.

I’ve tried this with the hapax being the master clock and it’s the same scenario.

I’ve created all patterns directly on the hapax + program changes etc.

When I worked with only one side so project A I did not get this issue but soon as I did both it happened.

Jean thought maybe the sd that shipped was the issue but I’ve correctly formatted and tried a few sd cards.


I’ll give this a go in a bit.

How many projects are you loading in 15/30 minutes? Can you reproduce it just by loading A, then B, then A, then B, etc for the same amount of times?

So in reality would be 8 as my 16 songs is an hour set. But I’ve been doing it quickly to see if it’s a project itself. So loading a play it a bit then b etc. last night I did a test as if I was performing and took my time but about 30ish mins in it happened. I got the attached bug report but that was a separate incident where the project loading itself froze but never happened again.

Do it like a dj deck a and deck b a song on each, mix then load new song etc