Novation Peak - notes latching on

Hi

Im a new owner of a Pyramid and am having issue getting reliable MIDI messages to my synths.

Using it in Live mode, with a direct MIDI connection to a Novation Peak, the keys on the Pyramid seem to occasionally ‘latch’ on and continually send a message to the Peak until I press the stop button. I have a video of the issue which I tried to send to technical support but it wont upload to them.

Could this be a normal feature of the Pyramid or is it a problem?

Welcome to the Forum & congrats on your new Pyramid.
I [expletive] love this thing.

First, when it happens check the screen for [H/] or [R/]. If you see those, review the Manual under Live Mode → Hold & Relatch

If those symbols do not appear on the screen, it would seem to me that your destination synth is not receiving a Note Off msg. You state that the Peak is directly connected to the Pyramid so:

Pyramid Out → MIDI Cable → Peak

If that is the case, then there might be a problem with your MIDI cable - try a different one to see if you can replicate it.

Also, you can check the MIDI Monitor via Settings → Info → MIDI Out x Monitor (Where x=A, B, or USB depending on which connection you have your Peak connected). You can see Note On and Off msgs as the Pyramid sends them. If the Pyramid is sending a Note Off and the Peak is not responding and subsequently failing to stop the Note Event, then I’d check your MIDI Cable and/or Settings on the Peak.

Hi, thanks for the reply!

Ive just woken up and tried everything that you suggested: swapped the MIDI cable - fault still present, checked MIDI monitor - all the information looks fine but still have the issue, and there is no [H/] or [R/] on the screen.

After trying those things I changed from MIDI output A to MIDI output B and the issue is resolved? I wonder if there is something wrong with the MIDI socket on the back of the Pyramid.

So to clarify, my set up is: Pyramid - new MIDI cable - Synth (on channel 1). If I use MIDI out A Ch 1 on the pyramid I get erratic notes play on the Peak and also notes keep playing after I release buttons. If I use MIDI out B Ch 1 on the Pyramid all works as expected. Something to also note is that the Peak works fine with my other sequencers.

Is there a difference between MIDI out A & B that could cause this problem?

AFAIK - the only difference between MIDI Out A & B is how you might have the set up in Settings. If those are both set to MIDI OUT, I’m not sure what else I can think of. If no one else has a solution and both A & B are the same setting, you could check with a MIDI Monitor app like MIDIOx to verify that all the Note Off messages are being sent out. I have no idea what is between the onboard MIDI Monitor and the actual hardware out.

Can you duplicate this behaviour with other synths or is it particular to the Peak?
Are you playing any other Tracks that might have a CC64 message? Or might there be any CC msgs on the Track that you are playing?

If your Settings are consistent between A & B, and you can verify with a monitor app that there is no Note Off being sent nor any CC64 or other CC’s that might affect settings on the Peak, and you can dupe this with other synths, then the issue might indicate Pyramid hardware perhaps. I’d check in with Squarp at squarp.net/contact

im not sure- i am new to pyramid myself. but sometimes i end up with a track that has some fx saved to it and i cant figure out why its behaving a certain way. maybe make sure that the track is completely cleared in step mode… or open a new project.

hope u figure it out because the pyramid is soo fun!!!

Interesting, I have the same issue Frank, with the novation peak! happens occasionally, I’m using output B. let me know what the squarp support team answers once you send them the video!

I have the same issue over both outputs. Seemingly at random, the Pyramid will begin holding played notes, which can only be stopped by hitting the stop button. Sometimes it will also play an additional note once I let go of a key. Very frustrating! Let me know if they are able to help

Well, at least I’m not the only with this issue. I tried to upload a video to squarp, it’s was under the maximum file size but their help form wouldn’t work.

I think I will just return it, I’ve been down the road of trying to get manufacturer repairs on new gear and it’s always been a massive headache.

This is exactly what mine is doing, but only on MIDI output A

do you also have this only with the novation peak? then its almost too much of a coincidence…

don’t give up on the pyramid just yet!

no, it’s the same problem on all synths. MIDI is coming from a Prophet X, being sent to a Prophet 10 module and Mother 32. Same issue everywhere.

Ok thanks, useful information, then you’d expect that this issue would be a known issue with other long time users? @Jags ? @thetechnobear ?

Well I’m not really a long time user as I’ve only had my Pyramid for a bit more than a month.

I don’t use the keys/buttons on the Pyramid itself to enter a sequence or play the synths at all. I always have local control on in each of my synths and play each synth directly. The Pyramid is set with MIDI Thru off and also MIDI Echo off. The pyramid is only recording what comes in and does not send anything out while recording. It is only once the loop is finished recording that the Pyramid starts sending out what was recorded.

My settings are as follows.

-In the Pyramid, Settings → Midi In → Omni Mode: set to Multitrack Bank A
-In the Pyramid, Settings → Midi Out → Midi A Mode: set to MIDI Out (default)
-In the Pyramid, Settings → Midi Out → Midi Echo: set to STOP ECHO

So perhaps since I use my Pyramid in a different way I may not be having issues. I don’t really know because, so far, I have no issues at all.

Perhaps doing a firmware update to the latest firmware may help.

Good Luck All!!!

One more thing I just remembered. I read somewhere that the Pyramid may have an issue with the MIDI optocoupler chips they use causing some unstable MIDI operation. The quick fix was to insert a MIDI Thru or Merge box between the Pyramid and the synths. The MIDI Thru or Merge box buffers the MIDI signal and stabilizes it so there are no unstable MIDI occurrences.

You pretty much need a MIDI Thru box on the Pyramid MIDI out anyways to split the signal to all your synths. I have a “MIDI Merge” box before my Pyramid MIDI in and a “MIDI Thru” box after my Pyramid MIDI out.

Perhaps this may also be a reason that I’m not having any issues.

I have this same issue, but with an external controller. At least in the form I’m experiencing, it it looks like a Pyramid firmware bug rather than a hardware issue, an issue with the connected controller, or a problem with the connected synthsizer. According to the Squarp Pyramid INFO screens:

  • Midi in sees: note on, then note off
  • Mid out: note off, then note on (for the same note)

The note on/off reversal was observed from the Squarp INFO screens and also at the synthesizer.
The hardware configuration is:

Controller on MIDI in
Synthesizer on MIDI out A
MIDI A is in “midi out” mode, not a thru mode
Omni mode is multitrack bank A

The use case this bug interferes with is basic live synth playing and sound design. The Pyramid is set up this way so I can play the synth directly without repeated notes and also create sequences. So even when I’m not making or playing a sequence but do have the Pyramid between the controller and the synth there is a Pyramid bug that prevents the controller from playing the synth correctly.

This may or may not be the same bug reported by the original poster.

1 Like

I’ve personally used the midi din in and out directly with the pyramid without any issue.

do you have a reference for that claim… has @squarpadmin acknowledged this?
I think creating some kind of ‘myth’ that the din is unreliable is extremely unhelpful, unless its an acknowledged issue - and with some proper details.

why is this unhelpful?
because, more often than not (in the years we have had the pyramid) the issues turn out to be either user issues or something related to their setup, or even the instruments they are driving.
but this ‘myth’ would be a simple way to shortcut this , and say ‘oh its the optocouplers’, rather than getting to the bottom of the issue.

also, how reliable is this - what if this ‘fact’ has come from a particular user, who happened to have a pyramid with a damaged optocoupler i.e. its a one-off (or even infrequent) hardware issue… or they just simply misunderstood the issue.

so please let’s not start repeating things that “I read somewhere” without something more concrete to back it up.

of course, if you have some solid information, this would be useful information (perhaps in a separate topic) - and also something that I think would be useful to discuss with @squarpadmin , so we can determine when and where it is likely to be an issue.


as for the above issue…
Im a little confused about what is being said, the OP seems to be quite related to a specific instrument and @Epicycles issue, id say at first glance is probably not related.

it/s not helpful to just lump ‘random midi issues’ in one topic… there are lots of us using the pyramid regularly (and have for years) without issue… so there is very unlikely to be a ‘generic’ midi issue that would have gone ‘unnoticed’ for so long.

usually when we see these issue its is specific combinations of devices, and frankly, invariably its some setting or issue on the controller or synth… which is, unfortunately, more common than you’d expect.

this means, its important for these issues to be very detailed very specifically, and not ‘muddy’ the waters with (potentially) unrelated issues.

as for the issues, as I said hard to track… but
generally, when I see note on/off getting ‘confused’ , this is almost always due to a previous note off some how being dropped… it gets really wacky, you get things like a synth, playing notes when you release a key, and silencing when you press it :slight_smile:
(sending an all-notes-off, will often bring the synths back into ‘sync’ , at least in my setup)

this is not specific to they pyramid, I’ve seen it in setups without any sequencer involved.

for me invariably, its caused by some midi feedback, or something else which overwhelms the midi data traffic (but usually its a feedback loop)… if these loopbacks do not involved clock, they can sometimes be quite hidden… as the system works fine, except for every now and then missing a note off…

1 Like

thetechnobear,

Yes I agree 100%

Here is the thread where they discuss the problem with the Pyramid MIDI chip and how someone replaced the midi in optocoupler (6n136) with the same reference from another manufacter (ONSEMI) . Last post of the thread #27. It is a known issue to Squarp according to that thread.

Pyramid incompatible with M-Audio? - Pyramid - Squarp Forum

1 Like

Thank you for yor reply!

I do apologize if I’ve hit a sensitive area by assuming that this problem is a software bug. I should not have done that and it is not my intention to slander the product or the team. The Pyramid seems quite wonderful to me, and I have been using it for hours a day, but only for the past few weeks.

I’ll try to resolve my problem here so that when other people run into this problem they will have some way to resolve it. This seems like a case where the forum is most valuable: the nature of the problem is not exactly clear and a number of people have experienced the same frustrating and confusing symptoms.

If it helps, I have seen a very similar problem (note-on/note-off revsered beween input and output ports) reported for the BeatStep Pro, so the same thing happens even with other with sequencers. We can’t tell from this that it is definitely a bug or not.

Regarding whether the issue I observed (MIDI IN/OUT on input mapped to MIDI OUT/IN on output) is the same as the OP’s issue, I want to reserve judgement. I am experiencing the exact same symptoms as Frank and Dewaldo according to their descriptions. Like Dewaldo I believe I have seen the stuck notes problem with multiple synths and multiple controllers. Because I mainly use my external controllers I have only observed the problem that way, which is also what allowed me to observe the note-on / note-off mapping reversed beween input and output ports.

To exclude the possibility that the problem is caused by a MIDI loop I removed the MIDI IN and MIDI THRU cables from my controller (a Prophet 12 keyboard in this case), so the controller only has MIDI out from the controller to the Pyramid. The Pyramid has MIDI OUT A connected to another synthesizer. Now there is no MIDI path back to the P12 (used as a controller) from the Pyramid. And there is no MIDI path back to the Pyramid from the Kodamo FM Essence, which is the synth in this case.

I can reproduce the problem within a minute or two by sending repeated notes with the arpeggiator from the P12. The problem is random and happens with normal play, with short notes, and with long notes. The arpeggiator is not required for the problem to happen. But I can make the problem appear quickly if I send more notes, so I use the arpeggiator, with the C4 key in this case. As the arpeggiator runs I hear the notes sound evenly and once in a while I hear a missing note. Then eventually I hear a note that is stuck on. Now I can stop the arpeggiator and look more carefully at the problem:

I naviagate to Pyramid’s INFO->MIDI IN screen. Then I hold down the stuck note and I see the ON C4 message. When I release the key I see the OFF C4 message. I do this repeatedly and it is always the same. Now I navigate to INFO->MIDI OUT and hold and release keys. But this time as I press the key down I see OFF C4 and ON C4 right below it. When I release the C4 key on the controller I see nothing on the Pyramid out monitor.

When the note is “stuck” the synth will sustain it if there is a note sustain level. I can use the “panic” feature of the synth to turn off the stuck note sound, but if I hit the key again the note will still be stuck as you would expect from the message log.

Power cycling the Pyramid (and nothing else) immediately fixes the problem that the C4 key will get stuck again the next time it is pressed. It will also resolve without power cycling after 5-10 minutes.

There is one more hint, but I think it is not relevant. In certain situations the Prophet 12 will send extra NOTE OFF messages with no corresponding NOTE ON messages. The way to make this happen is to lift the physical key up almost all the way and let it bounce there. So you get NOTE ON for the keypress then several NOTE OFF messages for the same key. I don’t see this happening with the arpeggiator though, so it is probably not related to the issue.

1 Like

So-far I haven’t heard back from the Squarp team regarding the bug I filed on this issue.

I was prepared to do more investigation, but the previous session showed that the Pyramid is getting into a broken state, and I gave a procedure that should allow anyone to reproduce the problem within a few minutes.

I’ve seen crashes now also (device freezes with message “Fatal Error”) while editing effects during play (auto-capture of effect parameters) and I’ve also seen other behaviors that seem to be bugs in the user interface.

For example there is this one: Go to track mode, select the track you want to edit, be in “player track mode” so the display follows playback. Hit the PLAY button, then navigate to some segment in the middle of the sequence and hit play again. Play is supposed to restart at the beginning of the current page of notes, which it does. But some of the time the cursor does not light up to indicate the note position while playing the current screen, after pressing “PLAY” a second time. Repeatedly pressing PLAY will cause the cursor to re-appear. I did not find an explanation of this behavior in the manual, though possibly I just missed it?

I’m still hoping to make this device the center of my creative process but the bugs are a challenge because they do interrupt my flow. I can do most of the sequencing and capture that the Pyramid can do in the DAW instead, but the immediacy of the hardware sequencer is a real advantage… if the device works without bugs, or if perhaps I get used to the bugs so they stop bothering me.

How are other people coping with the bugs? I’m using the Pyramid for live/multitrack capture and also step sequencing, more or less in equal amounts. I always capture automation live from the controller and/or knobs, whether I step sequence or live capture the intiial sequence. I’m usually bouncing back and forth between writing patches for the hardware synths and writing sequences that go with those patches. I’m generally trying to keep the imagined sound of the music I’m trying to write in my head as I work, so the process is fragile if the sequencer doesn’t perform as I’m expecting it to. I’m hoping there are people here who have been using ths Pyramid consistently for a period of time to create music, and I’d love to hear what your experiences have been…