Notes entered with MIDI guitar not registering properly


#1

Hi there,

It might be a long shot but I’m hoping someone will have a solution to this problem.
I’m using the Fishman Triple Play through a Kenton USB MIDI host directly into the pyramid.
I can control all of my synths as expected when going THROUGH the pyramid, but when I record using live mode, the recorded notes have an extremely short gate (a click basically) and none of the sustain is recorded (except very occasionally, strangely). I can compensate by adding release to the synths but that’s far from ideal in terms of expression. I noticed that when i change the display on the pyramid i can clearly see the notes that are being registered and that the note is holding for the entire duration of the note, it’s just not captured in the recorded sequence.
For a guy who is terrible at keys, this set up has a lot of potential apart from this rather important deficiency.

Any thoughts would be greatly appreciated.


#2

Sorry, did you mean you look at the midi monitor? Settings > Info > Midi In
Or the piano roll (of recorded notes)? Step > DISP


#3

Hi - I was referring to the keyboard/chord display in live mode. However, I did just check the midi monitor now and I’m seeing all kinds of info there including note on/ note off at what seems like the proper times. Not sure what i should be looking for, exactly. Thx


#4

I took at what’s happening in the midi monitor. First example is a depressed key playing C4. Looks normal, of course. Second image is the guitar, playing a C3 as cleanly as possible. Theres a doubling of events, plus additional cc info. any ideas? I’m pretty new to this data.

thumbnail_IMG_0374
thumbnail_IMG_0373


#5

There’s a MIDI loop there going on. That’s your issue.


#6

Interesting, that’s what a MIDI loop looks like? Well, I’ve tried eliminating any merger and thru boxes I had in the chain and there is no change. I’ve also tried anti echo, which also did nothing. Filtered out the cc messages as well… nothin. How does one eliminate a MIDI loop? Appreciate the help!


#7

So there’s no midi going back to your Kenton USB MIDI’s midi input I assume? If there is, is there a reason for it? Can you unplug it?


#8

No there isn’t. Midi comes out of the Kenton only.
What i’m finding strange is that very occasionally the notes will record correctly with the proper duration. perhaps one in every 15 notes or so.


#9

Have you tried unplugging all other midi devices, leaving just your guitar, Kenton and Pyramid active? I wonder if another device/synth is relaying the midi back somehow.


#10

Good thought, but yes I tried that. I’ve been doing some experimenting though and this is what I’ve found -as I showed with the photos, the midi guitar is sending 2 on messages and 2 off messages. and as I mentioned the note will play back properly occasionally. so, I was looking at the Midi out monitor and what I discovered is that for the note that plays back correctly the midi out shows two ‘on’ messages and two ‘off’ messages, but the notes that play back as just clicks - the output is showing only one ‘on’ and one ‘off’. What i’m thinking is this: since the message that the midi guitar is sending must be happening very quickly, the pyramid is usually only recording the first ‘on’ message. The second ‘on’ message, though it’s not recorded, interupts the sustain of the first note, hence the note with a very short gate. If there was some way to force the pyramid to consistently record both on messages (or to filter out the first one) I bet the problem would be solved. I can’t find any setting that might accomplish this however…
Thanks for your continued interest in my stupid problem.


#12

If the output monitoring of the Pyramid is picking it up, surely it could also record it, I’m thinking.


#13

Finally, try switching your Pyramid’s midi out to “MIDI OUT”, not “MIDI TRHU” or “MIDI OUT + THRU”. Might be an issue with the out + through doubling it up!


#14

yeah, the output monitoring looks very different from the input monitoring. like i said, only occasional notes are sounding correctly and that is reflected accurately in the output monitor. it’s set to “midi out” already, btw. gah, well i’m a few beers in. time to call it a day. thanks so much for your thoughts - all very reasonable attempts to troubleshoot. if you have an epiphany, let me know.


#15

Hey there I’d like to say that I’m experiencing this as well, also using the Kenton Midi Usb adapter. The same adaptor works fine for the OP-1 (even when both input and output are connected), I’ve removed all possible sources for midi loops as well. Also it’s interesting that it’s able to play the synth live fine, just only once it plays back recorded notes does the gating issue to occur. When I get home tonight I’ll try running the midi output from a computer connected to the fishman to see if it recurs. I’m wondering if there’s something in the fishman’s midi spec related to a sustain pedal or if it spreads out certain info amongst other channels.


#16

43 PM

Figured it out - Triple Play Sends the same message on two different devices (so it’s like a built in midi loop… yay…) - my guess is this is confusing as all hell for the Pyramid - I’ll see if there’s a way to filter this without the use of a computer as DAWless is my end-game for TP + kenton + Pyramid + all the synths of ever.

So I found a way to filter it out using a comp, just use any midi filter app to only send TP Guitar to the Pyramid (I’m using midi pipe on Mac os x), Midi Fire is a good iOS option, I’m sure there’s a ton of other good options on other platforms. This does work with almost 0 latency cause MIDI is fast AF. Obviously this is still not ideal but I’ll post again if I figure out a way to filter it out without the use of a DAW/Computer of any sort - kind of disappointing on TP’s end but I guess they designed it for use with a comp where this sort of thing is easy.

Will the pyramid ever get any sort of Midi input filtering? Obviously this is a fault with the TP but I could see other applications wherein input filtering would be useful.


#17

Probably not.

I use a iCM4+ for stuff like that.


#18

Wow, thanks for all the info. Interesting that there is no issue with the OP-1.

Like you, I wanted to avoid using a computer, but I’ll look into the MIDI filter apps you mentioned (which will necessitate purchasing an interface, I guess).

The triple play/ kenton initially seemed like a perfect solution. If you do manage to figure out a way of doing this without a computer, I will fly to your town and buy you a beverage of your choice.


#19

Joosep, can I set the ICM4+ up so that it can perform filtering duties without being hooked up to a PC?


#20

Yup. You need a PC to configure it and then its fully standalone. Its actually not that “smart”. It can do your basic filtering, routing, merging and splitting, but nothing very fancy. But you can connect all your gear to the iCM box and have only one USB go into the Pyramid, boh for power and MIDI.
Another option would be BomeBox. That box basically can do anything you want as you can write your own scripts for it.
There is also a new kid on the block, the MdiHub. I believe its still in beta, but it seems promising.

Hope this helps :wink:


#21

Amazing. Thank you kindly.
(anybody need a lightly used Kenton?) haha