Notes entered with MIDI guitar not registering properly


#22

Hmmm. I now looked at your pics more closely. It seems the MIDI data for both “instruments” is on the same channel. Thats a tough cookie and I dont believe theres a very easy solution for that. Are you sure this is not a setup error? Maybe somethin on the TriplePlay software?


#23

The triple play software is utterly basic. As for channels, the only choices are: everything on one channel, or different channel per string. I’m using only one channel. I’m looking at the icm4+ manual right now and I’m wondering, too, if it is an appropriate solution. That is, I don’t see how I could get it to differentiate between the two events (but I’m very new to this MIDI stuff.)


#24

You wouldn’t be able to fix this very easily as I said. This would require some heavy magic. That’s why I suggested an error on TriplePlay end.


#25

Bummer. Thanks Anyway.


#26

TriplePlay information is sent on two MIDI ports. Port 1 is called Fishman TriplePlay or TP Guitar. Port 2 is called MIDIIN2 or TP Control. Note that useful information for performance is ONLY on Port 1. Many DAW will require that you ignore information on Port 2 (MIDIIN2) for TriplePlay recording to work. This port’s information is only used for communication back and forth between the TriplePlay controller and receiver and is unnecessary for recording or other MIDI performance purposes. The figure to the right shows both TriplePlay ports as they are available within Presonus StudioOne 2 for Windows. Fishman TriplePlay would be the correct port to select in all cases.

From the manual.


#27

Interesting -I did not see that when I went through the manual (somehow). So, it confirms what we already know. But there doesn’t seem to be any way to disable one of the “ports” on the tripleplay using their software. They are referring to ignoring a port within presonus software which I’m not using, of course. Can The Pyramid ignore a “port”?


#28

Do you think the ICM4+ could do the work of filtering out one of the ports?


#29

I am not sure. I do not have a USB device that creates multiple “devices”. All my USB gear just send all their data as one device and I indeed can route them. Also you can filter channels, but your data is all on one channel, so that wouldn’t work.
So I don’t know :slight_smile:


#30

My guess is you’d be unable to filter based on devices, I’ll open a support ticket with Fishman to see if there’s a way around this (and advise you to do the same) - like I wonder if “Hardware” mode can disable the other function or if its foot pedal add on handles filtering (or just doesn’t send the TP control device info). I’ll also look into the icm4+ solution - I used to own an ic interface and I did like it a fair amount - pretty flexible routing and I know several people who swear by their midi devices.


#31

I actually think now that it is possible with the iCM4+.

From the manual:

Multi-port USB devices can be assigned more than one of the available USB MIDI ports on the Host Jack.

So you should be able to access each “device” separately.


#32

Thank you both for all of your help. I’ll get in touch with Fishman and will do some additional research on the ICM4 +. I’m still waiting on a Cirklon. I wonder if I’ll have this same issue with it.


#33

Alright, I picked up an iconnectivity box (the mio4) and it worked. Had to use the software to disable one of the fishman’s two ports and that was it. Again, thanks!


#34

Thats great news!


#35

Adding another final thing to this post - got an iConnectivity iConnect MIDI 4+ and it works amazing and fixes the fishman issue. I’ve also started using it for tons of other midi filtering and routing and it’s been an absolute delight - I hesitated on buying one for a really long time and I really wish I hadn’t waited so long! It pairs really well with the pyramid too, allowing for really complex configurations to get exactly what you want.