MK1 Screen goes blank


Today the screen of my Pyramid went blank ( it was idle for a while ), and I could only get the display back after turning power off and on again. I didn’t see this before, could be an issue with firmware 4.02 ?
I am worried, maybe a hardware issue with the screen ? I cannot reproduce this, today it happened already 3 times.
If anyone has a clue, please give me a reply !

Did you drop a mail to the Squarp team?

No I didn’t do it yet. As a test I have downgraded to 4.01, and it happens with that version as well. How to report this to the Squarp team ?

Simply there.

1 Like

Thank You, I have sent a message there. Let’s see what they suggest.

Now it is the weekend, but usually they do swift feedbacks

In the meantime it got worse. Now I have only blank white screen :-(.

HI, have you got any update on this?
I’m having the same issue with an MkII just updated to 4.02


It looks like a hardware issue with the display unit, not a problem with the firmware as I see. Even with the blank display all functions worked apparently. Fortunately my MK1 was a second hand instrument and I could reverse the deal.
Now I have an mkIII on order, hopefully arrives within a week :slight_smile: .

Ok, thanks. Meanwhile, I downgraded to the oldest version available (3.32) and it seems to be working fine… I’ll test it a bit longer and get back on you if you want
Anyway, enjoy your brand new mkIII!

Thank you, I think I will just go with the latest firmware, I believe it will be superior to the previous ones.

I meant that you could try your old mkI with OS 3.32, but now that I’m reading your post again I see that you don’t have it anymore. Anyway, may I ask how do you know that it was an hardware issue?

Hardware issue seems unlikely, else we would likely have seen more reports, I have been using 4.02 for a few days and have not had the issue.

Edit: Ah there is another report of screen issues:

Probably best to contact support @Dr.pyra

I will thanks, the odd thing is that with 3.32 everything it’s working fine, with 4.02 the screen randomly turns blank. That’s why I think it could be a software issue

I will go with the new 4.02 firmware when my mkIII arrives, let’s see what happens. I can go back to 3.x easily even without display.
By the way, in my case I have tested the affected mk1 with firmware 3.32, and the blank screen issue was still there. That’s why it was more likely a hardware issue at least in my case.

Good to know, thanks! In my case the issue appears only from version 4.0 and up, so maybe it’s a software issue after all. I hope so! I wrote to the support, let’s see what they say.

1 Like


Today my new mkIII showed up and I have installed the 4.02 firmware. I have spent the last 4 hours to connect and configure it with my rig, and I didn’t see any blank screen so far.

1 Like

Great, enjoy it!
Meanwhile, I wrote to the support team and they answered almost immediately. They sent me a beta 4.03 version that seems to have solved the issue.
Thanks Squarp, great support!


Great to hear that ! It means it is indeed a blank screen issue in 4.02 after all. I will install 4.03 as soon as it is released.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.