Midi feedback loop or bug?

Hey guys so I am not sure if this is a bug or not.

Sometimes when I am entering notes in to learn mode with my sl mk3 keyboard, it acts like I am holding a sustain pedal. It won’t release notes. Yet I checked it out on my Roland synths and it’s fine (they don’t have midi thru) my wavestate only no matter what, seems to sustain any note in or out of learn mode… I have keyboard going to deluge and hapax, hapax out to deluge. Deluge sends midi out to the synths, but midi thru is turned off. Anyone else having issues with midi learn like this? Using a mio10 router. For the learn issue it works after I turn hapax on and off. Thanks!

Doesn’t the Deluge also send midi to the synths? Try and remove the Deluge out of your setup and see if that helps. I think that might be the problem

Yes actually deluge gets all the audio from the synths and the midi to all of them. I could try to remove deluge but that’s difficult since it’s the brains. Maybe I’ll just try to midi out to a synth directly and see. But again deluge had midi thru off, and isn’t sending midi to the keyboard.

Okay - erased last message because I don’t think I solved it immediately. So I now have wired the keyboard only going to the hapax. I still am getting the “stuck notes learn” bug here and there. Strange! I wonder if it is the early firmware?

1 Like

So the Hapax is not connected to the Deluge and you still have the same issue?

Do you only get this with the SL keyboard?
ie not if you play the live pads on hapax?

Is it happening when you record notes in?

In live mode does the key stay shown as ON ( one the onscreen keyboard)

You mention the mio10…. Are you connecting the SL directly to the hapax or they the mio10?

Ive not checked, how does SL connect … din, usb?

Im assuming there is no possibility of midi feedback.

What I’d be trying to isolate is if it’s a quirk with the connectivity with the SL ( eg hapx usb code) or some quirk in hapax function ( learn) .

Ideally I’d be testing connected directly , where I can ensure no feedback , and also with another controller if possible.

Also if your just sending note messages , you could use the midi monitor function to look for oddities ( if you have more messages, I find this moves to fast to be useful)

Hopefully you can isolate the issue , the file a bug report via the contact form.

Yes only with the sl mk3, but i dont have any other controller keys , never had issue before. It does not occur when pressing live pads on hapax.
It is happening when i use learn mode, seeming randomly.
Live mode it doesnt show as on.
I tried direct sl to hapax but didnt fix issue. Currently have sl wired to hapax, deluge sends clock to sl currently but i disabled notes etc.
Sl is usb, also has midi, tried both.
Ahh theres a midi monitor !!! Will try to check it when the issue pops up again! I think might be ok, will keep at it. Appreciate your detail!

Hmmm okay so I disconnected the deluge entirely from the keyboard, hapax seems to be passing on every midi signal from keyboard over to deluge even though midi thru is OFF on the hapax. Midi monitor showing out and in to be mirrored - it is definitely forwarding the signal out, and when I am doing pitch bend it seems to be having issues sounding correct (it seems to be not smooth, almost makes a stuttering effect when turned. Any ideas?

so midi messages are passed thru if:

a) midi thru is on
b) a track has midi output set, input = all active, track is active
c) a track has midi output set, input = port/channel (track does not need to be active)

so (c) means midi is always passed thru… from input to output (applying relevant IO settings) , regardless if its active.
Ive never seen midi passed thru outside these use-cases. ( * )

so do you have (c) in play? have you set input channel/port explicitly.

I find these methods work really well
EXCEPT (c) is problematic if you are doing thing like trying to record a sequence from a sequencer… (see my eurorack video on why this is messy)

what Id ideally like is for tracks to have a ‘monitor’ state, like ableton
IN = play notes thru, regardless of pattern (this is what we have today)
AUTO = play notes thru ONLY if its an empty pattern
OFF = never play notes thru.

Ive mentioned this to Squarp, but I think perhaps its a limited use-case, so will need more votes :wink:

note: there is another related feature request to do with ARM (for multi-track recording)… this may also play in this area, as in Live AUTO also only plays thru on ARM’d tracks.

(*) in the past, I half remember a bug where it used the incorrect channel… not sure this is fixed, but in my current setup it appears ok - so possibly fixed.

Hmm yeah looks like everything operating properly, except I’ve discovered my pitch Bend from the keyboard is glitching bad. Not sure why. Do you have any issues with pitch Bend? Thanks!

Pitchbend seems ok from playing … but not checked data.
( it’s 100% ok in MPE as that I have tested thoroughly)

Is your wheel ok on other instruments?
I had my PW fog glitchy on my Virus TI a few years back, it’s basically just a pot with a spring, and like all pots can go scratchy and the spring also can loose tension. I replaced and it was lovely afterwards :slight_smile:

1 Like

This is going to sound weird, and probably won’t help at all, but when I got my Hapax, it was glitching/holding notes like crazy. I realized pretty quickly that the SD card was not inserted all the way. Once I turned it off, put the card in properly, and turned it back on, everything was fixed. Maybe a coincidence, I don’t know. Might be worth reseating your SD card just in case. Haven’t had any issues since I did this.


Ok so I also just had a hanging note. I also have a mioXL, but I am pretty sure nothing is sent to the Hapax except clock from my DAW.

Anyway, it happened after I changed the order of some of the midi FX on the Hapax. I tried rebooting the synth, but that didn’t help. Eventually what helped was just play the note that was hanging one more time on my master keyboard (which isn’t connected to the Hapax, but through my DAW).

Kind of weird, but I can imagine this happening, since I had Arp & Random (and also LFO, but I don’t think that is relevant here as it was just sending a CC) FX turned on which I changed order. I guess I swapped them at the wrong moment: just after a note on message was sent and before the note off message was sent. After the changed order, that particular note wasn’t sent to the synth anymore, but apparently the Hapax still had it in its memory and maybe the “note chasing” option may have kept sending it or something like that.

Does seem like a bug though…

= edit =

OK it seems the problem was still there. The Hapax didn’t seem to send any new notes to the synth anymore, while I was able to play the synth from my DAW. After I changed the clock source back to internal and pressed STOP twice (which will probably send a stop all notes message) on the Hapax, it behaved like normal again. So it defenitely was a problem within the Hapax.

yup, as you say, really likely to be notes-in-flight either not getting the note-off… possibly due to hapax thinking the note-on was for a different note. (i.e. got its tracking mixed up)
(I half remember similar issues with the Pyramid at some point)

unfortunately, this’ll be highly dependent on what fx you used, what the order changed was etc…as it’ll likely be a particular combo … and to make matters worst (for reproducing) what notes are ‘in flight’ at the time :frowning:

best hope is we can reproduce in simple steps… and report it.
though, I suspect over time, users will just naturally find that certain FX are usually involved …and so likely culprits.

as for the behaviour of the keyboard etc… yeah, thats pretty normal, unfortunately, Ive seen this with daws/sequencer before… the keyboard can clear the note, but then the sequencer still think its active and vice versa … so end up in the odd state… ive had keyboards acting in reverse, where pressing a note stops it, releasing it starts it :laughing:

as you said, normal fix is double-stop, which sends all-notes-off (and all-sounds-off too?)

Yes as long as they make it possible to use the transport knobs while clocked to an external device, this is not a big deal. But now I have to change the clock source setting first in order to make it send an all notes stop message.

1 Like

That is worth bringing up as an separate issue … even if the transport is not stoppable - we still need to be able to do a midi panic.


Well I made sure there’s no midi feedback loop but sometimes occasionally am getting locked notes on learn function. In other words it just keeps adding notes no matter what I play and no release. But if I turn it off and back on it’s back to normal operation. Unsure how to relocate but it does happen from time to time.

really you need to use the midi monitor (in hapax, or externally) to see whats going on…

as its only happening via midi… the most likely scenario is the number of note on are not matching notes on… or perhaps something odd with those midi messages…

unfortunately, impossible really to say, without more data :frowning:

if you can look at the midi data, hopefully that will show WHY the hapax is acting as it is… then that’ll make it ‘easier’ to track down why that situation is occurring… and where precisely.

1 Like

Ahh yes I will check the midi monitor when it happens again. Totally am thinking it is a bug, because the issue disappears when I restart it. But yeah I will check monitor when it happens again. Thanks!

1 Like

OK I think I just found a bug which causes hanging notes:

When a note is playing and you mute that project, the note will hang. I can replicate it every time again. Will report Squarp