Hermod Skipped Gates (v 1.71) - CV Clock In

Firstly, I’ve read through all the forum posts I was able to find on “skipped/delayed gates” and haven’t found any answers. Most of the posts are a little dated and refer to previous firmware versions so hoping someone can help me figure this out.

I’ve upgraded to firmware version 1.71.

I just wanted to set up a quick gate pattern to start testing things out and noticed that Hermod appears to randomly skip or delay gates.

Here is how I’ve set things up:


Patch Notes:

  • Pam’s New Workout Output 1 > Mult > Mult 1 > Hermod CV D IN
  • Mult 2 > Scope
  • Hermod Track 1 Gate Out > Scope

Hermod Setup:

  • Clock Source Set to CV D
  • Clock IN DIV and Clock OUT DIV = 1/4

Pam’s Setup

  • Output 1 is a X4 Gate with no other alterations

Based on the above, what I expect to see are both sets of gates lining up as close to perfectly as possible on the scope.

However, while Pam’s gates are good, Hermod randomly experiences either a skipped gate or what I can only describe as a delayed or “scrunched” gate which results in a glitchy sound when gating a VCO.

It’s worth noting that this behaviour is non-existent when clocking Hermod internally or via the host/midi port.

I can certainly rethink my clock setup using a midi/USB workaround, but would much prefer to keep my clock analog/CV based for a variety of reasons.

I’ll admit that Hermod is a brand new addition to my rack, so I’m hoping this can be resolved with a setting or configuration change.

Any help/insight is greatly appreciated.


UPDATE:

I am able to get consistent gates using this workaround:

  • KeyStep Sync Out > Pam’s CLK and Run (via HOSA YMM-261 cable)
  • KeyStep USB Out > Hermod USB Host In (with Hermod clock source set to Host Port)

I was hoping that clocking Pam’s via KeyStep but maintaining the CV clock in to Hermod would work… but I see the same issue with skipped/delayed gates.

Anyone else experience this issue?

Use the contact form on squarps website to file an official bug report. they’re pretty good about responding but it is summer break in the EU so expect delays in communication. What firmware were you on before 1.71 If I recall you may need to recalibrate your CV in and out as there were some changes a few firmwares ago. worth at least checking. There’s instructions in the Hermod manual site.

Thanks for the reply! Much appreciated.
Actually don’t remember now which firmware version I was on prior.
Found the procedure to calibrate the CV ins and outs… will try that and see if it works and will file a bug report if ever that doesn’t work :slight_smile:

when this happens does the tempo (bpm) seem to glitch as well?
this might help indicate if its the output that is delayed, or the input…

also what happens if you program a gate pattern (rather than use the clock out) - does this also get ‘delayed’?

also, id try to use a higher clock in div (1/8) see if this helps, as more clocks pulses potentially means a more accurate calculated tempo.

quite a while back, I did some tests with using cv for clock vs midi, and I generally found the latency via midi was better - so, I rarely use cv as clock in now.
(also we only have 4 cv in or hermod, so Ive usually ‘better’ things to use them for ;))

whats kind of ‘unexpected’ here is, Id have thought if the clock in was inaccurate, the timing would generally start to deviate , rather than just one gate be out, and then it come back in line…
but perhaps this is because it the clock out logic , rather than the tempo…

@astricii

I just sat down to run the calibration and decided to try reproducing the issue. All appears to be normal now. I’m a bit confused as I literally haven’t unpatched or changed anything apart from leaving my system turned off for a few days.

I had tried to power on/off when I ran into the issue and even took screenshots and pics on both my hardware and software scopes to be sure I wasn’t going crazy.

Really appreciate the response as it was one of the more confusing issues I’ve run into.

I’ll keep my eyes/ears peeled and will run the calibration if needed.


@thetechnobear

Reading your reply made me think about a few things and having the ability to start/stop via KeyStep (except for ‘arming’ Hermod) might be more interesting in some scenarios… and freeing up the CV in does indeed make sense considering we do indeed have only 4 inputs. Also… it’s not like I would use the host port for anything else right now.

Both configurations now appear to be working flawlessly now so I have options.

Definitely unexpected as you say… there really didn’t seem to be a pattern to the behaviour. It wasn’t gradual at all and didn’t appear to be a related to resolution. I heard it before I saw it and then started doing some testing and couldn’t figure it out.

I’ll set up my scope to keep an eye on things in my upcoming sessions and will test out your suggestions if the issue occurs again.


Truly appreciate both responses. Thank you!

Either way, super happy with Hermod so far and looking forward to digging into it more soon :slight_smile:

2 Likes

One last question was the issue present on a project created in an older firmware? I know there’s a lot of broken cv in on my old 1.6x projects that don’t exhibit the same issues when I make new projects on 1.71. I just kinda let the old stuff go and moved on :slight_smile:

@astricii

The project was in fact created in a previous firmware version so that sounds like another potential root-cause. Thanks for the follow up :slight_smile:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.