Hermod Compatible USB MIDI Controllers


#1

I’ve tried a few USB MIDI controllers connected to Hermod’s “usb host” and here are the results:

  • AKAI MPK mini - WORKS
  • Arturia MicroBrute - WORKS
  • Roland A-800PRO - DOESN’T WORK
  • Yamaha S90ES - DOESN’T WORK
  • Yamaha MX61 (claims to be USB Audio/MIDI Class Compliant) - DOESN’T WORK

Can anyone else post their results?


#2

ARTURIA KeyStep is OK


#3

Hi, thanks a lot, we will work on it!

To report Hermod issues, the best is to send us an email to contact(at)squarp(dot)net


#4

I posted my results, here, in the public forum so that other users could see for themselves without having to wait for an official list! :smiley:


#5

Great, we will soon create on our website a list of tested and approved USB controllers!
In the meantime, we will work on the HERMOD USB drivers.


#6

It might be good to maintain it as a forum thread or wiki page, so it can be easily updated (possibly by the community) :smiley:


#7

Teenage engineering OP-1 works fine in input of midi notes.
Didn’t try to send a clock…


#8

Have tried Kawai VPC and a MicroBrute – both work fine as long as they are plugged DIRECTLY into Hermod’s HOST, but neither of them work through a USB hub. In fact, Mac/Ableton does not connect to Hermod through a hub either!

Tried several different hubs, tried powered and unpowered – no luck.


#9

The small midi keyboard Miditech i2-mini 32 works properly.


#10

Teenage Engineering OP-1 - WORKS


#11

So we should not report Hermod issues here on the official forum and only via email?


#12

I’ve been posting in the forums so other people in the community can see what’s going on. Otherwise, there isn’t much transparency to what issues have been reported. I’d love to see a proper bug tracker!


#13

Hi Cowboy, I just picked up an MPK mini to use with the Hermod - I’ve plugged it in to the USB host input, the keyboard is powered up but when I play it the Hermod isn’t receiving any notes - was there any configuration required? I can’t see anything in the manual about it so thought I’d ask you. When I plugged a different keyboard into the MIDI in it worked straight away… Appreciate any advice!


#14

I honestly don’t remember, it was a while ago that I tried it!


#15

Damn! Thanks anyway


#16

Hi! Is it possible to add USB-support for Arturia Beatstep Pro?
Sometimes it’s horrible to make difficult sequences directly by buttons on Hermod.
Or if it’s possible right now - please share a workflow.

Thank you!


#18

have an akai mpk mini, powers up but doesn’t work for me either.


#19

Yeah it sucks. I’ve emailed them about it but it hasn’t been fixed. The only reason I bought the MPK mini was to use with the Hermod :frowning:


#20

Hi,

Do you have any USB hub between your controller and Hermod ?


#21

No, I just plugged the MPK mini straight into the Hermod USB Host input. The MPK powers up when connected but does not send any MIDI data to the Hermod.