Copy/paste/delete not functioning

Hi all, I’ve recently started playing around with the Pyramid and have been having a blast. One thing though that’s really been bugging me is that I can’t seem to get copy/paste/delete functions to work as per the manual (i.e., 2nd + Copy + Track, then 2nd + Paste + Track). I’m on version 2.30. Is there a setting I’m missing? I’ve reviewed the manual and can’t find anything other than it should just work.

Thanks,

-Javier

Howdy!

Press and hold 2nd + COPY. Keep holding. Now press on the track you want to copy. Release.
Press and hold 2nd + PASTE. Keep holding. Now press the track you want to paste to. Release.

Easy peasy!
Hope this helps :wink:

2 Likes

Thanks for the response joosep, this is exactly what I’m doing, still not working though. In Step Mode a little window pops up and says “Note: Steps copy OK.” In Track mode I understand there should be a similar pop-up window when you successfully copy a track and paste also but there is no functionality.

OK, I was able to get it to work. It seems that I might have found a bug/issue.
My original problem apparently stems from my workflow: I’m creating 8-bar tracks in Ableton and exporting them to my SD card to a project that I created on the Pyramid. Those tracks will not copy or paste. If I create an entirely new project in Pyramid and build a track, that track WILL copy/paste/delete.
So, in my case, I have to do either all my work in Ableton or all my work in the Pyramid which isn’t so bad, but it is a hassle since it totally locks out the Track Pattern feature without being able to copy one pattern to the other.

That’s interesting, hope you or someone can resolve this issue.

i also have problem with copy/paste:

i have a couple of step live-recorded and now i want to experiment with the recording a bit, so in order to go back to my initial recording i copy all steps : in Step-Mode i press 2ND + copy (display says: Note, Step Copy OK.

Now i modify my pattern (changes notes, add steps…) and at some point i want to paste my original … it just doesn’t paste anymore.
if i only remove some steps, it works
if i add some steps paste doesn’t remove the added steps

it works as expected if i copy/paste the track - wich is quite a bit unnecessary complicated

i’d like to add a question: how can i copy a pattern including all automation?

Howdy!

I would like the give the long aswer.

Copy and paste actually started with: 2nd + COPY + PAD and 2nd + PASTE + PAD. In step mode it copies single steps. In track mode it copies entire tracks (with everything inside). 2nd + PASTE is just a shortcut to copy the entire page of steps.

Tip: You can also copy a range of steps. 2nd + COPY + 1st PAD + 2nd PAD. To paste a range you simply paste to the first destinates pad.

Hope this helps :wink:

correct, paste is ‘additive’ i.e. it takes what is in the destination and adds the new step onto to it.
it doesn’t replace (as it would do on a computer/daw)
this is no real issue, for a replace, just delete first i.e. 2nd+DEL , 2nd+PASTE

and once you know its additive, this actually is fun e.g. try it with CC modulation, you can kind of overlay two modulation patterns… or with notes, have two note patterns and create a 3rd which is a combo.

also remember you can copy patterns over multiple pages by zooming out when you do the copy - when you paste its needed it will cross pages.

(sorry im using patterns here loosely as a group of notes/cc… not the ‘squarp pattern’)

1 Like

it’s all good … i think i was just a bit confused as it all works differently than on the elektron machines i’m used to

a whole (squarp)pattern can copied by going to the track page, switch to pattern view and then do the copy/paste thing

you should report the bug about not being able to paste tracks imported from ableton to squarp (there’s a “Contact us” form on their site).

Hi there ,

Somehow I’m only able copy and paste the entire track ( Instrument , notes etc ) only .
It doesn’t copy inSTEP mode the notes only into another track .

I tried several time as explained here before .
Is there still a bug ? ( I’m using latest beta version )

Many thanks

Word.

2nd + copy + Pad(s) for the step(s) you want to copy. You have to press them in that order or it doesn’t copy. You will see if the copy is successful when you release your fingers - Pyramid will tell you “steps copied OK”

Then

2nd + paste + (the) Pad you want the first step of your copied steps to land on. Again - Pyramid will give you a little dopamine reward.

You can’t pick up three steps and then paste them to different steps with one move. Copy will copy a single step or range. Paste will only let you paste that range onto a starting step, the other steps will land spaced out as they were when you copied them.

jim

2 Likes

Hi Jim ,

Thanks again . Appreciated your advice .
Tried tons of times and somehow nothing happen not a single note is copied to next step …

Do I have to be specific with the copied range ?

Yo

Yes you need to be specific. You need to make sure the steps you are copying actually have notes on them. So the pads have to be lit - showing there’s a note on the step there. If you’re selecting a range then you need to select the first lit step and the last lit step and Pyramid will pick up everything in between.

I’d suggest playing with the Zoom settings for a bit of practice. So, keeping it simple, let’s say you’ve got a basic 1 bar, 4/4 track (or pattern) in play and you’ve got notes on Steps 2 and 3 that you want to move to 5 and 6. Make sure you’re zoom is x4, steps - 16. You should be seeing your steps represented across the 16 pads with pads 2 and 3 lit where you’ve placed notes.

Remember if you are in Mono mode, the pads will be lit on every step there is a note, regardless of pitch. That should be fine for this practice run. If you are in Poly mode (switch between these by pressing record) you’ll need to move the main encoder or encoder one up and down the piano roll to navigate to the notes you want to copy. The note you’ve navigated to will be highlighted on the piano keys down the left of the panel. And the steps should be lit. If you’ve got lots of notes at different pitches on different steps, you’ll see the pads lit and unlit as you scroll up and down the piano roll.

Get the piano roll to the note you want to copy. Select the steps that are on lit pads or between lit pads, 2nd+copy+ the step or steps you want to copy (in this case, you would press steps/pads 2 and 3 simultaneously. Then 2nd + paste + step you want the copied steps/pads to land on (in this case step 5).

Try that and report back.

Are you even getting the “steps copied OK message”? If that’s not coming up then you’re not selecting steps that have anything to copy on them.

jim

1 Like

Yeah finally made it work :wink: thanks Jim .

It takes some finger technics :wink:

YAY!
jim

1 Like

hello, two things re: copy/paste.
1)i’ve been copy/ pasting tracks just fine but now suddenly unable to do it. nothing happens (ie. no copying no pasting, no popup window etc.)
i am not importing stuff from computer, simply programming inside the pyramid. i can copy/ paste steps but not tracks.
2) I have never been able to copy/ paste patterns. someone in this thread mentions that this is possible using the same 2nd & copy pad technique. really?
any ideas anyone?

*EDIT
it’s seems pyramid will copy/paste tracks with little or no patterns. but the tracks i really want to copy have 32 patterns. could this be the reason?

this works for me… just enable patterns, go to pattern selection screen ,
then use copy/paste as you would a track or whatever.

anything is possible if there is a bug…

to be clear, you are saying that you are able to copy/paste a track if it only has a few patterns, but not if it has a lot (32) ?
do you know at what number of patterns the copy/paste stops working?
are you able to replicate this on a new project? ( to eliminate possibility thats its something else)

I use patterns quite a bit, and often paste tracks and have not noticed this…
BUT I usually have something like 4-5 patterns.

that said, I just did a quick test here where I created a track with 32 patterns (using copy/paste pattern as above), and I was able to copy/paste that to a new track.

the only thing i can think of is perhaps you are running out of events…
as I can imagine if you have lots of patterns, then this might mean lots of events…
and if you’re copying to a new tracks thats doubling the number of events.

(this would explain why it works for you to copy tracks with less patterns/events)

you could test this… by saving as a new project (for testing purposes) , and then deleting some tracks to ‘make space’, and then seeing if you can copy paste the ‘offending’ track.
note: this will only work, if you are able to clear enough events by deleting other tracks… i.e. if this offending track takes up 75% of events, its not going to work.

My first guess would also be simply running out of memory, for total events or copy-paste buffer (depending on how it’s implemented). There’s a free memory indicator in the info screens, that should provide a clue if it’s about the total event limit.

That said, on 2-3 occasions I’ve seen copy-paste stop working for no apparent reason where a reboot cleared the situation (on the same project, so it was not an out-of-memory issue). Those occasions have always involved patterns, so I do think there are some bugs left regarding pattern operations, but haven’t found anything remotely reproducable.