Cannot Import Type 1 .mid Files for Separate Patterns


#1

Greetings, all.
Still a Pyramid n00b here - 1 week!
(Not quite a MIDI n00b tho :wink: )

Importing Type 1 .mid files into the Pyramid:

  1. Create a Track with multiple patterns on the Pyramid.
  2. Save the project
  3. Move the SD Card to the laptop, open the .mid file in software sequencer
  4. Edit the notes on the separate tracks on the sequencer
  5. Save as a Type 1 .mid file, paying attention to all appropriate naming conventions
  6. Move the SD Card back to the Pyramid
  7. Load the Project and all note data is on the last Pattern only (All note data as in: All note data for all tracks in the .mid file)
  • Have tried 2 different software sequencers (Sonar & Anvil).
  • Semi-verified these are Type 1 .mid files by their behaviour opening them in Live
  • Tested importing a Type 0 .mid file into a Project with multiple Patterns on the Track, and behaviour is different (so, therefore kind of verifying it’s not .mid file type issue)
  • Note: importing a Type 0 .mid file into a Track with multiple Patterns puts all the note data on the first Pattern

Ref:
http://squarp.net/modesaveload#ancre06
Right hand side:
Note: if your track includes multiple patterns, it will be saved as a type 1 midi file (multiple track file). In the same way, if you import a type 1 midi file, all tracks will be imported as multiple patterns.

Is this a known bug?
Has anyone had expected results with this type of process?
Is this another edition of Stupid n00b Tricks?
Help?

…whut?


#2

yeah doesnt work with cubase 9 either.
though slightly differently (for me) , i had 4 patterns, and notes appeared to have moved from pattern 1 to pattern 4.
so id guess its a bug.

report it to Squarp perhaps they can take a look, or perhaps already identified it for OS3.


#3

Thanks for the response!

Actually, your test with 4 patterns was my initial issue. In all cases that I’ve tested, Type 1 .mid files move all note data to the last Pattern.

Since you can also duplicate this (I was actually hoping more people could dupe it), I figure I’ll fill out a Bug Report.

Thanks again!


#4

Just in time! I am about to try to import 2 .mid files then translate them to anologue synths via the squarp.after my nap ofcourse. If it triggers the ol ADD then i’m just going to have to play them into the sequencer myself.( hope it works the pieces are kinda hard to sight read)… a guitar player wrote them on encore, live with his guitar…let guitar player jokes begin cuz we know they are funny cuz they are true.
.


#5

It’d be interesting to hear if you’re able to import - let us know if you were/are able to import or if you found a workaround other than re-recording the data.


#6

nope.the files copied to the removable drive (sd card) but show as … on the squarp.and doesn’t load .I asked buddyboy to use separte midi channel but still no go…files created on a mac using Encore .


#7

What do you mean “doesnt load”?
Do you get an error? Or does it load and theres no data at all?


#8

squarp load screan is as follows. 2nd +save/load. result. backup and …(dot,dot,dot) that’s it
I check sd on compy and clearly there are the (now)3 midi files complete with names(5kb .mid files
looks likes like it’s back to ol’ mmt8 way.play the notes in.at least that’s way faster than step entry.


#9

Are you familiar with the required naming conventions and folder structure?


#10

nope.but transferring a standard .mid file should be easier and should take what 3 seconds?
I’m thinking now …i’m going to need to hook squarp to compy,play sequences and record them as midi direct into tracks. just setup track lengths etc… and record them as they play off compy.
ive done that with EMX so it might work with squarp.


#11

It’s a bit more complex i think. Ive only had my Pyramid a week, but it doesnt use just a standard midi file.

Im not at my computer (on my phone right now), but for the Pyramid to recognise the Project, there is a directory for it, it has a core.pyr file (i think), and then the .mid files for the tracks: track01.mid to track64.mid.

What I’d suggest in my ignorance is:
Create a project on the Pyramid with a Track with patterns enabled that is the length of the track you want to import. Save it. Then transfer your mid file to replace the Track file created in that dir and name it correctly.

Its my understanding that loading that Project should have your imported midi tracks. However, what I and technobear are experiencing is that data for all separate midi tracks in the Type 1 file are put in only the last Pattern on the Pyramid, which is counter to what the documentation would indicate.

Ref:
http://squarp.net/modesaveload


#12

we are the same page then.just need to find a workaround that is easy and fast.
3 separate midi tracks=main melody midi channel 1.channel 2 bass,channel 3 harmony voicings (guitar)


#13

Im still waiting to hear from Squarp.

Im thinking one workaround would be going through the steps for importing a bunch of Type 0 files on separate Pyramid tracks and then copy/ paste to Patterns on the salient tracks, but I’d swear i saw someone post that they couldnt copy tracks that had been imported ( possibly same or related bug, if it’s a bug). I havent tested that yet.

Or realtime recording is an option.

Ive got a lot of data to import so Id rather just transfer files instead of getting into gruntwork.


#14

lol ya figure the grunt work was done by the composer and I could just add my parts as instructed.ugg.


#15

Oh. I didnt fully read your last post.
Unless you’re trying to import where the destination is one Pyramid Track with multiple Patterns, none of this applies. Separate Pyramid Tracks with Patterns not enabled are Type 0 mid files (I think), where Pyramid Track 01 = track01.mid, etc


#16

If I hear from support, I’ll post here.


#17

nope using multiple tracks…type 1 .mid files


#18

Good on ya .I’ll be watching.


#19

Yeah - still haven’t heard back from Squarp Support, but grunt workaround:

Create a Type 0 .mid file for each Pattern, Import as separate Tracks, Copy/Paste via [Step] mode into Patterns on the destination Track. Not sure if there’s any drama due to some tweak or other undocumented…“feature” (read: bug), so YMMV, but I was able to do it in a test environment. I’m still too new to the workflow to trust myself with real data…give me an hour or two. heh

Ridiculous workaround IMO considering the documentation states you can import Type 1 .mid files, but perhaps I’ll hear back from Support.


#20

chill out, everything has bugs :slight_smile: … given you are the first one to report it, its obviously not used that much.
hopefully they will fix in 3.0 now you have reported it.

personally, Ive only used the exporting , since my workflow is create on the Pyramid, then move it to the DAW for ‘finishing’, so never really been interested in moving it back to the Pyramid.

also the workflow is kind of ‘broken’ going back anyway, as the whole thing is ‘flattened out’ into tracks (patterns and tracks) when doing into the daw… so if your going to import back, you then have to manually start selecting ‘groups’ of tracks, to import back into a pattern.
… and of course it doesn’t work anyway with Live, which I like using … as patterns turn naturally (if not automatically) into
clips.

anyway, I can see it important if you use the Pyramid for performance , so hopefully they will sort you out for 3.0