What Omni Mode are you using? Pyramid with a mix of Keyboard/non-keyboard synths

From the settings manual:

MULTITRACK OFF will play notes and CC on the current track, regardless of the controller channel.

  • MULTITRACK BANK X will play channel 01 events on TR01X, channel 02 events on TR02X, …channel 16 events on TR16X.
  • CH01 to CH16 will play events of the selected channel on the current track. Other channels are always sent thru MIDI A output.

I’m assuming that MULTITRACK BANK X is more desirable for multiple synths with built-in keyboards if you want to use the synth’s keyboard to play on and be able to play them when the Pyramid is in standby?

If you wanted to use a master controller, would you use MULTITRACK OFF?

This is assuming you have local control off across the board and are using a Thru off the Pyramid to feed back into the synths, and a Merge on the Pyramid input, to combine all the synth outputs into the Pyramid.

I use OMNI A. I put every synth on a different channel (Hw synths, eurorack, bitwig), and I have the patterns on the Novation SL MK3 set up for the corresponding track on the Pyramid.
That way I can set live mode on a track on the pyramid, and live sequence all tracks I want to record live (by using for instance a keyboard split on the sl mk3).
CCs from the controller will also go to the correct track, so you can record CC automation.

I don’t normally use sequences but switch tracks live when I need them. Sometimes I put pre-sequenced stuff on bank B, so it doesn’t interfere with the live stuff.

This is what I did on this video to record, loop tracks, control effects etc.


1 Like

Do you have your MIDI Outs configured as “Out”?

I’m noticing that, with this setup, I have to go and flip tracks all the time, which is kind of annoying when you just want to play your various keyboards.

If I set it to “Out+Thru” the Thru doesn’t work, despite the manual stating it should:

MIDI out + thru (all messages received on the MIDI input will be sent directly on the MIDI out A, together with Pyramid MIDI messages).

“Thru” works as expected, but the Pyramid stops sending anything that was recorded already.

I have it on OUT, but I don’t have to go and flip tracks. I have midi in echo set to “allow echo”, maybe that has something to do with it.

1 Like

Ah, yup. I lost that setting in a power cycle.

did that fix it?

I haven’t tested yet, but it donned on my last night that I did have it working when a wrote a new ditty.