Velocity ... always back to 0

Hello … has anyone else experienced this issue? When in Live mode and trying to use the smart to play external instruments… frequently I can not play because the velocity keeps returning to zero. Only way to raise it is with X/Y axis on touch pad … and usually just goes right back to 0. Also seem to have issues with Velocity in Step mode as well. The 3 knob while in step for velocity does not work. Please advise …

This has happend to all of us. :wink:
Its the accidental touch of the touchpad. Turn te touchpad off in the settings and you will see the problem disappear. Of… learn to manage your movements around it.

Hopes this helps :wink:


Yes, to all of us :wink:

Ok … I will give it a try. Thanks!

I cannot seem to use the 3 knob to set velocity while in step mode.

I thought perhaps it is due to using a controller to automatically set the note and velocity. there is a setting for this and I have not tried turning it off.

I want to use the controller to set notes and then change the velocity with knob 3, but it pyramid continues to create notes with the controller velocity even after changing it with knob 3.

Is this what you are experiencing as well?

I don’t think it’s actually a touch of the pad. Velocity is on the X axis so to accidentally set it to zero would need you to touch the very left hand edge. It’s probably an accidental touch trigger kicking off when you just operate the pyramid, touch other buttons or knobs, or slight case flex. Basically an over sensitive touch pad and likely something that can be fixed in firmware. I tried reassigning the pad to something else but then realised there isn’t a way to assign it to velocity. Or is that “pressure”?

I turned off the touchpad and all is well! However now all midi notes are at a default of 100 velocity. Which is fine for me I can go back and use knob 3 in step mode to change the velocity for “aftertouch” or human touch dimensions. IT is better than it shutting down to 0 every time I go to live mode z(which was happening). I do understand what you are saying though as I also use my keyboard controller to originally trigger the midi pattern when recording in Live mode. Does this now also automatically record at 100 velocity without regard to the key velocity? I have not had a chance to try it yet…

I agree … but it did solve the initial issue. Not quite sure what it is probably does need a firmware fix. Now wondering about lack of aftertouch velocity with midi keyboard controller though. As the default for every trigger is 100. Please see my reply to addisonday above … :slight_smile:

When you disable the touchpad, you only disable the touchpad, everything else still works

If your MIDI controller sends velocity data then Pyramid will also record it. When you are in STEP mode and press a note on your velocity sensitive MIDI controller, then Pyramid will “learn” (sets note and velcity to that inputted value).

In LIVE mode Pyramid will record incoming MIDI as you send it, regardless of the velocity value on Pyramid That means if you are on LIVE mode and recording and insert a C4 with velocity 50 with your MIDI conrroller, than it will be recorded as such. The velocity value on Pyramid is used when you use the pads on the Pyramid to input notes.

I myself did not disable the touchpad, but simple tried recognizing my movements around it.

Hope this helps :wink:

Hey Joosep

When remarking that the 3 knob will not work - let me clarify:

in STEP mode, with NOTE LEARN enabled, playing a note on the controller will result in the VELOCITY value displayed reflecting value from the midi IN controller, and used for new notes as they are entered on the pads, just as it should.

Now, once this VELOCITY value has been set by the midi controller, you should be able to use the 3 knob to change it, but this will not work. If you try, the value will change on the display, but the notes will continue to be added with the NOTE LEARN value.

It is not a consistent logic because knobs 1, 4, and 5 will still work to change note, width, and offset.

The workaround/hack is to change the note away from the NOTE LEARN note with knob 1 or image, and then back again. Then the 3 knob value will be used for new notes.

this seems like a bug to me

*EDIT: This has nothing to do with the touchpad, but was the second issue OP mentioned.


Now I get it! Yes I am seeing the same happening on my Pyramid. Strange. This certainly seems like a bug!
Its odd I havent even noticed it, tho I use the STEP mode all the time.


Yes … Thanks for the insight!

I submitted the knob 3 issue to Squarp and Jean got back to me very quickly!

He said the knob 3 issue in STEP mode isn’t a “bug” per se but that he intends to implement a change whereby knob 3 will change velocity for NOTE LEARN notes.

Wow! Amazing responsiveness I have never experienced from a company before. I think it is a real privilege to use a product developed and supported by a company like this. They listen to and respect their users. More instrument companies should be like this! Obviously, the niche market makes this possible, but it is so refreshing!

Thank your Squarp for being awesome


Ok, my touchpad is definitely bugged. It forces itself back to zero as soon as I take my finger off. Press somewhere and velocity rises up, take finger off and it drops back to zero. I now have to disabled it completely to get anything done.

That sounds strange indeed @mongrol.

Could you please check Settings -> Misc -> Touchpad Relatch ?
If no relatch selected, the touchpad (assigned X or Y position) will keep it’s last set value. If a value is selected (for example 0), the touchpad will send back this value when the touchpad is released.

It sounds like your setting is at 0.

Hope this helps :wink:

1 Like

Also you could try with an external midi keyboard controller.

Go in STEP mode and push a key on external keyboard and it will show velocity/note on the readout in Pyramid.
It should stay on the level that you hit a keyboard key. And it should not return to “0”.

Touchpad is set to no-relatch. It definitely seems to be intermittant. I’ve enabled it again and will do more testing over the weekend.

@soundklinik . Yep, that operates normally at the moment. When the bug reappears I’ll test with an external keyboard too.

Ok, done some testing and I’ve pinned down the issue. It’s board or case flex. Velocity goes back to zero when I press the pads on step 2,3,4 (mainly 3) or the “Channel” pad above it. If I gently press them the velocity won’t change. Under normal operation it’ll zero on 80% of presses. It also zero’s when I press the metal case between the pads around that area, although I have to press quite hard. This tells me it’s internal PCB flex rather than case flex. The fact that it’s goes right to zero indicates it’s triggering the very left hand side of the touchpad sensor.

Perhaps a sensitivity or some kind of threshold option could be introduced for those affected to adjust?

1 Like

Thats no good. I would send it to Squarp.

Out of curiosity, which version do you have?

v2. It’s 2 months old.