V/Oct CV to Midi


#1

Hi there loving the Hermod thus far! I originally got the hermod so I could take pitch from my harmonaig (4 part eurorack quantizer) and send that pitch data to the midi/usb outs. I have tried everything and i cant figure out how to set up cv>midi pitch translation. Is anyone having luck with that?


#2

Bump? Anyone? I find it hard to believe that no one else is trying to use this thing for cv > midi for pitch?


#3

It’s in settings, CV input settings https://squarp.net/hermod_settings
But it’s unreliable at the moment, even with pre quantized signals… (solved soon)


#4

Hi EarthCry,

I was trying the same yesterday. using pitch and cv out from my Metropolis Sequencer into CV inputs A and B. I was using an empty track with in track settings the CV source configured : CV/gate AB.

Tried differend CV-ranges, and quantize on /off but not a good result. I did get midi notes but not sometimes wrong notes and double notes.


#5

Add the midi out effect on an empty track that has cv / gate in on a&b / c&d.


#6

I did that and the notes are played on the midi device ( JD_990 synth ) but sound off tune.
I still are investigating, maybe I did forget something, or it is a bit buggy


#7

I tried this today with midi out to a monomachine - was perfect. Try turning Quantizer Note with in Settings > CV In to On (Gate).

Does that fix it?


#8

No, this didn’t help me.
Changing:
Settings > CV in > CV in range
to -5V to +5V did make the tracking better. Despite the manual saying this setting is only for modulation signals, it does seem to affect pitch CV, too. “0V to 5V” results in a scaling of the pitch CV so that semitones become tones.
But pitch CVs are typically 0V to 10V, so the range is truncated to 0V to 5V. I got CV to MIDI working for a 1 octave range (not a very useful octave!). Mmm, so can I offset incoming CVs by -5V to get into Hermod’s -5V to +5V range. Kind of. Then other weirdness sets in.
MIDI garbage must be getting sent out, both because listening to some of the weird stuff suggests so, and because the destination MIDI instrument keeps crashing (MAM MB33, then Mother-32 which I tried to make sure it wasn’t just the MB33).

I’ve been around in circles for 3 hours. I’m giving up. This is something I really hope Squarp sorts out, it’s a major feature isn’t it? I would certainly love to use the Metropolis to sequence MIDI gear …


#9

Hi, is this sorted out, yet?
I haven’t got a Hermod, yet, but good CV to MIDI would be the main reason for me to choose it over other sequencers.
Part of the problem with doing this (in general), is that Euro sequencers typically send the gate and then change the CV value. If they do it the other way round then the DAC hasn’t caught up by the time the gate comes. I have been trying to use a Doepfer A192-2 for this.
Most (quantised) euro sequencers seem to have this issue.
Sequencers that I own with this issue are, Metropolis, Varigate 4+, Rene (Classic) and BSP.
I typically use EOR from channel 1 of Maths as a trigger delay :roll_eyes:
If there was an option to dial in a delay for reading the CV value, then Hermod could get the values right. This would cause a slight latency while it is doing this, but because Hermod knows where the gate actually came in, it wouldn’t need to have the latency when the recorded sequence is played back.
This would also be useful for compensating for external quantisers.


#10

@Marizu No, this hasn’t been sorted out yet. I’ve been struggling with the same things lately. I really like your idea of delaying the input gate internally in the Hermod, since it can be smart enough to then compensate it in the actual recording. This would make Hermod a huge value to me.

Sadly I never got comfortable with making/editing sequences directly on the Hermod. The interface of buttons + encoder + the small screen seem to frustrate me too much. But I thought I had a eureka moment today when I started recording the output of my Metropolis with the cv inputs of the Hermod. I got really excited but then I ran into the issues described above. :sob:

The metropolis is outputting a very stable pitch, but once it goes in the Hermod, things get wobbly. Without note quantization on the input it sounds kind of ok, but then you can’t record the notes because the noise will show up as glitches in the sequence.

If I turn on note quantization on the cv in, the noise is causing random variations. I really hope the Hermod is equiped with good enough quality ADCs and they can sort this issue out.

@squarpadmin This also made me think of a useful feature for Hermod. If it allowed you to just record the cv/gate inputs as-is (without converting to midi notes), you would be able to record sequences with glide in them as well. So basically extend the modulation recording functionality to also include gates. Then you loose the ability to use some midi note fx on the recorded pattern, but I think being able to record and play back the cv/gate input without modification would be super useful.

When playing live with cv input recording I also found a bug.

  • (not sure if related) hermod in sync slave mode
  • (not sure if related) set cv/gate input to record on active channel
  • (not sure if related) set cv/gate quantize on
  • go to track mode
  • select track 1
  • push encoder -> clear track (just to initialize everything)
  • start clocks/hermod and run external sequence into input
  • go to step mode
  • hold y and press rec (to turn on hard REC)
  • press rec again to stop the recording (now the recorded pattern is playing back)
  • go to track mode
  • toggle the track enable button a few times.
  • … silence

The only way I found to fix this silence is to clear the track.

I guess I will make an official bug report for this.