USB Sync Problems

I did a search, but haven’t yet found any info… When I send clock sync from my Pyramid Mk ii through my Pluggable powered USB hub to my Digitone or Prophet 6, the timing is a disaster! The tempo can be seen going up and down by +/- 3bpm on both machines. On the Digitone this is even causing the pitch of the Digitone sequences to fluctuate wildly! When I use Midi, the problem disappears. But before buying my Pyramid, I was previously using USB without timing problems. And I’d rather use USB as lots of my setup runs on it.

The Pluggable USB interface is one of the fastest and most recommended USB 2 ones. Never had any problem with it before. :thinking: And I want to keep using my Pyramid as the Master Clock, ideally… I wonder what’s going on?

how do you do this? what is the usb host?
both the digitone and pyramid are usb midi devices, and you would need a usb host to connect the hub too…

I don’t use a computer, only my iPad running AUM, with its midi matrix.

You could try an iconnectivity midi 4 plus, solved all my problems. Using it with a powered usb hub, works flawless…

1 Like

Can you explain exactly how you’re hooking that up? Port 2 connects to the hub, port 1 connects to the Pyramid, midi connects to your devices?

What ports are you referring to?

Sorry, that was vague wasn’t it?



Those are for hosts. Pyramid is not a host.
Remember, USB MIDI is not like DIN MIDI where both ends have the same conectors. USB-A goes into the host and B goes the slave.

Pyramid -> Powered hub -> iCM4+.

1 Like

your picture shows the wrong Ports, those you need are on the backside…

So the usb hub connects to the rear type B port of the iCM4, and the Pyramid connects to one of the child slots of the hub?

Should work,
I got my pyramid connected via DIN MIDI and some synths via USB hub and some synths via DIN…

No, thats not what I said.
I would recommend you to read thru the iConnectivity manual. If you need help then make a topic, lets not trash this one.

1 Like

it’s not complicated. ios or computer plugs into the ports you posted a pic of. there’s another usb host jack that allows up to 8 usb ports to transmit midi to and fro (at least on the ica4+, can’t speak to the others). Great when you have lots of modules and controllers with usb compatibility. cuts down on cables and makes setup easier imo.

I highly recommend the iconnectaudio because you can then easily route audio from hardware through audio fx (and midi fx) using a host like AUM or Apematrix. Makes routing very simple. Plus, allows perfect clock sync with fun things like Patterning and Spacecraft.

Anyhow, I found my solution without spending any money… I had to set up Turbo Midi on the Pyramid and Digitone. That fixed my sync problems so far.

1 Like

The only downside to using the Turbo Midi option is that there seems to be a particular sequence that works, regarding the order I turn my machines on… And sometimes I’ll have to restart the Pyramid to establish the Turbo Midi connection(?) It’s also funny to watch as the connection is lost then refound, every time one saves a song. I’m using 4X. And I wondered if there are any pluses and minuses to using the fastest 6.6x connection, if I remember rightly?



Interested in improving my clock from Pyramid too.

Out of interest, was that your review for the MidiPace app by Audeonic?

It states that the app solved clock issues. I’m interested to hear a bit more. :slight_smile:

Yes, I think Midi Pace is good. But it still doesn’t completely fix the erratic start-up behaviour of Samplr. The app I’m trying to sync to my Pyramid. Still takes a few bars for things to become with steady though! It indicates that it is steadying 0.2 of a bpm when I work on the track at say 125 bpm. But as I say I do still run into some occasional timing errors that seem to be helped by my reloading the Project in the Pyramid.

Thanks for the reply and info. :slight_smile:

I too am having erratic clock going from Pyramid to a 1010 Blackbox via USB. Via Midi it is rock solid, via USB it’s all over the place. I’m assuming it’s a power over USB issue (the Blackbox is powering the Pyramid). I have no issues going to a Hermod.