USB MIDI channels and Cubase - Help

Just got a Pyramid and have having a bit of trouble with midi going into Cubase.

I set a Pryamid tracks output to channel 1 and then create an instrument track in Cubase on channel 1 and it plays fine. But then, I create another instrument track in Cubase and set it to channel 2 and for some reason it’s receiving the midi from Pyramid track 1.

In other words, it doesn’t matter what channel I set the pyramid track or Cubase track to, it just plays the notes from all tracks over all channels in Cubase.

Any help is appreciated.

did you set the channels correctly on the pyramid, and confirm using info->midi out?

if so , I suspect this is not a Pyramid thing at all

Cubase is a bit odd (and flexible :slight_smile: ) when it comes to midi channels, since it can happily record multi channel data on one track (very cool for MPE !)

but due to this, i guess, it lacks an input channel select , the channel selector on the track (that looks like the thing that would do it in most daws) is the output channel not the input channel

rather cubase, has the approach of using filters, so if you want to filter a track by input channel , you need to add a midi insert -> transformer -> channel unequal X , action = delete
(you need to do this for each track)

or at least thats the way i do it…

but given the flexibility in cubase, Im sure there are other ways to do this, or to optimise this process, which I’ll never work out because life is too short :wink:

2 Likes

Thanks for that!

I’ve been out of the game for a while and just getting back in.
I forgot that that was just the midi out channel and knew I might have to use the transformer. Just forgot where it was.

This does nothing for me. But i’m probably not understanding what i’m supposed to do exactly. Maybe i need something below too, in Action Targets? I have two channels i’m testing, 2 and 3. This is what i used for ch2. For ch3 i used paramter “3” otherwise its the same.

Turn the tab on. It’s a greyed out button at the top. Definitely not obvious in any sort of way. Unfortunately.

I’ll try an make a screenshot thing tomorrow.

Thanks, i got it working. I was so caught up with cubase that i completely forgot to change channel also on the Pyramid. It works great!

1 Like

Hi Sluggo,

Im getting exactly the same problem.

Pyramid>USB Ch1>Cubase IN>Pyramid MIDI USB>Cubase OUT VSTi>Ch1

This works but if i have another VSTi with exactly the same settings but for Ch2 it still plays Ch1 and Ch2 step partterns.

Can you confirm to me what you did to correct the issue?

Thanks

Mark

Sorry but Cubase midi channels have both INPUT and OUTPUT so i don tthink its Cubase as the input is set to the correct channels (for me at least() but it still doesnt work.

No matter what channel is selected in the MIDI channels INPUT Pyramid send to that channel (and all the others).
Cubase also receives all patterns from Pyramid to any midi channel that is record enabled. So if i have 2 step patterns set to USB 1 out and USB 2 out on the pyramid ANY record enabled channel in Cubase will play BOTH patterns, weird no?

Not sure what to do to fix this, hoping for an answer from Sluggo :slight_smile:
Mark

wrong… (at least as of cubase 9)
the midi channel you see is the OUTPUT channel not the input channel
this is a very common mistake users make… as it seems illogical.

if you get a midi monitor app on your compute you can see what they pyramid is sending.
and you will see cubase does not give a monkeys about the midi channel, regardless of what you think your setting…

add the channel filter as discussed above, and you will see it magically starts working :wink:

Hi There,

Sorry but i dont understand what you mean.

I can create a midi channel in Cubase, set its input to any external gear i have (excluding pyramid) and its output to any external gear i have and it works accordingly. (in is in and ouyt is out)

And i have no idea what you mean by “add the channel filter as above” as there is nothign explained that i can make sense of regarding this written anywhere above.

If it is as you say it is why is it when i have 2 midi channels assigned to 2 different external synths they both dont play at the same tiem regardless of which midi channel i trigger with an external keyboard?

I would be interested in seeing how this is corrected if it is infact the issue you say it is but im not convinced.

Mark

Hi thetechnobear - i didnt see this “rather cubase, has the approach of using filters, so if you want to filter a track by input channel , you need to add a midi insert -> transformer -> channel unequal X , action = delete
(you need to do this for each track)” so i am trying this now, thanks.

Mark

Hi thetechnobear

Is this what you mean?

Pyramid is set to USB 1 out track 1 and USB 2 out track 2.

Mark

Added to for reply purposes

Hi thetechnobear,

It seem si have cracked it.

you need to add the transformer from the channel button and select local and make sure you have Module 1 actually turned on.

i have used Cubase with midi for over 20 years and have never had to do this to make an external device sending midi in to Cubase work properly. Weird but i apprecviate your efforts :slight_smile:

Mark

yeah i figured it out, thanks.

Mark