USB Host > Not receiving midi?

I’ve tried to connect a few controllers to the usb host input of the Hapax, but when monitoring the midi in no midi is coming in.

I tried a Xone K2, a Novation LaunchKontrol XL and a Faderfox EC4, normally perfect devices for sending midi via usb, but the Hapax isn’t responding.

Is it a setting I’ve missed? Or just not meant to work like I’m expecting and was hoping for?

Hi tim,
I plug my Faderfox EC4 directly to the HAPAX via USB.
I check the sellected track to have ALL ACTIVE as midi input.
And as I push 2ND + LIVE and turn a knob on the EC4 the left display shows incoming data.
If You do exactly this, aren’t You able to confirm that?

1 Like

I’m using a Roland apro , connected via usb , all working

1 Like

yeah, out of the box it should ‘just work’ ™ , Ive tested with quite a few usb midi class compliant devices and not had issues.

to be clear though, you are plugging directly into the Hapax?
USB hubs are not supported (currently).

1 Like

I indeed do the same. Did double check the incoming port on the track, but those are all on all active. Ec4 is direct via usb on the host usb of the Hapax. No midi input shownn

Correct, no hub in between. I was searching for a Factory Reset, might help, but no idea to do it and also can’t find it via manual or Google.

Super weird. Those controllers are no strange exceptions, so must be doing something wrong. Check all midi settings, nothing wrong as far as I could tell.

It becomes even more weird now.

I powered off, connected the usb from the ec4, powered on and received midi

Tried the same with the Xone K2, no midi (device turns on, but nothing is received)

Tried the same with the LaunchKontrol, no midi (device evens looks like staying in Vegas mode, not booting to real working mode??)

Hey - I also have the same issue with midi coming from and going to my Moog Sub37 from the USB host
In the beginning it did not work, changed cables it worked for a bit but began to start failing and missing notes both ways, eventually stopped all together (Moog did not receive and was not able to send midi to USB host - note that even here the Hapax was indicating that it was sending midi). Anyway, at that point I gave up and routed it via the Midi Din. Still not sure what the route cause of the issue is but certainly is a valid issue - what you described seems very similar.

Try and install the 1.12 RC2 version, they did some improvements on usb host compatibility. Might help.

Also, in my experience, for some devices, midi via usb can be rather sensitive when it comes to cables, so in that kind of situation, always try out some different ones.

Thanks all for the feedback and the suggestions.

Will give other cables and the RC2 a go to check if that helps!