Usb clock sync with ableton problems


#1

Hey guys, Up to this point i’ve been able to slave pyramid to ableton when recording with pretty good results. maybe .1 or .2 is tempo fluctuation while recording, which was acceptable. i tried recording some tracks last night and now they are not syncing at all. Ableton’s tempo is set at 105 and when I start recording the pyramid’s tempo shows from 117.5 - 119.0 bpm. it also makes all the arps that are programmed sounds terrible since the bpm is so erratic. what’s more confusing is sometimes the bpm will sync back up again after i restart the computer, sometimes not though.

I thought it might be the usb port i’m using so i tried switching that around with no luck. thought maybe I was recording too many tracks at once (14 tracks) so I disabled all of them and still same problem. I’ve tried setting the bpm on the pyramid to 105 before recording but as soon as ableton starts recording the bpm shoots up to around 118 despite ableton being set to 105.

any ideas what is causing this issue?


#2

In my experience, Ableton does have a few glitchy bugs with the clock it sends ; most of the time if you quit and re-launch ableton it usually does the trick (you might also want to check again your midi setting in the parameters, sometimes disabling and enabling them again solve some issues) ;

But there are also other problems which are sometimes related to the abeton project beeing corrupted in some way, for example Ableton can send weird CC messages coming from nowhere (I’ve seen that a few times on several ableton/computer, it’s rare but it happens);
to see if your project is corrupted just open a new project and test ; then you can import your patterns of the older file into the new one using the library/browser ;
it can also make a gap in sync at some point (it launch the sync 2beats later, usually when you are not at the begining of the song, but if you push the stop button then the play again it launches in time) ;

Finally, with some gear like the tanzmaus, ableton sync makes the LFO skip steps randomly ; no other clock does that to the tanzmaus, only ableton does ;

So long story short, open a new project and try from the begining just to see if the clock is fine, and work your way up to the 14tracks you had ; you might also want to check the settings on the pyramid again ;

So far I’ve not see any issue with ableton and pyramid but I’m only a 1month user (still I use it every day) :slight_smile:

Keep us in touch:)


#3

I’ve narrowed down the symptoms a bit more. I’ve tried restarting, reflashing , etc. to no avail. When I press play in ableton, pyramid starts it’s sequence, like it should. Everything in the sequence plays in sync to ableton’s tempo (105 bpm), even the lights on the keyboard/smartpads light up in sync to ableton’s clock rate. What’s odd is that the bpm display on the pyramid is not 105 and fluctuates from about 117 to 120 bpm and sends out a fluctuating bpm to slaved synths. Any idea what is causing this?


#4

omg can’t believe it, I just stumbled on the solution. Turns out disabling usb sync fixed the issue


#5

That’s weird, but glad it works ! No timming issues, and no latencies in my setup ! plus I play a midi controler keyboard to ableton, then it goes out to my X0Xb0X via a midi interface then to the pyramid and the synth, absolutely no latency :slight_smile:


#6

Ok, I ran into the same timing issues again. I ended up buying ableton 10 and that fixed the issue fir good. I was using ableton 9 that was installed on a another computer that was accessed through a homegroup. That was prob the issue, just never understood why it was intermitten


#7

cool !