Uh oh! Broken encoder or...?

Day one with the Pyramid that I bought from a chap on Kijiji. One of the encoders seems to be acting up.

The button works fine when pressing down on it but turning it only seems to send data intermittently. Here’s a video with the behaviour I am seeing. Any thoughts? Is it possible the previous owner deactivated it in one of the settings?

While the sequencer is stopped, hold down the Assign button and rotate that encoder. It should pop up a window and I suspect there may be an assignation already there. If so, select “Remove Assign” (i think thats what the msg is)

Oh, and Kijiji, eh?
Canada then?
Toronto-esque here

Hey! Thanks again for the swift reply. Given the circumstances, I REALLY appreciate it.

I did as you suggested - while all of the other encoders give a pop-up box and allow you to assign whatever, #4 does not. The button portion of the encoder works fine tho. When pressed, it says “No Assignment” but the encoder seems to be AWOL. Made another video FWIW.

I also tried doing a factory reset by holding down FX during the boot procedure but nothing doing with that.

If worse comes to worst, I could drop it over to Jay at Synths When. Being Toronto-esque, perhaps you know of Jay already. :slight_smile: If not, I can’t recommend someone more highly when it comes to synth repair in T.O.

Okay, in hindsight that test wouldnt have worked because even if it had an assignation it would have popped up with values. Bah. Sorry

Someone else here might have a better insight, but Im thinking it might be encoder failure. A msg to Squarp at squarp.net/contact might be handy to help verify it needs to be replaced first.

If you go into STEP mode, they change things like step length - this would be easier to see if there is a fault.

( assign should be unlit - I think that’s default behavior)

But yeah it looks like a faulty encoder at the moment.

I’d either return it , or contact Squarp directly to see if they can repair.

I bought 2 new Mk 3 units over a one year span last year and both had encoder issues. I returned both and cancelled my orders…just didnt trust them after that.

BUT, i found a barely used Mk2 and just bought that because i had a MK2 in the past that worked perfect…dont trust those Mk3’s at all.

Hi @therockfrog ,

I’m very sorry you experienced this.
Please note this has nothing to do with them being mk3, you’ve just been really unlucky.

I do realize two mk3 in a row seem not to be a coincidence, but given the sample size, it’s not really representative of the entire supply.

What I can say is we’ve found the source of this low-occurrence failure, as the Bourns encoders we were using were not handled by our circuit board manufacturer within their specifications. This issue should not occur in any further batch.

Please note that if your unit is under warranty, we will service it free of charge, and we also provide an out-of-warranty repair service.
If you ever have a hardware issue with your machine, you should contact us via the contact form:

1 Like