Track starts on 2nd beat of bar and is permanently offset

I am recording MIDI in track-by-track and I’m using Bank C for MIDI A outputs in this project. I cannot stop Track C2 from starting on beat 2 of the 1st bar. Is this is a known issue? Let me know if you need any further info.

So now I have deleted the tracks on BANK C Tracks 1 and 2 and have decided on the following setup:
Yamaha AN1x > MIDI OUT Ch3 to Pyramid MIDI In
Pyramid MIDI A > Yamaha MIDI IN
BANK A Track 1 > MIDI A Ch1 > AN1x Rx Ch1 = Scene 1
BANK A Track 2 > MIDI A Ch2 > AN1x Rx Ch2 = Scene 2

I play in on the AN1x and capture in Live mode. It plays back correctly, but then when I stop and restart it always starts from the following positions:
Track 1 > Bar 2 > Beat 2
Track 2 > Bar 3 > Beat 2

What could be causing this?

I’m running the latest Pyramid firmware.


Do you experience this phenomenon if you also enter the same or similar MIDI data using Step Mode?

Hey @CreepyPants. Not if I start a new project and enter notes in step mode,

I saved the project above and created a new sequence on track 2 and I still get the same issue, but I also created a new 2-bar sequence on track 3 and I get the same issue.

There is more I’ve noticed: If I view the main SEQ info page with the bars displayed bottom left, I notice that double-pressing stop reverts playback to start at bar 2, but if I move the bar in focus, and stop once it starts playback from the bar after the bar in focus. Does that make sense?

I think it might have something to do with the Pattern Delay setting, which I had set to Instant. Just checking it now.

On the Project that does not work as expected, what Track Run Mode are you using on these Tracks?

This seems to ring a bell:

Something to do with the live looper (I don’t personally use, so no idea)?


yes it’s exactly what I described and comes from he liver-looper mode. This has been an issue since this feature exists, and it seems squarp has no interest changing this

1 Like

I enabled the live looper in my saved settings a while back to test it out, so I’ve disabled it and start position is now bar 1 > beat 1 on all tracks. Thanks everyone!

@CreepyPants Just to confirm, track run mode is set to free.

1 Like

there was a reason why I enabled the live-looper mode. I don’t remember clearly

Can you - while the sequencer runs - switch to record mode and freely play & record notes?

but of course, you have to fix the track lengths in advance.
(variable track lengths is what looper brings to the table)

this is how I most often use the pyramid - with omni=multi bank A,
so that it’ll just record on from whatever midi channel Im playing on on my synth.

1 Like

ah you are right , that was the point of using it!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.