Track start step wrong

for me this behavior is expected (i’m not saying its perfect) but i tried to make a drawing to better explain why and whats happening if it makes sense to you.

1 Like

i totally understand that this makes sense, but the other way makes also sense … and it’s just annoying that there is no control about it

1 Like

sorry if i made you look dumb :zipper_mouth_face: just wanted to make clear its not “buggy” or maybe it is, but not in this case :slight_smile:

My advice would be to set the looper to 1 bar (could not make it start from any other then 1 with this setting.
Or turn the looper of and set the track length before you record.

(sorry changed my advice as i realized it did not work after testing)

Or make sure you start your recording on the 1!

This does not seem to be the behavior the live looper is exhibiting - If you record a long pattern (several bars) on top of a 4/4 loop, when you stop recording it doesn’t go back to the start of the loop like your picture suggests, it usually jumps to somewhere in the middle of the pattern, and it’s not even predictable. Is this how the looper is working for you? Because the picture doesn’t really clear things up very much, that is how it should work, but it doesn’t seem to work this way.

well that way i would loose the flexibility i like about this approach

i don’t want to start playing on 1, because i maybe don’t want a note on 1 . Also i’m not player … i play with bad timing .

I’d like to have a looper that always starts at 1 like every other pattern in the pyramid but extends the length of the pattern as i play … it seemed i hav this, but then i noticed the mentioned problem, wich makes the feature almost useless to me

ah ok, sorry. haven’t used it to much but it have seemed to work for me, but i usually record short stuff with it.

1 Like

perhaps i misunderstanding … but behaviour seems correct to me…

so the live looper is for layering tracks, so you want it to keep its start point with respect to other tracks, otherwise what you record, is not going to be what you get when you play back…!?

(I’ll admit it would be a nice feature of @squarpadmin could allow this ‘offset’ to be adjusted e.g. if you get your timing slightly out)

if you want the looper to start recording on the bar boundary, have you tried setting “default perform” to 1 bar. for me setting live looper = 1 bar, default perform = 1 bar, gets me pretty much what i want, even if my timing is a bit off :wink:

default perform does have other uses, so perhaps it would be nice if the live looper had its own ‘quantise start’ option - but not sure if its necessary as default perform 1 bar works nicely for me.

1 Like

I was thinking exactly this… i dont get why you wouldn’t want the playback to sound/align the same way as when you played it.

That’s how I want it to work too, but it seems to be glitchy when recording long patterns - like I said, if you record a longer pattern of several bars, when you hit “stop recording”, instead of starting from the beginning again it usually jumps to some random part in the middle.

to be honest i don’t understand why it is necessary to offset the start point of a track to keep things as you played them?
when you start every track at 1 and just put the notes as played it’s all fine. No?

however … if that actual behavior is good for some people - fine. A possibility to modify the start point afterwards would hurt no-one who doesn’t need it - but help in some cases

1 Like

Are you both using default perform = 1 bar?
Because if I have that, then I seem to get the behavior @verstaerker illustrates.

ie recording/playback starts quantised on the bar.
(when first notes are played is irrelevant)

I’ll say mainly it just seems to work for me,
I activate the looper from a pedal by counting in the using 1 bar, then start playing the next bar.
For sure like a looper pedal it takes practice to get the timing right
( or as ‘right’ as I can make it , I just call the bad timing ‘humanization :slight_smile: )

( so basically I leave default perform as beat, and just time my start manually).

If @squarpadmin is listening, I’d love to have undo/delete as a cold pedal option … for when I make mistakes ( hmm i’ll email them :))

well yes it’s true … so maybe i had this just off , wich is why my pattern started at 5 or other odd steps

1 Like

ah, this behaviour is intended. This bit me too. I love the live looper because I don’t have to stop the sequencer and can just go and go. But eventually I do stop the sequencer and want to use the loops I’ve made. Because they don’t start on step1 but rather some other step, everything is all weird.

I, too, would like a way to control this behaviour. Either a way to change the start step of a pattern, or an option to have it prefer ‘always number 1’.

2 Likes

Moving things by holding 2nd and tapping arrows in step mode strikes me as a fairly clunky way to reposition a track. good for messing with things a bit, but not good if you want to shift things 5 bars over.

I wish there was a keycombo that would move any step pressed to the “1”

2 Likes

True.
As a tip: 2nd+</> moves by one “pad”, so it is zoom level dependent. Just can easily zoom out and then 2nd+</> to move entire bars.

+1
its important on the Pyramid to get used to zooming in and out to do things with finer/coarser granularity.

I find myself sometimes forgetting this, as I kind of getting locked into the 1/16 view of the world :slight_smile:

as mentioned above, did you try change to default perform = 1 bar?

as far as i can tell there is no bug/issue here, the misconception is about quantisation…
essentially your saying (by saying you want to start on 1) , you want to quantise to the bar, which s what default perform sets.

as stated above, I do agree it would be nice to:

  • have this quantising separate to ‘default perform’… though, as yet honestly, its not caused me issues.
    (and we already have so many quantising options, its getting complex)
  • be able to shift this start point manually,
    (its a bit odd thats it a ‘hidden’ parameter of the recording)

EDIT:
actually, on reflection, I may be getting the ‘correct’ quantisation due to using Live Looper = 1 bar, rather than Live Looper = beat. this means the recording is always started on the next bar start, regardless of when you punch in.
So, Im now not sure if default perform is part of it of not ( it seems a bit illogical that it was)
Its still just about quantisation, just which parameter is affecting it :wink:

1 Like

right. I still find that a bit clunky.
fewer steps = better workflow.

I play everything in live from a midi controller. If I want to loop a few of bars from something that’s say… 22 bars into a pattern, isolating that loop takes a fair amount of fussing, and to attempt it in a live performance setting would be pretty silly.

It would seem that development is more or less closed on the Pyramid, but a loop selector or a quick way to tap a step and have it “set 1 here” - like in ableton - would be very handy. Especially for playing things in live and composing on the fly.

1 Like

Not trying to argue with you or to say your workflow is invalid. Just trying to help :wink:

1 Like

Oh @squarpadmin squarp can we get “set 1 here” please.

1 Like

sorry, didn’t mean to take an argumentative tone there
:cowboy_hat_face:

after using the pyramid for over a year now, can’t help but notice this speed bump slowing things down quite often.

1 Like