Track Lenght bug?


#1

Hi guys
Im having serious issues with track length with different sequences.
Lets say i wanna have
Track 1 = 4 bars in Sequence 1
Track 1 = 8 bars in Sequence 2
Track 1 = 16 bars in Sequence 3

If im working in SEQ 3 and i wanna go to SEQ 1 or 2 to make some changes the Track length does not change back to 4 or 8 bars, it stays at 16…
Same thing happens if im working in SEQ 2 and go to SEQ 1, then it stays at 8 bars.

Am i doing something wrong ? its really frustrating.


#2

Yo,

You could try using patterns. Each pattern within a track can have a different length (and/or time signature) then you can use a 4 bar pattern in Seq1, 8 bar in Seq2, 16 bar in Seq3.

jim


#3

Yea i use patterns.
Looks like I can’t use empty patterns, track 1 has to come in at sequence 3 only.
Meaning I have to punch in a silent note at all sequences to have it come it at the correct time, which I found to be annoying.

Let’s say I have 30 different synthesizers and I want synth be 27 to come in at sequence 40.
I have to punch in silent notes in all sequences ? Hmm


#4

No, the track just needs to be unmuted when you save the current mute state across all tracks into a sequence. When you save a sequence, you also save whatever patterns are active in the tracks at that point.

So just mute the track in all the sequences you don’t want to hear it in.

You need to activate the red 'record button in track mode to save mute states or edit the mute states of the active sequence.

Each pattern can have its own run mode too. If your pattern has a run mode of relatch it will always start at the start of its 4,8,16 bars when it’s unmuted.

Does this help?

jim


#5

I also tried the mute states but it did not work.
I will load an empty project and try when I get home


#6

make also sure that rec is activated in track mode or else the current seq will not update the mute states.


#7

Another tip…If you turn auto pattern on, Pyramid will create a new unique pattern with a number relative to the sequence number whenever you create a new sequence. So pattern 4 in a given track will be active in sequence 4, 5 in sequence 5 etc…

This makes it easier to edit sequence specific patterns within sequences as you jump between sequences. Handy for making sequence specific changes to notes, length etc without losing track if which pattern is which.

jim


#8

Yeah, the initial issue with track length changing across sequences sounds like the same pattern is used on all sequences. Unless the auto-pattern feature feature is used, you need to manually change the pattern used in a sequence.

Might want to re-read the sections on patterns and track run modes, the factory default “freerun” mode is a common source of gotchas.


#9

I use auto patterns. Also tried the Mute states with the record button activated.
The only thing that did work was entering a note and setting the velocity to 0 for the silent patterns.