Touchpad issues

I recently purchased a used Pyramid from eBay. It’s great but there seems to be a problem with the touchpad…

It’s running PyraOS 3.22

When I go into settings, misc and try to turn on the touchpad, nothing happens and it stays set to Off. If I move the encoder the display flashes a bit but nothing else happens.

I saw somewhere someone mentioned you could calibrate it by holding encoder 2 while switching the power on. I tried this but it says ‘init touchpad’, and touching the touchpad does nothing.

Obviously I also can’t assign the touchpad to any CCs or do anything with it :frowning:

Any ideas what the problem is and if there is a fix?

Stays off: did you press it down when your cursor is on off?

I’d try to check whether the touchpad works. Record any cc via touchpad in step mode. If it works then I would try more gestures over touchpad while holding the encoder as sometimes it is tricky to catch the axis Y or X.

I go to settings, misc, scroll down to touchpad, press the encoder, turn the encoder, and it doesn’t change to on, it stays saying off. If I move the encoder a lot I can get it to say on for a brief moment before it goes back to off.

It doesn’t work at all; I can’t record anything in step mode at all.

I’m starting to think it’s a hardware issue :frowning:

Take off the knob and try it without. I remember it posted here somebody and the issue was to put a small flat thing inside to lift it a bit. Try it

The knob is fine. Everything else works OK, the problem is with the touchpad.

I’d refresh the firmware first and ask pyramid team then.

Yep - looks like have something extremely similar here…

Mk2 > PyraOS 3.23

Unresponsive touchpad. Unable to turn from OFF to ON in MISC settings - though as you mention, it will turn to ON very occasionally, and seemingly at random, but reverts to OFF when clicking the the encoder down. In desperation I tried the ‘encoder trick’ as mentioned in this trail - but no success.

Touchpad calibration, by switching the device on whilst encoder 2 is pressed down, just gives me the same ‘Touchpad init…’ message, from which point I can do nothing.

I need to contact Squarp directly I guess - have you managed to progress with yours yet by any chance?

I had a similar issue, pyramid would freeze when I wanted to activate usb midi in the misc settings menu. A fresh firmware install fixed it.