Timing Issues with PyraOS >3.20

Okay, I think I’m taking crazy pills, but I just wanted to see if anyone else is shopping at the same pharmacy:

I have a rather extensive set of incoming CC’s to the Pyramid to control ‘stuff’.
Well, recently I started jamming with a new set and was noticing timing errors when I send a bit of that extra CC data into the Pyramid.

Tried a few things with some results, but the big one that freaked me out was going back on PyraOS versions.

v3.2 I didn’t have these timing issues with the same File
v3.22 and above I have timing issues - a ‘glitch’ when going from a few Tracks playing to several
Note: I got a bit confused and didn’t test out v3.21

All I’m changing is the OS and using the same Pyramid data files.
Just want to see if anyone else has noticed something…wonky.

Addendum: Curiously enough, I ran into fewer problems with PyraOS 3.2 and below.
I actually went to my logs/script and I’m only throwing 7 CCs at the Pyramid to turn On/Off MIDI Effects, but it was enough to slow things down.

I built in a delay into my script and incorporated an external Clock and things run tighter, but it’s disheartening to face the reality that one OS ‘update’ might destroy my whole system. sigh

Note: I tested different versions of PyraOS from 3.2 on (I don’t seem to have ones older than that, unfortunately). Also tested Internal vs External Sync, plus running less data thru each Port (splitting up my DIN MIDI connections between Ports A and B even though I’m not using 16 channels per Port). I have a Merger in the data chain, but I tested with and without the merger and experienced no differences. Also, the Merger runs on DIN Port A and the ‘slowdown’ was experienced on Port B data which has no Merger.

I haven’t noticed anything, but then I haven’t really done much anything recently. Will keep an eye on it when I do. Regressions especially on minor updates that don’t appear to have any relevance to the matter are indeed nasty.

Older PyraOS versions are downloadable at http://squarp.net/pyraOS/<version>/PyraOs.bin even if they’re not linked from http://squarp.net/pyraos, for example 3.1 is http://squarp.net/pyraOS/310/PyraOs.bin


Thank you thank you thank you for the info on prev OS versions! I love being able to test things out when i experience bizarre problems.

I tested the Pyramid with sending plenty of CC data In awhile ago, but it’s taken me a long time to develop my interface script. In that time, whatever part of PyraOS i relied on to make my script work got changed, and now that Im further along in development it became an issue.


I think it’s only a problem if youre sending data IN to the Pyramid. Im not sure many people do that, or at least this is my impression.

Ah well, have a workaround and an E-RM MIDIClock on the way, so it’s all good. (Admittedly need the clock anyway)