Stuck When Saving

Hello, im having problems to save a project.
The thing is that im copying some .mid files (blade runner end titles cover) to one project.
I rename as a track01.mid bla bla. In this case i have only 2 .mid tracks with 112 bars.
Squarp can read it with no problems, but if i want to save it , the unit freeze .
If i change the name of the poject it freeze again and i can keep the information on the original project, but if i try to save the original project , it goes corrupt.

Im using the last OS and my SD card is a micro to sd class 4, i dont know if its the problem in this case…Whats the best option for SD?

This is not the first time the saving page freeze, once with a simple tracks information also freeze, and i try another SD and it freeze also (a 32gb class 10)

Whats the problem? its my unit faulty?

And another question is… when im saving a project, the smoke of the cup of cofee must move? can be that im not waiting enough? i wait 10 minutes and nothing happend…

Thanks in advance.

1 Like

I’ve had similar issues when I wanted to transfer some midi files to Pyramid. For me the solution was to remove all the other midi information (for example controllers, continous controllers and so on) from the tracks, leave just midi notes, nothing else. After that the same project could be saved and loaded again, worked fine.

I use class 10 SD cards, just to be sure. But the freeze happens also with these cards, it’s independent from that, but maybe the projects load faster.

1 Like

Hello thanks for the reply.
I exported it without any modulation at all (there is a dialogue message on cubase that you can deselect de option of exported with modulations) and its same, FREEZE!
Also i exported the same file in Ableton and…FREEZE!

Note: its just one track not the completly song. cannot imagine how this machine can save 16 tracks or more.

I feel very frustrated, the manual said that the machine reads .MID this was the main reason to buy the unit.

There is no way to save the project.

Whats the aprox time that this “amazing .mid reader machine” take to save 112 bars song? Just to know.

Thanks in advance.

1 Like

welcome to the forum.

Unfortunately, I think you need to approach this systematically to identify the cause of the issue.

(no nothing should be taking 10 minutes to load, Id say one minute would be too long! )

I’ll assume you are on latest firmware, always a good first step…

a) is this only a problem when you import midi files.

if you create a fresh project, and just use the pyramid for recording and playing.
does it freeze - in use?

when saving / loading projects?
if it freezes when you are saving/loading (new) projects.
then it sounds like a hardware issue.

first step would be to reformat the sdcard and try again.
if that does not work, try with a new sdcard
(sd cards do fail… they are consumables)

if you are buying a new sdcard, go for a branded one - I use things like SanDisk Ultra.

if a new sdcard still has issues then you need to contact squarp via the contact form.

b) projects works it just imported midi.

k, this is good news, since seems unlikely a hardware issue…
(though you will might want to try a new sdcard)

if this is the case, first create a very simple midi file and try to import that.
this will test your process/workflow

if that does not work, then either something is wrong with your process or your daw is adding meta data that is not liked (so try different daw)

if your simple version works, then try more complex ones.
start with a few bars, then build up
hopefully by elimination you can find the part of the project that they pyramid does not like,
with that you can report it to squarp via the contact form.

1 Like

Have you selected “Export as Type 0”? For me it’s working. And just to be sure, in Cubase, before the export, if you select the track, go to MIDI → Functions → Delete Controllers and Delete Double Controllers. With these settings I was able to export 115-145 bar long midi files, 7-8 tracks (export them one by one), I can save, open and play them, no issues.


Hello thanks for the reply, honestly.

Yesterday i tried with a differents song (moments in love-Art of noise) it have 10 tracks only. Before i uploaded it to Pyrmaid, i exported all the tracks one by one, without automation (there is a dialogue before you exported in Cubase, where you can deselected to export automation) at first, it was all ok, it saved kind of quickly (5/10 min?) but after i work for almost 2 hours, just doing play and stop nothing more (only a ARP on the intro), the machine show a bug (see image) so i decided to save the project…and…FREEZE!

After this, i load it again, and was no way to make the machine send MIDI note on channel 10 and up, was impossible to route channels to MIDI, the machine was completly corrupt on this project.

Im gonna try to re export all today again and see what happen.


Thanks, the problem is when you try to save the project.
When you load it it works perfectly (and quick), but when you start to do something in the project like add FX or just play and stop and decide to save the machine didnt save,or take sooooooooooo long. Its kind of random, sometime it save sometime not.

I assume that the latest firmware is the best, so im working with it.

I have a sandisk SD , but it is 32gb , its better to work small capacity SD?


if it freezes/throws an error whilst saving its most likely corrupting the project.

this is the latest firmware?
if so Id report this to squarp via the contact form , they do not do support via this forum.

The machine show the bug when i was working in the project. Not when im saving it.

what kind of resolution do you use for export the .mid file?

I use the default value that is set in Cubase (480).

Might be worth trying a smaller card, you can fit lots of songs on even a 2gb card, use a good brand like Sandisk.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.