Squar Rample SD Card Problem

Hi guys,
so yesterday I did some new arrangement of my Rample SD card. I changed some kit names (for example: A1 to B5). I did a backup of the SD card before that. I also changed the name of the .rtf files (for example “D - Richard Devine” to “D - Favorites”).

So after that I pulled the SD card into Rample, but the SD card was not recognized (arrow to the left). So I wanted to load the backup back to the SD card because I thought maybe it’s because I changed the name of the .rtf files. But then out of nowhere my computer didn’t recognize the SD card anymore… I tried several times but it’s not working anymore. I tried a different SD card on my mac and it was recognized.

Any of you had this problem yet or has an idea how to solve this?

UPDATE: I used the SD card formatter program to format the SD card. It worked yesterday so my SD card was empty again. I tried to load my backup to the SD card, then an error appeared. I deleted the files on the SD card again (about half of the files have been loaded). And now my mac doesn’t recognize the SD card anymore again.

SD card formatter isn’t working anymore (tried quick format and overwrite format).
It says:
“[ERROR] Error while writing 1048576 bytes of padding to offset 0: 5 (Input/output error)
[ERROR] Error filling leading part of device with zeroes: 5 (Input/output error)
[ERROR] Error while writing volume structures: 5 (Input/output error)
Formatting failed!”

I also tried deleting it with the mac disk utility but it doesn’t work either…

Cheers,

odd,
sounds like the sdcard is corrupted… but formatting should fix this.

you do not need the RTF files, simply the A0 (etc) folder with the wav files named correctly and of correct format - thats it. (all as described in https://squarp.net/rample/manual/ )

the format of the card is FAT32 (iirc?), so should always be readable by your mac.


so Im assuming you do the following
format it (with sdcard formatter), and then create folders and add wav files.
then eject it.

place in rample (while powered down) ,
dont see any kits (?)

power off , then insert into your computer and its corrupted?


so thoughts are…

a) sdcard is malfunctioning - corrupting itself
b) rample is corrupting sdcard
c) computer is not writing card correcting

seems like a few things you can try

  • use a new sdcard, see if its the same
  • format / prepare card before - then try to read with another computer (not rample) , tests b/c

I think trying a new card is important , sdcards do fail- and become pretty erratic.

if you try this, and its working with other computers, and so Rample appears to be corrupting,
then I think you need to contact Squarp via the contact form, as its possible (if unlikely) that Rample could be malfunctioning.

1 Like