[Solved] Pyramid sometimes leaving notes on when synced to Ableton?

Lately I’ve been using Pyramid synced to Ableton via MIDI and noticed that it sometimes leaves notes playing. But it doesn’t happen at all when it’s not synced to Ableton. Any ideas for a fix?

EDIT: Apparently the issue was in my MPG-50 controller for Alpha Juno 2. All my other synths played nicely even when Pyramid was synced to Ableton and the Alpha Juno did too when I bypassed the controller in my MIDI chain.

1 Like

I imagine this is probably obvious but you are using the USB midi; is that correct? In order to diagnose; as many details as possible are helpful. Are you using a hub? If so does this happen when you are not using a hub?

I had to read the description of the issue again because I scanned it too quickly as usual and thought you meant that there were notes left out…

Are these notes very sustained notes covering a bar or more? If so a possible fix might be a 0 velocity note at the very end of the clip.

I’m guessing that this has something to do with a note off not being recognized by Ableton… Do you have any other DAW to check it against?

Pyramid is synced to Ableton with a MIDI cable from a MIDI interface, I’ll try the USB connection soon if it would work better. If I understand my settings correctly Ableton is only sending start/stop and sync messages to Pyramid. Notes seem to be sustained until the same note is played again. I recorded an example that shows the correct clip and the same clip with notes getting stuck.

The example could not be found but that’s not that big of a deal. Anyway, I would say that the easiest thing to check right off the bat would be the note lengths… Are there any 17 note length notes that should be 16 notes long? Can you put a 1 note length note at the end of the phrase and assign it a velocity of 0? does that do anything?

The other thing is… yes… if you are using the Pyramid with Ableton (or any other DAW) I would use the USB midi… I have a USB Midi cable interface that I begin using with Ableton so that I could get 32 channels of midi but I’ve found that it’s… mostly academic now… I don’t use the USB MIDI cable because it’s honestly sort of a hassle and with usb midi it’s just one cable…

My bad, I had the wrong link in the previous post, updated it now. There’s only short notes in the example.

I also tried the USB connection and there’s still notes getting sustained until played again. It happens maybe once in a 5 times the pattern is played.

Well, I’d have to check it on my Pyramid but my point was that sometimes you have a note that overlaps the length of the clip so that the note off is sitting out of bounds.

That is an odd one… Can you check the phrase in another DAW? My suspicion is that it’s not the Pyramid… because it’s hardware and hardware may do funny things… but they generally come down to what you put in to them…

Another thing you might check is go to about the place where the stuck note usually happens and zoom way in…

and now… this… isn’t something to take as gospel… but it is a diagnostically asked question… Does it happen in any other DAW?

midi isn’t really the absolute reason I stopped using Ableton… but… it is one of them…

Just noticed that the issue was only happening with my Alpha Juno 2… And more precisely with a MPG-50 controller in the MIDI chain. Removing the controller from the chain seemed to fix the issue. Guess I Shouldn’t be so hasty with these forum posts :slight_smile: thanks for the tips anyway!

It’s fine… One of the biggest things I learned as an Apple ipod tech support agent is that my job wasn’t really to fix the issue for other people 90% of the time but to walk them through possible options and questions until the solution presented itself to the customer…

Glad you got it sorted. :slight_smile: