SOLVED - MIDI recording skips note-on / note-off


#1

Hi everyone,

I’m experiencing issues when trying to record MIDI notes through MIDI IN .
When I play from my MIDI controller, often, randomly, the pyramid:

-skips note-on and note-off events
-starts to play the sequencer

Did anyone experienced similar problems?

( my M-AUDIO controller works well, as I tested it with direct connection to sound module )
( in pyramid’s MIDI-IN logs you see only events that are effectively played, the other ( ignored )
do not even appear in it ).

can you help me, please?
maybe It’s a known bug?

thank you


#2

Maybe your controller transmits more than note events and that could trigger the sequencer…


#3

thank you for the reply !

I double checked the controller.

Let say I’m pushing key C4 only repeatedly.
often note-off is not catched ( pads remain lighted-on )
often note-on is not catched
some times pyramid starts playing.

should I consider my pyramid an exception, or it’s a well known behaviour ? :expressionless:


#4

I will try the same and report I similar behavior but never experienced this so far…


#5

I always use a midi controller with the pyramid… and never had an issue.

you don’t mention which controller specifically… is this directly connected to the Pyramid via DIN, or are you connecting the controller to a computer, and then the computer to the pyramid?
(or using something like iConnect midi)

so i can only suggestion normal troubleshooting rules

  • check cable and controller with another midi device
  • use another controller to check to see if the pyramid is ok
  • if your using any ‘intermediate router’ (midi router/computer) remove this from the setup.

if your having the sequencer start when your just playing notes, then that indicates that the midi is becoming corrupted on its ways to the pyramid (which would also explain the note-on/off getting dropped) … midi over din, is not a very robust protocol to hardware faults.

anyway, id test with another controller and cable, and if it still there, then its possibly a hardware fault, and id contact squarp support via email.


#6

i’d also recommend to get an intermediate midi utility like a midigal or something so you can inspect what the controller is sending outside of pyramid’s built-in midi analyzer


#7

thank you all for the suggestions.

this will be a busy week, so I won’t be able to do any check before next we.

In any case, yeah, I’ll do my best to troubleshoot this issue spending more time
to check on controller also ( although I think it’s ok :wink: )
it’s an M-AUDIO keystation 61 II via DIN 5 pin MIDI connector directly to pyramid

I’ll try the controller with cubase LT or some other DAW.
then I’ll do the same check as “DAW vs pyramid”.

I’ll let you know :slight_smile:


#8

Hi everyone!

I’m happy back to say that I was using a bad USB cable to power up MIDI keyb controller.
it seemed to work like yes-no-yes-no… and so on…

I’ve changed it and now everything is really really good =)

I’m so happy pyramid works !!!

thank you all for the support!! :hugs:


#9

@stanoc: Great that you found a cure;)


#10

Hi, I have just recently godt a Pyramide. I can not get any midi in to the Pyramide. I have tried my midi controller m-audio, and from all of my synths. The settings should be OK. I have tried to change midi cables and switched USB cable to power up the controller. Any suggestions out there to solve this?


#11

You’ve not given enough info really to indicate where the problem might lie.

Most likely it’s the track channel settings , so
make sure the midi channel is correct is correct (and if it’s din or usb)… also check in info to see if the pyramid is seeing any midi data

probably best to review the section in the manual on midi too


#12

The omni mode on the Pyramide is multitrack off. I use din cables for midi in and out. There is no signal shown in the midi in Page under info, general settings. All midi out work fine.


#13

when pressing on pyramid pads, you should see a little triangle in the upper part of the screen ( MIDI output notification )
when you send MIDI events to pyramid MIDI in, you should see another little triangle in the upper part of the screen ( MIDI input notification ) .
do you see them ?


#14

Midi out show the triangel. Not the midi in. It seems the pyramid starts playing when I use the volume slider on the controller. The lover C sharp has the same effect. Som Kindle of messe is sendt and received but No note on/off. When using the controller for other midi conections it works fine.


#15

It seems the same problem I had.

I resolved switching power supply cord for the M-AUDIO .
Make sure you are powering you keyboard with needed power .

Could you try to send MIDI events from a computer to pyramid ( just to verify pyramid is ok ) ?
I think these M-AUDIO keyboards are ( maybe ) a bit crap.

I could suggest also to power up pyramid as last device just to make sure that M-AUDIO keyb. start up do not mess up pyramid MIDI-in port status… ( I know MIDI ports are opto-de-coupled, but maybe “noisy MIDI data” are being sent over the cable at keyb. power up )


#16

You are right about the m-audio. I tried now with the Ultranova as source. I turned on the Pyramide last. Now it seems to work fine. Thanks for your tips. Problem solved. :grinning:


#17

happy to hear that !!! :pig:
:smile: