Sending Pyramid CC to MFB Tanzmaus - NOT WORKING, I tried everything, pretty desperate

I tried everything. Sending notes but no CC.

The right midi Channel, definition txt in the right format, tanzmaus set to manual.

Nothing helps…Pls it’s been driving me crazy…

Hey there.
First step in troubleshooting anything like this is to breathe.
I usually forget that step.

If I understand correctly, you have the MFB Tanzmaus responding to MIDI Notes which control the individual drum sounds, but you cannot get the Tanzmaus to respond to MIDI CC messages from the Pyramid. If I’m understanding this correctly, here are some suggestions:

  • Set up a Pyramid Track to play a 4-on-the-floor kick drum pattern
  • Verify this plays as expected, then [Stop] the sequencer
  • While this Track is selected, press & hold [Assign] and while holding rotate one of the Encoders, which should bring up the screen "Assign Encoder n To…? (Where “n”=the number of the Encoder selected) You can release the [Assign] button at this time.
  • Using the Main Encoder, highlight “MIDI CC” and press/click to select
  • Scroll down the list of MIDI CC’s to select the desired MIDI CC and press/click to select

Now, go back to Track, press [Play] on the sequencer, and rotate the Encoder to verify that the desired modulation is occuring.

If this modulation does not occur as expected:

  • Stop the Sequencer, and rotate the Encoder. You should get a pop up window that indicates Port and Channel of Output (verify these are going to your Tanzmaus), the CC # (verify it is the correct CC#), and of course a value. If your Definition File is in error, this step will be exquisitely frustrating and lead to severe skull damage from beating it against any flat, hard surface nearby. I would strongly suggest not using a Definition File at this state of troubleshooting, but I’m more of a command line kind of guy so your mileage may vary. Definition Files are a handy cosmetic, but not necessary to play the game.
  • If the popup window does not happen, then you did not [Assign] the Encoder to send the proper CC msg. Return to the instructions above or review the Pyramid manual.
  • If the popup window happens, but no changes occur as expected with your Tanzmaus voice, then it would seem to me the CC you are sending is not set up to receive and operate as expected on the Tanzmaus. For that you would need to refer to the Tanzmaus documentation.
  • If the popup window happens, and you have verified the Tanzmaus is set to receive this MIDI CC as expected and that the Pyramid is sending the correct MIDI CC, then the issue could very likely be your cable and/or your data path from Pyramid to the Tanzmaus. If you have a USB Hub in there, try to get a direct connection - as in, avoid any extraneous gear in the data path.

Remember there are 3 bits to this:

  • Is the Pyramid sending the data you expect in the format you expect
  • Is the data path clear
  • Is the receiving device set to receive and process this data in the way you expect

The rest is just making music!

Good luck!

:skull:

3 Likes

That is one of the better problem solving advices there is! :grin:

3 Likes

Hey man, I just want to say how privileged I feel to be part of such a great community.
Not just here (obviously a great place), but the electronic music community as a whole.
Literally, there is always someone who is willing to spend some of their time thinking about your problem and suggesting possible solutions.
One thing that today I feel the world seems to be struggling with is promoting that same level of super strong sense of community. I hope it’s just the optics of modern times & geopolitics and adapting as a society to the violent pace of the technological progress.
I’m sorry about the off topic but we should all get reminded of that more often. Together we fucking rule.

Again, thanks for taking the time to write this super detailed step-by-step guide.
I followed all of the steps but it still did not work.
Finally I found the problem - in my case it was the manual trigger mode.
I previously read that the tanzmaus needs to be in manual trigger but it’s not enough to have it activated it by pressing the red button to get the left light on. YOU NEED TO ACTIVATE THE GLOBAL MANUAL TRIGGER by pressing shift + settings (button 16) and then pressing button 11
(manual/step).

Once again thank you.

3 Likes