Sample and Hold Incoming CV?


#1

Pardon if this is a dumb question, but is it possible to effectively sample and hold incoming CV?

Say I have different voltages coming in every 16th note, but I would like to trigger and hold those voltages via random or slower gate signal.

This seems like something that can be done somehow but I can’t quite wrap my head around it. Any pointers are appreciated!


#2

(Assuming you want to sample the voltage and send it to a V/OCT input then try the following…)

Send your voltage into one of the inputs (eg: A). Set up a Track to be a Note track. Go to the Mod Matrix and assign input A to the Midi Effect: Root Note of that Note Track. Add a Scale effect if you want to constrain those notes to a scale.

On the Note track add notes in Step view where you want the sample and hold to occur (eg: on the 1 & 4). What happens is the voltage input on A is constantly adjusting the Midi Note value, this is then sampled when a trigger is trigged on the note track.

Hope that is what you’re looking for.

Kid Y.


#3

Ah yeah patchful thinking :+1:t2: will try this out! Thnx!


#4

Thank you! It’s not exactly what I was looking for but seems like a useful approach for other reasons.

I did some testing and it seems like the sample and hold is a default behavior, at least for my current application:

A (CV in): Receiving different voltages every 16th note
B (Gate in): Receiving irregular gates (though quantized from same clock as CV in)

Input A/B --> Track 1 (Note track w/ Scale FX)

Sounds like it’s working!


#5

Nice - I like how there’s a couple of ways to do this.

+1 for flexibility :+1:


#6

How are you finding the Sample & Hold-ing of CV? If I’m using it for note data I can hear subtle glitches in the audio tuning. This happens even if Quantize is switched on in the CV In settings. I’ve tried the same set up (an LFO held by Triggers) into an O_C and there’s no glitching. I feel the Hermod should be handling Sample & Hold much better than how it does currently. Right now it’s unusable :roll_eyes:

EDIT: I didn’t realize there are 3 settings within the CV In settings for Quantizing the CV. Off, On and On (Gate)… the last one works perfectly when receiving a gate. Nice.


#7

Thanks for that tip! I was experiencing some instability on my end and wasn’t sure if I was doing everything right. I’ll give that 3rd mode a try and report back.