Roland boutiques not playing nice with PC messages, Not sure what I'm doing wrong

I’ve been working on embedding program change messages into my patterns so all my stuff with patch memory automatically changes when I launch sequences. My JP-08 and JX-03 don’t seem to want to cooperate with this. The odd thing is that they both change patches when I go in and edit the PC value in the patterns, but won’t change patches when I switch between sequences while playing. My Alpha Juno-1 doesn’t seem to have the same problem at all so I suspect it’s some cryptic setting in the Boutiques. Am I missing anything obvious?

This has been an intermittent and ongoing problem with certain synths.
Sometimes it’s the synth and how it handles program changes (Access Virus TI) where the first note is always cut off if there is a program change.

There’s nothing to be done about this that I know of. I sold my Virus because it was useless like this for my purposes.

The Boutiques on the other hand only began behaving differently with an OS update to the Pyramid.
I noted it, and wrote to Squarp, and the sent me a beta to test with and it worked. Fixed the problems.

  1. Patch change not being recognized without a hard stop (double click stop)
  2. Patch changes creating a hiccup for playback of the Roland Boutiques synths (only.)

Then a couple of updates ago these problems came back.
And you know… I didn’t write about them again. I just decided to stop using program changes entirely.
I work in manual mode now in a live performance, and just manually adjust my sounds as a part of the performance.

However, the patch changes we insert into a Pyramid should really be recognized without having to press stop twice.
And the program change should not create a hiccup for the notes of that particular synth.

I’ll set it up tomorrow and if 3.21 is still doing this, I’ll demonstrate it and write to Squarp about it again.
I suggest you also do the same.


Ok, I didn’t wait until tomorrow… I tried this tonight.


  1. Using Pyramid OS 3.21
    I created a track for the Boutique JU-06 and played some notes.

  2. In step mode:
    Held down the STEP button and rotated the encoder until I arrived at CC MESSAGES
    I then chose a patch number at random using the touch pad, and pressed the first step pad [01]

  3. I pressed play.

The program change was immediate.
No notes were disturbed or interrupted.

I changed the JU-06 back into manual mode while this was playing.
The patch change did not jump back to the random PC CC which I had set.

I pressed STOP and then PLAY
The patch did not jump back to the random PC CC which I had set.

I pressed PLAY a second time while the sequence was playing (this is set to restart the sequence for me)
The patch did not jump back to the random PC CC which I had set.

I pressed STOP twice.
The PC CC jumped right to the random CC I’d previously set.

Personally I like how this works, and I’m delighted that it doesn’t cut off any notes in so doing.

Try getting tricky with PC CC’s and create a track which relies on them. So there’s PC CC #1 at step 1, and another at Step 5, and perhaps yet another at Step 10.
Try this across several tracks.

I’m satisfied, and may very well add a couple of these back into my live set, as it’s a drag in the dark to remember what my tiny little notes on my set list mean in the heat of the moment.

I hope this helps you out.


Before undoing this and putting it all away again I decided to try multiple PC CC’s just to see. I got curious.

I placed a few more PC CC’s across the pattern.
1 CC 24 at step 1
2 CC 50 at step 13
3. CC 41 at Pg 2/2 step 5

The sequence plays and all of the patch changes are executed without note interruption or hiccups.
Seems to work great.

The thing to remember in a situation where they don’t appear to be called up correctly it to stop twice, and verify that the PC CC’s have indeed been sent.
In a performance I would time this intentionally if there were some kind of critical patch change needed for an important moment in the song. Make it so I could just double press STOP and then play…

Again, hope this helps.


Quick reminder: You’re awesome brother.

Hey thanks a ton! I went through and tried to re-create the steps you did and it made me discover that the firmware on both my boutiques and the pyramid were out of date. I’ve upgraded to the latest version and now everything is running perfectly!


Fantastic news!!!