Record CV dropping gates when unquantized and UI glitches


#21

Ok thanks :slight_smile: So that means the notes sent by the OP-1 are not overlapping in this case, otherwise you would have a legato on the FH-1 too !


#22

A series of tests:

Test 1:
OP-1: “endless arp” sends notes to Hermod, it is directly connected via “USB host”

Hermod: Sends a clock to the OP-1 but is not the master clock (an Octatrack is, the clock is received on the DIN input). A “Midi out” effect is added to the track, for monitoring the Midi on a computer and to find out if only the gates are dropped or the midi as well. (spoiler: both. That explains the stucked notes on my P12)

Everything’s fine during a couple of seconds or minutes. Here’s the output of Midi Monitor, totally normal:

19:32:15.376	From HST 2	Note Off	1	59	0
19:32:15.377	From HST 2	Note On	1	61	127
19:32:15.439	From HST 2	Note Off	1	61	0
19:32:15.440	From HST 2	Note On	1	64	127
19:32:15.501	From HST 2	Note Off	1	64	0
19:32:15.502	From HST 2	Note On	1	71	127
19:32:15.563	From HST 2	Note Off	1	71	0
19:32:15.564	From HST 2	Note On	1	69	127
19:32:15.626	From HST 2	Note Off	1	69	0
19:32:15.627	From HST 2	Note On	1	64	127
19:32:15.689	From HST 2	Note Off	1	64	0
19:32:15.690	From HST 2	Note On	1	61	127
19:32:15.749	From HST 2	Note Off	1	61	0

And when I notice/hear that some gates are being dropped, here’s the corresponding output of Midi Monitor:

19:32:19.610 From HST 2 Note On 1 56 127
19:32:19.611 From HST 2 Note Off 1 63 0
19:32:19.672 From HST 2 Note On 1 56 127
19:32:19.734 From HST 2 Note On 1 58 127
19:32:19.735 From HST 2 Note Off 1 56 0
19:32:19.795 From HST 2 Note On 1 61 127
19:32:19.796 From HST 2 Note Off 1 58 0
19:32:19.858 From HST 2 Note On 1 68 127
19:32:19.859 From HST 2 Note Off 1 61 0
19:32:19.920 From HST 2 Note Off 1 68 0
19:32:19.921 From HST 2 Note On 1 66 127
19:32:19.983 From HST 2 Note Off 1 66 0
19:32:19.984 From HST 2 Note On 1 61 127

As you can see, a new “note-on” message is sent to 56 instead of a “note-off”, the same for some other notes and everything goes wrong… In fact, the note on is sent twice but only one note off is sent, this causes « stucked notes » on a poly synth like a Prophet.

Test 2 : Same sequence sent directly to my computer and monitored during a few minutes, no overlapping :

 19:45:53.034	From OP-1 Midi Device	Note On	1	69	127
19:45:53.103	From OP-1 Midi Device	Note Off	1	69	64
19:45:53.103	From OP-1 Midi Device	Note On	1	67	127
19:45:53.171	From OP-1 Midi Device	Note Off	1	67	64
19:45:53.171	From OP-1 Midi Device	Note On	1	62	127
19:45:53.239	From OP-1 Midi Device	Note Off	1	62	64
19:45:53.239	From OP-1 Midi Device	Note On	1	59	127
19:45:53.307	From OP-1 Midi Device	Note Off	1	59	64
19:45:53.307	From OP-1 Midi Device	Note On	1	71	127
19:45:53.375	From OP-1 Midi Device	Note Off	1	71	64

The only difference is that in this scenario, the OP-1 doesn’t receive a midi clock from Hermod (is not in Sync mode) but is the master clock.

Test 3: Now, I’d like to find out if Hermod is responsible for that or if the OP-1 goes crazy and generates a wrong suite of messages when it receives an external clock.
Op-1 in sync mode, Clock from Hermod via Iconnect4, and OP1 notes directly sent to the computer : No issue, no overlapping.

Test 4:
Op-1 in sync mode, Clock from Octatrack via Iconnect4, and OP1 notes directly sent to the computer : No issue, no overlapping. So, the OP1 doesn’t seem to be the cause.

Test 5 :
Same setup as in the first test, OP1 in sync mode connected directly to Hermod but this time Hermod is the Master clock. And the issue happens again, very shortly after the Arp has started.

20:15:52.565	From HST 2	Note On	1	57	127
20:15:52.604	From HST 2	Note On	1	59	127
20:15:52.605	From HST 2	Note Off	1	57	0
20:15:52.646	From HST 2	Note On	1	62	127
20:15:52.647	From HST 2	Note Off	1	59	0
20:15:52.689	From HST 2	Note Off	1	62	0
20:15:52.690	From HST 2	Note On	1	69	127
20:15:52.729	From HST 2	Note On	1	67	127
20:15:52.730	From HST 2	Note Off	1	69	0
20:15:52.771	From HST 2	Note On	1	62	127

Test 6 :
Octatrack is the master clock but the clock is sent to OP1 (in sync mode) via Hermod. Op1 is connected directly to the computer. No issue, no overlapping.

N.B: there’s no midi loop that would cause a double « note-on » message in this setup. The only midi out effect in this setup is only here for monitoring the output of Hermod.

EDIT : I notice that an OP-1 sends a Note-off with a velocity of 64 ! Maybe that’s a cause of the problem, don’t you think ?

2ND EDIT: The issue doesn’t happen when a PRO2 arp is the Midi source. This one sends notes-off with a velocity of 0

Sorry for the long message :stuck_out_tongue:


Clock output starts when transport is stopped, can you replicate this issue? (fixed in 1.021)
#23

Wow, interesting :slight_smile:

Will read it again tomorrow as my head hurts haha :smiley:


#24

imo there’s definitely an issue with the combo Hermod + OP1, I can confirm that the problem doesn’t happen with another midi source ( a Pro 2 arp in that case). This issue not only affects the gates sent from Hermod but the Midi output as well :-/
EDIT: possible cause added to the previous post: OP1 sends a note off message with a velocity of 64. Now I remember that I had a similar issue with my Max patches.


#25

The issue also happens in a whole new configuration:
Octatrack sending a rhythmic pattern (not something complicated, running at 120bpm) to a Nord Drum2 via Hermod. After a few minutes, a large amount of notes/gates are missed (Midi and gates)… :pensive:

Nord Stage 2 to Hermod, gates OK, midi notes dropped… :disappointed_relieved:


#26

It should be fixed in the 1.02 version!


#27

can someone confirm it’s been fixed? because I don’t see any changes unfortunately.


#28

I’ve just installed the firmware, I will check it in 30 minutes and post the results


#29

Yes the gate output is still faulty. There’s also a new bug related to the gate output, the clock is sent when the transport is stopped and stops when the transport starts…


#30

yep the gate output is still bugy as. At least we should have the option of choosing legato or mono mode so that the sequencer output a gate for each note if we want to, wether or not the notes are overlapping!

I cannot say I’ve had the best time with this module, the experience is very frustrating, there are A LOT of micro bug or inconsistency that make this experience infuriating. not happy


#31

@Elberstein Thanks a lot for this thorough testing.

I suppose you are using the OP-1 with the MIDI host port of Hermod. That could be the reason of the note drops. Do you have a way to plug the OP-1 to Hermod via MIDI ? Using your computer as a MIDI through for exemple.

I have a feeling that this is a USB problem. Unfortunatly the USB stack we are using has problems, we are curently looking a new (better) one.

Cheers,
Mathieu


#32

Yes, I can connect the OP1to Hermod through the iConnectMidi4+
That means we shouldn’t be using the USB host socket for now ?


#33

@squarpadmin I have that same issue with a simple midi keyboard plugged in straight into the midi in, as soon as notes overlap it drops the consequent note.


#34

@Elberstein We’ve noticed some issue with some device unfortunatly … When you try that with the iConnectMidi, can you please give me a feedback wether it’s working or not ? Thanks
@madeinspace We’ve noted that one to, thanks !

Cheers


#35

Sure, I will


#36

Thanks an option chooser in the midi effect would be the perfect place imo to chose between legato (where picth take over gate trigs) and mono (where gate are triggered on each note no matter if they overlap or not) :slight_smile: thanks