Record CV dropping gates when unquantized and UI glitches


#1

Hi!

I’m on fw 1.01, I’ve been trying to record a series of unquantised gates through CV input but results are really less than satisfactory, the sequencer drops some gates in that mode and well that’s a problem.

Another issue I found when also recording pitch is the notes on the tiny screen are getting thicker which make it look really ugly and unreadable ( not sure if that makes sense could post a pic).

I could post some videos too

UPDATE: looks like the recording of unquantized notes/gates is still tied to the tempo, because at maximum tempo this issue kinda disappears and at slow tempo the issue gets worse.


Issues with 1.01
#2

Interesting problem.

I was having problems with gates right out of the box myself.
I solved the problems in these ways:

  1. Zoom and gate length
    By zooming in, the gates are automatically shortened.
    Be sure your notes aren’t overlapping.

  2. Elektron note off data value (0/64) problem
    I was attempting to use my Octatrack’s midi sequencer as an input device for Hermod.
    The results were poor. The first pitch was recorded, and the rest were a blur… Seemed like I never took my finger off the first key.
    This has been addressed and fixed in Firmware v1.01 and I can use any input device I’ve got now without an issue.

I have not experienced live playing being poorly recorded, or gates skipping.
With tracks behaving this way, I assume you are step editing the preformed tracks and looking to see that the gates aren’t overlapped, yes?

If they are, try shortening them and see if that brings them to life?


#3

no mater how I set up the hermod I’m getting dropped gates all over in unquantised mode and I’m not even asking it to record super fast event just an 1/16t arpeggio from the OP-1! it just can’t keep up. I’m bummed out, I sold my shuttle control for this and wondering if i made a mistake or not now. The squarp crew don’t seem to be very active on this forum either. :frowning:


#4

Ah… the light goes on.
You are recording sequenced material from other devices!

I’ve done some of this too, and agree that the timing isn’t perfect. But that’s understandable.
Getting locked in sync between devices is a challenge. But I believe that’s the culprit here.

Things to try:
For analog sync:
Use the shortest cables you can.
Don’t jump right into record mode. Start and stop and restart a few times to be sure you’ve got the sync you need.
Then punch into record.

For midi sync:
This should already be pretty good. If it’s midi to midi there will be a little bit of a delay, but it’s minuscule and could potentially be corrected easily.
If there’s a lot of trouble with midi sync, I would look to be sure there wasn’t a double clocking or some other interfering problem.

Generally there will always be a little hassle when trying to clock up clocks and record the output from one to another. A little adjustment is to be expected (at least in my experience.)
Quantizing the CV works in two ways with Hermod:

  1. Quantize the rhythm 1/8, 1/16 etc.
  2. Quantize the pitch - in CV input settings.

It would be interesting to at least try to capture an analog sequence using these helpers and see if the results are better, or worse.
I made a little Youtube video in my Hermod category of myself recording a Doepfer A-155 sequence into Hermod and it was so seamless that I felt like I wanted to get 4 of them, and record and loop and play and layer and go wild.
So it’s possible to get this together.

I hope any of this helps.


#5

Here is the link to the video:

It’s crap quality, sorry. I make these little clips with my phone in the heat of the moment, and they look good enough for instagram, but on youtube they’re diabolical.


#6

Hi @Sunshine

Thanks heaps for your help, really appreciated. I made a short video of the issue:

Strange thing is that it recorded the note events but cannot spit out the gate, so I’d think it is a bug unless there is an obvious setting I’m missing? or Am I asking too much for this sequencer? Note the issue also happens in quantized mode.


#7

Yeah, I just tried this too and something is definitely wrong.

I can’t get the gate to externally clock the external sequencer (which worked fine with version 1.0)
and the gates are also behaving as if they are getting stuck and going away.

This is not true with output. For example, if I sequence with Hermod everything is fine.
This seems to be happening only when using CV/Gate or other external device for input.

Would suggest writing to Squarp in an email, and point them to this thread.
Something’s not right here.


#8

Hi madeInSpace,

By the looks of your video, it seems that every note overlaps each other, so the gate stays high indefinitely. Do you have a “gate length” parameter on the OP-1 that you can shorten ?

Try putting a ratchet effect in the effect rack and play the OP-1 for a short amount of time. If the ratchet effect outputs the correct note and stops when you stop the OP-1 arpeggio, then it’s a gate length problem !

Cheers,
Mathieu


#9

Thanks guys,

Yes that did the trick, also another workaround is to randomise the length with min/max set up to the minimum length.

There is still a problem with the gates not being triggered it happens quite often after a while the track just won’t emit gates and I have to reboot the module.


#10

Have you set Hermod up, as I have, to have the active track be A-B and also the Track you’re playing as A-B?
I suspect that’s also causing some trouble.

I’m going to try this again with the active track set to either something else, or off.
Might do the trick.


#11

Same problem here (about the track stopping to emit gates after a while). No need for reboot, just drop an euclid effect or ratchet and it works again (then delete the effect). Little boring though…


#12

It’s definitely an input problem, yes?

I have not experienced this with anything which I’ve generated on the Hermod itself.
It only seems to be when attempting to send CV and Gate into Hermod to either record or just to pass through.
Is that also your experience? Or are you having these issues with internally programmed sound too?


#13

Nop, it happens while the sequencer is reading the pattern… Let’s say I generate a random pattern : everything is fine. Now I want to add a scale effect. Well, sometimes when adding the scale effect or modifying it a bug appears : the Hermod stop emitting gates (on that track)… only solution is to add a euclid effect or ratchet effect to make the gates work again.


#14

Yeah exactly the same issue here :frowning:


#15

Oh, I experienced the same issue today, with an OP-1 arp sending notes to Hermod without recording, only live playing. Really annoying, especially because it doesn’t always happen but after a few notes. Is there a way to adjust the length of the notes on an OP-1 like suggested earlier ? I don’t think there is but… Well, maybe the issue comes from the way the OP handles midi but It would be great if this problem could be fixed on the Hermod side because I don’t think that another OP-1 update will happen someday. I don’t know, a kind of “note filter” or “force note off before triggering the same note”, or a length quant in the Midi menu or something ? I experienced some problems with the OP sending notes to a Prophet via Hermod and I noticed that some notes were stucked, I didn’t know the cause but now I imagine this is related.

Edit:
This doesn’t seem to happen with the same OP_1 arp connected via an FH-1, just to say that the OP is not the only responsible maybe


#16

I think that’s because the FH-1 doesn’t have the issue the Hermod has when midi “gate on” signal from one note and the midi “gate off signal” of the previous one are too close.

I’ve been thinking about this and I don’t think overlapping is the problem. An Hermod user posted a video where the Hermod was used with Ableton Live (sending a midi sequence to the Hermod). The notes that were sent to the Hermod wasn’t overlapping at all, since they were put into the piano roll of Ableton (a case = a note). Besides, it can be great to not have gate generated when notes are overlapping cause otherwise you couldn’t do legato stuff.

So I really think the main issue is gates not beeing generated when midi “gate-off” “gate-on” signals are too close… which happens often with fast arpeggios

My 2 cents :smiley:


#17

Yes, that makes sense :slight_smile:


#18

I hope the next update fixes this issue, maybe that’s why it’s been delayed


#19

:slight_smile:

Btw, I was wondering : if you press a note on a midi keyboard connected to the FH-1 while olding the previous one, is a new gate generated or it makes a legato ?


#20

It makes a legato.
I don’t remember if this behavior can be modified but it probably can