rampleOS 1.43 - new firmware

Hey y’all!

We’re happy to officially announce rampleOS 1.43!

This release should fix all known bugs and crashes.

On behalf on the entire team, I’d like to extend our most sincere of apologies for the modules crashes some of you have experienced recently.

We know this fix is overdue, but please know we have worked tirelessly and have recalled and quarantined multiple failing modules to get to the bottom of this, and have conducted expansive testing, both in-house and with beta testers, in order to confidently assert this firmware solves the underlying issue.

To download this update, and for more details about the release, click on the link below:



Hey Thibault,

I got my new Rample today (s.-no. 2028, running firmware 1.4) and had several crashes nearly every 10th trig on channel 4; with the module put into rack straight out of the box.
Also the zero point on fader 2 wasn’t correct - when physically on 12 (zero), it displayed a slightly negative digital value.
This was a shock for me because I love the concept of the module and after unpacking I was really happy to see, that it is produced with high quality parts for its really fair price. I was very excited to play with it, but then it chrashed (with frozen display, no function) several times.

After updating to firmware 1.43 everything works fine now: no crashes, no wrong values. Everything as it was meant to be.

Long story, short message: thank you!



Omg, I was using the last update today and it crashed on me. I logged on this morning to see the new update and happy to see progress. My Rample sat in my 4MS nursing case for the past year just collecting dust unfortunately. I really like the module for various abilities to move through modulations and kits for live performances.

No use getting rid of it so I waited it out.
I haven’t given up hope and I am sure these guys are doing their best. Pray that this will finally solve these issues with crashing. I will keep you guys posted


I’m speechless and a bit annoyed. I’ve tried and still crashes on me when ever I scroll to other banks of sounds. I’m ready to hang this one up for good. Not good

Hi @JuneLopez ,

I’m sorry to hear that. We’ll get in touch and try and solve this.

1 Like

Lovely, will update and report back. When scrolling through banks, hitting C0 would kill the module. Mid-set, this was pretty crap. Would have to unscrew the module and pull the plug to avoid having to lose the whole case

Immediately dead after a few triggers - New update didn’t solve anything for me it seems. Really not fun

I have no idea what’s causing this problem but it seems to happen when you trigger layers of multi-samples in one bank. As soon as you turn the dial to another bank of sounds, you can hear the voltage spikes as it’s trying to balance itself out. It happens too often when triggering at fast tempos. It’s almost like it doesn’t know how to handle the CV load.

I don’t think its (just) related to trigger/cv rates … I tested with USTA all the way up to audio rate trig/modulations on all 4 tracks… and could switch kits without issue (or any other issue for that matter)

perhaps you can detail a use-case where it crashes that others could try…

it would need to include :

  • kit used, factory kit, so we all have it (*)
  • bpm / trig pattern
  • cv assignments to rample … include rates/type of modulation. (**)

(*) the kit would also be reset, so we don’t have to dial in parameters.
(**) ideally produce without cv assignments, as again easier to reproduce elsewhere.

if you cannot reproduce, with a factory kit, and default parameters - then that points to perhaps it being something to do with the kit/samples you’re using… and that would be a huge hint in itself.

similarly , if you only get crashes when you introduce modulation, then this might start to hint where the issue is.

if others can’t reproduce with the same scenario (assuming its been defined clearly as above) , then that indicates its a likely hardware issue … be that, sd card, rack or rample.

unfortunately, when an issue is not being seen by lots of people, and it can’t be reproduced, its always going to be nigh impossible to fix … its a needle in a haystack.

@yratof , if its happening on particular kit, have you tried to reload the SD card… the (very) old firmware used to corrupt kits, and a corrupt kit would crash rample… (this is mentioned in the FAQ)
similarly, you might want to check its not something to do with the save settings on that kit.

Where can I access the original Rample samples if I format the card entirely? I can’t seem to find them anywhere beyond the SD they arrived on - then I can nuke it and push it to fail

where it says ‘zip package’, this is a link.

1 Like