rampleOS 1.21 - new firmware

Hey everyone !
rampleOS 1.21 is here !

This minor update fixes a few bugs, mostly related to saving kits and settings on the SD card.
To download this update, and for more details about the release, click on the link below:


1 Like

@Thibault_Squarp when I installed this , I repeatedly had it ‘hang’ after flashing with all red LEDs lit. then rample would not power up properly. ( i did this a few times with same result)

what I then tried, was deleting the save and _save directories, and re-flashed,
then it flashed correctly, and reboots are now ok - so all looks good.

I do not know if this ‘fix’ is coincidence or not, but perhaps worth a try if others have issues?!
(perhaps a corrupt/incompatible save? i don’t know)

tried to update and ran into problems as well. I even tried deleting the save and save directories before flashing and it would either get stuck at the end of the fw update as the screen is completely red or it would say no kit.

My deepest apologies, the uploaded firmware was the wrong one.
It should be fine now.

1 Like

@Thibault_Squarp when does autosave decide to save?

I find if I change to a new kit, and then turn off/on… most of the time it doesn’t save the change.
however, if I press listen on a few samples it seems to then save!?
(or perhaps it just takes a short while before it saves?)
seems a bit inconsistent… or perhaps just lack of my understanding :slight_smile:

^ This.
It saves when the module has been on the same kit for a while, and that it has time to safely perform an IO operation on the SD card.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.