Rample: Store function not working as expected

hi folks!

I recently got a Rample and i really like it and the kits on it, one thing however is very frustrating:
whenever i have customised one of the stock kits to my liking and i go to SETTINGS->STORE, instead of saving what i created, the Rample is reverting to the default settings of the kit. is there anything i am not getting or some global setting i have missed?
runing version 1.43

cheere
juju

Welcome to the community.

Which settings have you changed that you are trying to Save?
Are you using Save Settings or Store?
There may be a data corruption issue, so when things go ‘weird’ it’s my understanding the best practice is to reformat the SD Card and re-install the kits - and with a used device you may or may not be aware of its history, so that might be a valuable step. (Review the FAQ if you haven’t already FAQ | Squarp instruments)

hi there and thanks :slight_smile: i am trying to store the things like levels, cv-input assignemnts, and layer playback styles (random, cyclic, velocity).
i have tried both store and save settings, but when i hit store, my loose all my changes and the kit goes back to default.
device is brand new and i havent even taken the SD card out yet…

Ooops - sorry. Got this thread mixed up with the used Pyramid one. Yeah: new Rample. Got it. Sorry.

Okay, this is strange. It works fine on mine.
Usual things to check have been:

  • OS Version
  • SDCard data corruption
  • Store/Save confusion

The parameters you are changing, are these the parameters you access when you click the Main Encoder? Or are we talking about CLicking [Assign] then [1] [2] [3] or [4] twice, changing the Layer behaviour for that SP, and then Storing this “per kit” parameter? Or are you changing the Settings with the Main Encoder, scrolling to Layer, then Saving?

They are two different processes affecting two different settings.

Most people and many domesticated animals are quite a bit smarter than me, but I know that was the confusion I had (and often still do!) with the Rample. (Luckily it’s a set and forget device! Woo!)

1 Like

hey creepy pants, thanks for your help!
i have done a complete formant/ reinstall and it is still the same…

i am clicking [Assign] then [1] [2] [3] or [4] twice, to change say from RANDOM to VELOCITY for a particular sample in a kit. i can select it and it works as expected. when i then click the encoder and hit STORE, and all my changes are lost. howerver if i hit COPY, i can PASTE my settings later, but don’t seem to be able to STORE.
the same goes for levels of individual parts that i have adjusted pressing [Assign] + [Listen], then moving the respective pot, and CV-assignments. basically all changes that invove the [Assign]-button.

am i understanding it correctly that store would be the appropriate action to save this or what am i doing wrong?

cheers!

Im not at my rample right now to test, but will check later…

Is it just assignments or are other kit parameters not being stored too?
(e.g. layer mode)

what is Settings-> Assign set to ? (see manual settings )
Kit or Global?

if you want to do different assignments per Kit, then it needs to be on Kit not global.

this (global assign) feature was requested by users, and added in 1.30.
basically, some users wanted to always have the CV configured in a particular way, regardless of kit … eg. they wanted CV1-4 to represent Pitch 1-4. and did not want to have to set this on every kit.

let me know , how it goes with these… if its still not working I’ll test it out on my rample.

hi technobear!
neither assignments nor layer mode (which is actally the most improtant to me at this point) are being stored.

Settings->Assign was set to Kit already, i have changed it to global and back but no luck so far…

what i wanna do: have a kit eg. stock kit N0 to behave as follows: SP1 and SP2 should have layer mode VELOCITY, SP3 and SP4 should have CYCLIC
Rampe is being triggered with MIDI, but that is not so important, i want to be able to contol when my kick and snare sounds change…

cheers!!

ah, ok, it wasn’t clear you were using midi… rather than cv. (as you mentioned cv input)


ok, so I tested this… and its working absolutely fine here. (latest firmware)

basically what I did :

  • select factory preset C0 (its got good layers for this)
  • press assign, press b1 twice, select velocity, press main encoder
  • press assign, press b2 twice, select velocity, press main encoder
  • press assign, press b3 twice, select cyclic, press main encoder
  • press assign, press b4 twice, select cyclic, press main encoder
  • hit main encoder : STORE

then I sent in midi…
first sending in same velocity … t
check sp1/2 remain the same, and sp3/4 cycle :white_check_mark:

then sending in different velocities …
check sp1/2 reflect velocity :white_check_mark:

(you can also seeing the assign screen what layers are being triggered)

ok, so far so good :slight_smile:

switch preset to C1
I then checked the assignments were different - they were (all random)
(both via assign on sample and also by sending in midi)

switch back to C0,
again same midi test, and also I could see assignment were correct :white_check_mark:

did a power off/on… to just check it recalled these settings on power up
and indeed all correct there too :white_check_mark:


so looks like its functioning perfectly correctly for me.

so what I would do…

on the Rample SD card you will find a directory called
_save

this is where is saves all the settings.

what would be interesting :
is there a file called C0.rpl (or what ever preset you saved…)
this’ll tell you if its writing

(unfortunately, they are binary so we can’t really say if they are valid or not)

but no matter, the first thing I would do is delete this directory.
and retest… perhaps there is something odd going on with the preset you are trying to save over.

IF this does not work , as you are on the same firmware as me… I can only guess there is perhaps an issue with the sdcard (either reading or writing) , so perhaps try with a different sdcard?

its odd since, you’re reading kits ok … so thats a good sign.

so hopefully it’s just some oddity in the saved settings, and deleting _save will clear it.

The strange bit is that there aren’t really that many troubleshooting steps for the Rample that I know of - most seem to come down to user confusion, user error, bug/feature, or some incompatibility.

It would seem that you have a better grasp of Store/Save than i do.
You’re on the latest OS.
This isn’t a documented issue, and to the contrary, works brilliantly for everyone I’ve discussed this device with.

The only thing that my addled brain can come up with is some rogue CC or CV msg entering your system after you’ve done the Store function. (Don’t laugh, those of us less graced with grey matter have done it many times!)

So, just to make sure, I’d remove any MIDI or CV inputs and see if it duplicates.

so i have cleared the _save folder, didnt change anything! (didnt expect that either, have done two formatting/reinsalling sessions already, all according to Rample’s specifications)
also has started getting glitchy both in audio and sometimes at start-up freezes and needs a hard reset (power up with encoder pressed)

i am contacting Squarp now, and if they dont respond soon, i am gonna contact the retailer i bought it from and ask them what they think. wonder if i should get my money back or ask for a replacement… cos i a am in generall very happy with the build quality, the features, the samples. but this is costing me more time then the money is worth:(

really, this is not what you said previously…

if you had tried formatting, it would have been nice if you had told me that, and saved me a lot effort of explaining this, as Id have known this wasn’t the issue.


well, if you have the latest firmware, and you have tried with a new SD card (to eliminated the SD card),
and you followed my instructions for using store… then it should work, as the functionality seems perfectly fine when try it.

then I unforunately, think its a hardware issue…
(seems odd since its having no issue loading kits, I cannot see why write would fail)

indeed, you need to contact squarp via the contact form and/or get it replaced by the retailer.

Did anybody find a fix for this issue? i have the exact same problem: Store just resets my kit parameters to the default settings

see my post above… follow the steps.

if still not working you will need to contact squarp via the contact form.

as far as I can tell there is no general issue, so its either an issue on the sdcard, or a hardware issue (very unlikely, but always possible)

As i just bought it I will try to exchange the device. After a few tries of formatting and re-installing the newest OS the “store” option started to corrupt the kits i was trying to store. Really strange behaviour : /

1 Like

hmm, odd perhaps report as a bug to squarp via contact form, if you can find a way of reproducing it repeatedly?

hey all, havent responded as issue is still ongoing.
made a bug report to squarp which were super helpful and sent me a fresh SDcard right away. this however didn’t fix my issues, it remained the same. conclusion from squarp was that i have a faulty device.
squarp offered to send me a replacement, but i went through the retailer i bought it from, as i bought from them first time and wanna see what their service is like. when i have my replacement, i will give a shout here again

1 Like

I have the same problem, tried everything.Save kit reset to default parameter.Save seting
damage files.

hi all!
received my replacment rample yesterday and got round to testing it today. i can confirm that so far all i have tried works as expected:
i can save changes to kits, i can save my midi settings, wonderful.
so it was a faulty device, and from vincent’s and lukas85’s post i conclude that there might be more out there… hope you have as little trouble returning them as me!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.