Rample - SD card PC detection issue

Hey there, just got Rample and it’s fantastic with the preflashed samples.

However, i tried to upload my own on the micro SD via the adapter i got with it and my PC didn’t even detect the card. It’s not problem with my SD card reader, works fine on other cards.

Anyone had the same issue and knows how to solve it?

Thanks for advices in advance

micro sdcard used by rample is fat32 format
given the rample is able to read it (for pre-flashed) samples, that seems to indicate there is no issue with the micro sd card.

fat32 is supported by all (modern) versions of windows - out of the box.
(I’ve accessed the rample’s micro sdcard on windows 10, macOS and linux without issue)

so unfortunately, I’d say the issue is one of:

  • your microsd /sd card converter (unlikely)
  • your sd card reader
  • something with your windows setup

front a technical standpoint, you could look to see if the sdcard reader is recognised, then if the card is being recognised, or if windows is complaining about partition on the sdcard… but these seems unlikely.

but the easiest diagnostic is try it on a different computer.

I grant its very strange if your computer / card reader is reading other fat32 formatted cards.

the only other thing i can think of is… windows has an annoying habit of constantly thinking it has to ‘repair’ cards , when it believes they have been not unmounted cleanly (complete nonsense 99% of the time!) … so perhaps there is a popup somewhere when you insert it, that is waiting for this ‘repair’ … or you have some how disabled this… and its refusing to mount due to this?

also some versions of windows (and preferences) don’t auto-mount, they wait for you to say what to do with volume … but you would see the same with other cards that you say you can read successfully.


so today i’ve tried 3 other computers, 2 with windows and one Mac. On one of the windows it detected that the card is inserted and started some initialization or something. When that was over, no folder popped up (tried it more times with same result). Then the other windows couldn’t even detect it, like the first one, but on my roommate’s Mac it went without any problem.

I’ll try to upload the samples via their Mac now. Is it possible that the SD card was formated for Mac only?

It’s works fine on my Windows 10 machine.

What version of Windows are you running?
Have you tried a different as sdcard reader?