PyraOS 2.3 problem

I just updated to PyraOS 2.30 and now I’ve got nothing but a Start screen with the logo and version. Pressing any buttons does nothing. What am I missing.

Just connected to my PC and it says something to the point that an item connected to USB has malfunctioned and is unrecognizable.

Any ideas? This was working fine before the upgrade.


Have you tried flashing the OS again? That’s what i would do first.

Tried flashing four times, all with the same result.

What happen if you start Pyramid with no cables, only with the official power supply?

1 Like

tried with multiple cable connections including no cables but power. Same problem.

Is there a way to get an older version of the firmware?

Don’t know if it should matter but, this is a MK1.

Try a different SD card. Also try to flash an old firmware then update again if it works.

Been working with someone at Squarp for almost a week now. It works fine with V1.3 but, when flashing firmware V2.0 or higher, I get nothing but a Version screen. When you go through the Test Mode with these versions, it doesn’t recognize the touchscreen and that’s as far as you can get.

If anyone has had a similar problem, I’d love to hear what you’ve done to fix it.

I’ll post what I end up doing if it ever gets running correctly.



Turned out to be a touchpad hardware problem. Squarp were very professional in handling the return and repair. Thanks to Squarp and everyone for your help.

1 Like