Pyramid won't live-record CC [SOLVED]

I turn knobs on my Machinedrum and see CC messages coming in Pyramid’s MIDI input monitor, but nothing is being recorded. Checked the manual, no luck.

EDIT: This might be a bug. I can’t record CC coming from the same MIDI channel that the active track is assigned to. When I send the desired CC message from a different channel, I can then record it onto the active track. I can record notes from any channel without a problem.

Relevant settings:

  • Omni mode: Multitrack OFF
  • MIDI Echo: Stop echo
  • CC Assign: Autorec ON (changing to OFF makes no difference)

EDIT #2: OK, I understand how it works now. If you leave overdub recording on, it will keep recording the last CC value. Makes sense. That’s why it seemed like it wasn’t recording. I was probably just stopping recording before the loop.

EDIT #3: I think it would be nice if there was a setting to smart-disable CC overdub. Like it stops deleting events when there are no incoming messages after 50ms and then “wakes up” when another message comes in. That way you could truly overdub CC automation without clobbering existing automation.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.