Pyramid with Iconnectivity MIO 10 not triggering notes - solved

I’ve got a very simple setup: Squarp Pyramid connected to Iconnectivity mio 10 via the USB host port and a MacBook into the USB 2. DIN 1 goes out to a midi thru-box to an OB-6 (ch 2) and Prophet X (ch 3)

The clock signal runs fine, but I can’t get the Pyramid to trigger notes on my two synths. I have connected the Pyramid directly to the synths, so the problem is most likely that I don’t understand how to route the midi channels in the iConnectivity software. The manual didn’t do it for me.

I would like the Squarp Pyramid to start/stop the Logic sequencer AND trigger notes on my synths, but I can’t figure out how to make it happen.

PS: I am connecting more gear to the Mio, I just figurered it would be less confusing making two synths work initially.

I’m probably overlooking something basic here, and it’s driving me nuts.

PS: I have posted the exact same question on Reddit:

“I have connected the Pyramid directly to the synths,”

When you connect the synths directly to the Pyramid, does everything work as expected or do you run into the same situation?

If it works as expected in that scenario, it sounds like the problem is in your Mio - check the documentation there.

1 Like

Thanks for answering. When connecting Pyramid directly to the synths, via the din-ports, it works as expected, but I have not made it work using midi over usb. Since Pyramid connects to Mio using usb I’m not sure where the problem is.

You can try hooking up Pyramid to a computer via USB and use a DAW or MIDIOx to monitor.

Since you get clock via USB, and i dont think USB MIDI Clock is a default setting, then I assume you are familiar with Settings in the Pyramid and are properly creating Tracks with their Channel and Port settings.

I use the USB MIDI In/Out on the Pyramid with no problems, but i do not use a Mio (i like them and could use one, but havent pulled the trigger yet). Have you set up the routing on the Mio properly and/or posted on iConnectivity forums?

1 Like

The midi in/out (din-ports) works perfectly, it’s just really annoying that I can’t make the usb to Mio work. I’ve set up tracks corresponding to the midi-channels on the synths, and since it’s working via the din-ports I’m pretty sure the problem is related to the (lack of) routing in the Mio software. I will post the same query in the iConnectivity-forum, was just hoping someone in this one had experience setting up the Pyramid with Mio.

Edit: actually, I can’t get any of the synths works directly connected to usb either…so the problem might be me;)

Makes sense.
Plenty of people here who use Mio, Im sure. Its just not always a high traffic forum.

I hope to be using a Mio soon. If the results of my latest loopback test works then I’ll definitely need a one. Heh

1 Like

Well, I’m glad you bothered to answer and give me some pointers. Thank you for that:)

Are you sure that you have selected usb midi channel/port in the track channel setting?

1 Like

Thank you for answering. Yes, the track midi channel corresponds with the channel selected on the synth. It’s a mystery…

And usb on the Pyramid is set to send clock and midi out

I have the same setup. Did you select the correct midi channels on your squarp? Usb channel not midi.

2 Likes

So in track mode, on the display where it shows cv, midi a, midi b, usb; usb is highlighted?

1 Like

That’s the basic setting I overlooked in the manual…thank you so much! Problem solved and now I feel happy (and a lttle dumb):wink: Thank you so much!!!

2 Likes

That’s it. I never noticed the different categories above the MIDI-channel. Thank you so much for helping me out :slight_smile:

1 Like