Pyramid’s “USB Midi Thru” capabilities

Hi everyone!
Already sent this q to support, but maybe someone here is familiar with this topic.

I’ve set my Pyramidi to control “keypads” from notes received from channel 13 and made my MatrixBrute’s local control off and the out channel set to Channel 13. Doesn’t work with Echo protection either on or off, it doesn’t seem to matter.

They are connected through the BomeBox and both Pyramid receives the notes from MB (at least there is an icon for “USB in” receiving something when I press the note on MB) and the MB receives and plays the notes if played on smartpads.

What I can’t seem to make it do is to relay the notes from channel 13 to the selected channel/track. Pyramid just receives and keeps them to itself.

Please tell me I can do that and am just missing something. That’d be really cool!
Software v. 2.3, hardware v. 150.

I think that in theory it should work - I am able to record my other synth’s parts a way like this.
It is on channel 2 on both in and out, and I can record notes played on it straight into pyramid as a sequence.
I can’t understand what I am doing wrong or missing on…

To see whats going on in the Pyramid, you can go check the MIDI Input and Output monitor.

Settings -> Info -> Scroll down :wink:

2 Likes

That’s exactly the question – there is the input, but no output.
When the instrument is set up to record itself on the respective channel of Pyramid- everything works fine. As soon as I try to make Pyramid to receive the notes on Pyramidi and turn them into keypad presses in Live mode - it doesn’t.

For example:
Synth out (USB, Ch 1) -> Pyramid USB in -> track 1 (USB, Ch 1) -> Pyramid USB out -> Synth in (USB,Ch 1), works great, but only for one instrument.

Trying to connect a “master keyboard”:
Synth out, Local off (USB, Ch 13) -> Pyramid USB in (Pyramidi on Ch 13) notes are received on Pyramid, but are not going anywhere further.

@psypad - Have a look at the Omni Mode setting, it defines how the Pyramid routes incoming note events. As I understand it, Pyramidi sets the channel on which the Pyramid will respond to various CC messages which let you control the device remotely (e.g. mute tracks, select sequences etc.).

When I first got my Pyramid, I wanted it to play notes from my Keystep to the synth on the current track, but only on a particular MIDI channel. I thought that the Pyramidi setting would do this, but couldn’t get it to work no matter how hard I tried. After re-reading the manual several times, the penny dropped and I set Omni Mode to the channel I wanted (CH03) :grinning:.

1 Like

Thank you!
Will look into the Omni mode.
For some reason I always forget that Pyramidi is a whole other thing…
But at the same time, there is an option “Assign Note to - Keypad”

edit:
According to manual, Omni mode “off” is exactly what I am looking for.:thinking:

edit 2:
But then what does assign note to do?..
I’m confused…

Assign Note tells the Pyramid how to handle the note events, as though you were in live mode e.g.

Keypad - Treats notes as though you are playing the top 2 rows of pads (i.e. passes notes through).
Smartpad - Treats notes as though you are playing the bottom row of smart pads (e.g. single note will generate a chord if that’s how they are set up)
Etc…

After a bit of experimentation it seems you need to turn off Pyramidi (or set it to a different channel) to let notes from the MB through. Notes on the Pyramidi channel seems to be swallowed up so they don’t get forwarded…

1 Like

YES!:tada:
Changing keyboard’s “Out” channel from Pyramidi’s channel did work!

Looks like I got in a bit of a loop in my experiments with settings and was unable to get to where I wanted on my own.

Thank you very much for your help, @drGrov!
I love forums.:joy: