Pyramid - Play / Record Buttons Stopped Working


#1

Last night I was working on adding some Program Change tracks to my two sets and my Pyramid’s Play & Record buttons stopped working. (submitted a ticket to squarp.net/contact) Logging my processes below in case anyone else runs into something similar and needs a quick solution

Here’s a video: https://www.youtube.com/watch?v=sMAH5pKpe-Y&feature=youtu.be

What isn’t working:
Pressing Play (Live/Step/Track/SEQ)
Pressing Record (Live)
When in TRACK (Record light is low-lit)

What I’ve tested:
I backed up my files, formatted the SD card, rebooted the latest OS: that didn’t work
I also booted back up the OS which was the latest Beta right before the V3: that didn’t work
I can trigger “Play” from Ableton / Keystep
I Formatted a new SD card and booted 3.0 with it, still the same issue so it isn’t a bug from a project file
I tried starting Pyramid holding down FX to reset to default settings

Workarounds

  1. I know Ableton will work but don’t have table space for a laptop & Pyramid so I’ll recreate my set in Ableton as my backup
  2. Loopy iOS app allows sending midi start/stop so I’ve got a iOS USB camera connector to a USB midi cable going to Midi In on the Pyramid, this is going to be my Option A if I can’t get this bug resolved by Sept 1 (show)

#2

Have you tried removing the Program Change messages?
Have you tried removing all your hardware/midi gear? Maybe there’s a feedback loop…
If that works, slowly add all the gear back until you find the device that’s causing the issue.
Are you using a foot pedal to control start/stop? Maybe something stuck in the pedal input?

I’m just throwing ideas out here.

I hope you’ll get it sorted out. I know how you must feel with the show coming up.
Good luck and all the best!


#3

Thx @maximee yes I tried removing the PC’s.
I grabbed a fresh SD card I had and formatted it w/ Pyra 3.0 on it and did a boot and then held FX down and did a boot to reset to default settings (all of this with nothing hooked up to the Pyramid). So, no feedback loop happening.

Thanks for the tips tho, I appreciate it cos it’s easy to forget something when you’re scrambling to fix a bug!


I’m in touch with Squarp now and sent over all my details, I’ll keep this thread posted.

I will say that last night in a less than 4 hours I was able to take my two projects and load them into Ableton and recreate my entire set in Ableton working off of looking at the SEQ mutes… One thing I absolutely love about this machine is the ease of working like this. Now I have 2 backup plans and a Ableton template for my rig I can use in the future to reverse map my sets back into Pyramid so, silver lining, documented a solid workflow :slight_smile:


#4

Sounds like you’ve tried all you could – I’m out of ideas, sorry!
Glad to hear you’ve found a workaround for your situation. Let us know how/if this resolves.
I listened a bit on your soundcloud, I liked the latest track!
Keep it up & enjoy your gig!


#5

Quick update here. I spent a few weeks working with the Squarp team to see if we could debug the issues I was running into. In the end I had to ship my Pyramid back to them to look at. This weekend I got a package in the mail and surprised to have gotten a brand new Pyramid.

I haven’t sync’d with them yet on mine, but I imagine the bug / issue was going to take a while to solve and instead of me being w/o the Pyramid any longer they decided to replace it. Much appreciated as I do play out and was missing having it.

From first contact to getting a replacement, this company is ace in customer support!