Pyramid keeps resetting velocity to 0


#1

Hi - don’t know why this is happening, but the Pyramid keeps resetting all my track velocity settings to 0. I can go to Step, turn the velocity back up to 127, then press Step again and it instantly resets to 0. It also resets when I click on other tracks.

Don’t know if there’s a setting where velocity is set globally or maybe I’m getting some odd Midi signals changing the velocity (have a Z1 keyboard as the controller keyboard), but it’s infuriating - means I can’t use the pads for playing stuff until I keep going back to Step and changing the velocity.

Any help would be appreciated thanks.


#2

Sounds kind of like how my midi keyboard has messed up velocity, though for me I have to play a note for my step velocity to change. Try to recreate it with nothing going to the pyramids midi in and then try with a different controller keyboard, that should show you where the problem is


#3

Thanks for the help - but just tried it again without any Midi input and it still resets to 0 when I switch to Track mode and then back to Step mode.

I might just start again from scratch with a new template - I might have accidentally recorded some Midi messages or something.


#4

My diagnosis is your shits all fucked up


#5

i had some similar things happening, turned out i accidentally touched the touchpad’s left corner and set the velocity to 0


#6

Thanks - I’ll see if I’ve accidentally set something with the touchpad. I’ve tried loading different older projects & the same thing happens with velocity constantly resetting to zero.


#7

I think you’re right!


#8

Thanks for the touchpad tip - have played around with it, setting velocity to 127 via the pad, and it seems to have stopped glitching to zero! Fingers crossed that was it.


#9

This. I have to really think about not resting the palm of my hand on the touch pad especially when editing piano rolls. I’d turn it off if I didn’t find it useful for drawing CC’s.


#10

I actually tape my set list guide over the touchpad in live shows to avoid my wrist messing up the playback. Sadly I prefer this safeguard to the live fun of the touchpad.

Happens all the time.


#11

Yes, I wish touchpad to velocity could be deactivated in settings, maybe we should ask a feature request?

Done!

http://squarp.community/t/turn-off-touchpad-velocity-in-settings/1289?u=darenager


#12

Thanks for all the replies - good (or actually not so good) that others are experiencing issues with the touchpad velocity. Hopefully Squarp is listening…


#13

This was brought up on the old forum, so…


#14

Squarp very kindly got back to me - you can actually deactivate the touchpad by going to Settings > Misc > Touchpad > Off. It’s a global setting but at least you can deactivate if it’s messing up live gigs etc.


#15

Yeah you can, but it’s on or off for the whole thing, not just one input for one parameter. I did mention in my first reply that I chose not to turn it off because of drawing CC curves using it is brilliant compared to setting a start bar and a finish bar then letting an algorithm make the curve for you (MV8000 way of doing it).


#16

Ah cool - yeah I’m still finding my way around it, so didn’t realise. I have yet to try drawing CCs with the pad, so will do that later. Thanks!