Pyramid freaking out after midi input overload

I have found a strange bug while using my Pyramid.
I use my pyramid with my Nord Lead 3 as a master keyboard and a dsi Mopho both on channel 1. Sometimes, while playing/recording, my Pyramid starts freaking out, it takes velocity data from my keyboard and sends it to my Mopho and if i move one of my encoders (nord or mopho) he sends midi cc data to al the parameters.

I’ve been able to recreate this by recording a loop with a bunch of midi cc automation while using my Nord. I assume midi channel 1 is overloaded and the pyramid sort of crashes.

I have tried this on both v2.3 and v2.0 and both did the same thing. Has anyone ever experienced the same problem?

thanks in advance, Willem

Definitely not a midi loop ?
What’s connected to the midi in/out and USB ?

no midi loop I’m aware of, I have:
Pyramid midi out -> midi splitter -> nord lead and dsi mopho midi in
nord lead and mopho midi out -> midi merger -> midi in Pyramid.
I have turned off the external midi cc control in my mopho and the problem has occured less

I would personally try removing the midi merger and see if that rectifies…
I wouldn’t necessarily blame the Pyramid… remove that from the equation… (midi thru box > midi merge box) and you have a perfect loop if I’m understanding correctly

Totally sounds like a midi loop to me.

If I understand correctly and you’re merging the Mopho and the Nord outs to go back into the Pyramid that’s a problem.

Somehow clock is being looped. The pyramid wouldn’t be freaking out if there were not a loop.

I’ve encourntered a number of these, and been baffled by some of them, and solved others. They are frustrating, and I don’t like them at all.

I have not always been successful turning clock off, or switching the pyramid settings to not listen to clock. The worst example of this was the Beat Step Pro.
I wanted to use it before the Pyramid so that it could enjoy all the possible sound sources, but I did not want to use it as the master start stop/clock.
I tried everything to get it to sync without looping midi clock. I sold it. When a new firmware came out, everyone said “Oh dude, it’s totally fixed!” so I bought it again… No dice. Sold it again.
So frustrating.

To solve the Octatrack clocking problems I had with wanting to send a controller into the Pyramid in order to access sysex and CC data from a remote fader device I found that even in a device I wasn’t sending any clock from it was causing problems - stuck notes, and all sorts of hassles.
So I moved the controller further down the midi chain, and put the merger between my 3x8 midi breakout box and the octatrack and it’s fine now.

The mopho is most likely the culprit here. But it’s possible that the nord is also sending something which is looping too.

Try taking the mopho out of the loop and see if that does it?
Try moving the mopho down the chain a little, and if you can help it, don’t bring it’s output back into the pyramid.
Clocks and loops are a drag. Hardware doesn’t seem to play well without a clear master clock.

Please try taking the mopho out of the loop, and report back here.
I’d love to help if I can.

I’ve tried several configurations and it is indeed the merger that is causing al the problems. No bug in the squarp and probably a midi clock problem.


What MIDI settings have you set on the Pyramid regarding MIDI THRU? Have you thought about maybe removing the splitter and using the two independent MIDI outs on the Pyramid? Are the two synths set to THRU any MIDI on their output ports?