Polyend Medusa MIDI OUT to Pyramid MIDI IN Problem

Hello… I seem to have an issue with the MIDI OUT from a Polyend Medusa (Firmware 2.01) not working with the MIDI IN on a Pyramid MK2 (pyraOS 3.22). This is just an issue with the 5-pin MIDI DIN connections; the USB MIDI seems to be working properly with the Medusa.

The MIDI OUT on the Medusa is working fine when I send it to other sequencers like the Korg Electribe 2, Elektron Model:Samples, and even an old Yamaha QX5. It also works when I run it into a Waldorf Pulse 2. For some reason, the Pyramid acts like it’s not receiving any MIDI signal at all from the Medusa. I know the Pyramid is working correctly because its MIDI IN receives MIDI OUT just fine from an Arturia Keystep. So, the Pyramid MIDI IN seems to work with other devices, and the Medusa MIDI OUT seems to work with other devices, but when I connect the two together, it’s as if there is no connection.

The Pyramid MIDI OUT to Medusa MIDI IN seems to work correctly.

I’ve tried swapping out MIDI cables, confirming that I have all the correct connections, changing MIDI channels, making sure there’s no MIDI filtering on, toggled Echo on the pyramid, etc. without any luck.

Has anyone else had similar experiences with these two devices? Any ideas on what I could try to fix the issue?

Thanks!

It’s probably a similar hardware-level issue as discussed in this thread for various other gear: Pyramid incompatible with M-Audio?

The short version is that either the Medusa is low on power to transmit sufficient voltage on the MIDI line, in some cases powering with external power supply instead of USB has helped. Or there’s a hardware-level incompatibility (which shouldn’t exist, MIDI being a standard…) that can be worked around by adding a MIDI-thru box or similar.

Thank you so much for the quick suggestions! I always use an AC adapter for powering the Medusa, so I don’t think that’s the problem. Based on your advice, I tried using an old MIDIMAN MERGE 2X2 and a MIDIMAN 2X2 USB MIDI interface that has a THRU feature and neither worked, even when I connected external power to the MIDIMAN boxes.

I did try running the MIDI OUT on the Medusa into the MIDI IN on my old Yamaha QX5 sequencer, and then connecting the MIDI THRU on the QX5 to the Pyramid’s MIDI IN, and that seemed to work! So, I have a workaround but it’s a bit cumbersome. I assume I could also get it to work by putting other boxes that have MIDI THRU jacks between the Medusa and Pyramid.

As others have stated in thread you linked to me, this appears to be a case of one or both devices (Medusa and/or Pyramid) not adhering completely to the MIDI spec. It could also just be an issue with the particular boxes I have so I’m curious if others are also seeing this problem with the Medusa/Pyramid combination.

Thanks again!!!

I don’t have a Medusa, but the same thing happens with my Moog. I have to put some kind of device between the Moog and the Pyramid - this is whether I use the MIDI / USB ports of either device. If I put the signal through a MIDI monitor, there are no extra / missing bytes. I wonder if it’s a clock rate thing - i.e. Pyramid’s frames are not lining up with the expected input, and aliasing…and somehow powering the other devices adds the extra frames needed to be in sync. The only solid experiment I can think of is to see if inserting a passive Thru box fixes it…which would rule out under-voltage.

Interesting, thanks. I tried a passive MIDIMAN MIDI THRU and MIDI Merge, and even applied power to the MIDI Merge and none of those boxes worked. I’m kind of wondering now if a passive MIDISolutions MIDI THRU box would do the trick.

UPDATE: I got ahold of a passive MIDI Solutions MIDI THRU box (1 in, 2 out). It does not work as a bridge between the Medusa MIDI OUT and Pyramid MIDI IN, unfortunately.