Pads are too brightly lit 😀

This was discussed a long time ago, in the old forum. I think we were going to ask Squarp if there could be a control for this! Not for all, but for some of us, there is the issue of the pads being too brightly lit. It’s the brightest thing in my small studio, and lights up the room as well as blinding me! :grinning: Does anyone else find this? I once bought some sticky back plastic that toned down the brightness. But it wasn’t that sticky. :grimacing:

1 Like

yeah, I’m super sensitive to LED’s to the point where I won’t buy stuff that has lots of flashing lights. I get weird dull headaches from them, and occasionally migraines. So something like the Deluge is out of the question :slight_smile:

I’m with you. Wish there was a low illumination setting or something.

If gear has LEDs that aren’t really essential (like glowing USB ports and such) I open things up and tape over them with electrical tape. and for overbright displays, including the Pyramid’s, I’ll use dimming gels like this:

I haven’t opened the Pyramid, but I’ve definitely considered it. Lemme know if you find a solution that works.


Good idea about the dimming gels.
I also would love a way of dimming the LEDs & screen. Ideally, that would be a setting in the SETTINGS menu.

1 Like

The sticky back plastic I used previously came off too easily, The Dim It Light Dimming Sheets look interesting… I think we will have to ask Squarp to listen to us. We need a control! :grimacing:

I completely agree, I’ve done few performances with the squarp and it has been significantly brighter than my other electronic instruments. It’s significant enough that if I know I’m going to be playing in a dark venue I will actually use other sequencers. I think a brightness adjust feature would go a long way…

Yes! Eye strain is a major element that makes me tired sooner than I’d rather be! The question is how to get the message across. Looks like I’ll be pestering Squarp with an email.

Squarp themselves asked for all feature request and bug reports to be sent to them via email.
So dont worry! i think they are happy to respond :slight_smile:


Even better… We all email Squarp. If we really want them to listen to our opinions. :slightly_smiling_face:

1 Like

I actually wanted to order…
now, I really do have problems with too harsh lights (impossible for me enjoying a concert with washer_lights pointing into the crowd, really - I have to leave then. Same with diving in the night:impossible)
hoping for a ‘dim’ - function in the preferences menu!

An adjustment would have been a cool idea…

I have played an awful lot of sets with the Pyramid, and it’s great in the dark. Not too bright for me.
In the twilight, or the daytime it’s very hard to see what’s going on. I actually often resort to sunglasses in order to see what’s going on.


1 Like

Got answer from squarp.
They wrote positively about it… guess they´ll build it in soon,
(after this is no biggy after all, too)



its not because a feature is simple for the end user that it is just as simple to implement
“no biggy” might mean significant changes codewise.

in the past Squarp has already made the LEDs more dim, can you imagine that it was actually worse than this?
I could be wrong, but I think the problem probably is that they are dimming the LEDs digitally (software PWM), which means that it can have impact on CPU performance and hence timing of the Pyramid. Dimming the leds just means a different frequency of LED flicker, and is not that nice as dimming them electrically.

I heard back from Jean at Squarp. He kindly said they will see if they can build in some control for a future update. In fact, the next he said, perhaps ambitiously(?) Meanwhile I’ve got some Lightdims and will see how that works out.



Now if only politicians kept their promises like Squarp do. Wonderful update 3.1. LED BRIGHTNESS = NIGHT MODE (enable white leds low luminosity for night uses).


I’m enjoying the lower level of brightness since the update! The only problem now is that muted notes are not that easy to see, in Step Edit. The muted notes look too similar to active notes in terms of brightness. :thinking:

That’s a limitation of the hardware. You only have so many usable brightness levels. I guess you can’t have all.

… or start looking COOL and get sunglasses :smile:

1 Like